Jump to content

FAQ: Hitman C47 is running too fast !


  • Please log in to reply
24 replies to this topic

#1 Bert

Bert

    Gordon Cole

  • Super Moderators
  • 10741 posts

Posted 17 October 2006 - 05:50 AM

Q: Codename 47 runs way too fast. How do I fix this ?
A: This is a problem that is often encountered when using newer computers. The Codename 47 software conflicts with the new computer's software and causes the game too speed up. IOI has released no patch to fix this issue.
There are a few alternate ways.

Like I've mentioned before, my game runs way too fast. I did a small test:

In the beginnin just after you've talked to Gontarro, walk to the door on your left and turn 180° to face the arches.
I walked the distance to the left base of the arch in 8 seconds, and ran the distance in 2.2 seconds. Nice speed, huh. :o

Anyway, when trying this out, I started a new game (all my old testings was done loading a saved game)... and... the speed was back to normal. Yeah!
Load a game = Too fast
Start a new game = normal speed. I'm sooo happy!

I guess it must have had something to do with me playing a few levels on Win98 before upgrading to XP.
Black no.1 -- you had the same problem and you mentioned both Win98 & XP... maybe this'll fix it for you too...


I fixed it, but the only way I found was to enable the debug console.

Open hitman.ini in the install folder, append "enableconsole 1" to the bottom and save.
Start the game, hit "`" (also the "~" key) and type "IP_TIMEMULTIPLIER .99" and hit enter. Then escape the console by hitting "`" again.

Wierd, even though it's .99 it still fixed my problem.

EDIT: I also have it set to run in compatibility for w95 (that might help as well).


Please ask here if this doesn't help you.
You remind me today of a small Mexican chihuahua

#2 HitmanamtiH

HitmanamtiH

    Thug

  • Members
  • Pip
  • 16 posts

Posted 18 October 2006 - 12:04 AM

My preocessor is Intel® Pentium® M processor 1.73 GHz
512 RAM , 80G HD and I have no idea what my videocard is....

Ok, I've tried the "ip_timemultiplier" thing which did not work, the patch didnt work either because it corrupted everything and using the "turbo thing" didnt work.

Edited by HitmanamtiH, 19 October 2006 - 07:23 AM.

  • 0

#3 HitmanamtiH

HitmanamtiH

    Thug

  • Members
  • Pip
  • 16 posts

Posted 19 October 2006 - 04:49 AM

hello!!!! Could anyone please tell me whats wrong?
  • 0

#4 Bert

Bert

    Gordon Cole

  • Super Moderators
  • 10741 posts

Posted 19 October 2006 - 10:59 AM

hello!!!! Could anyone please tell me whats wrong?


Please don't be rude. If people don't answer, it's because they don't know.
Try to use the search function in the meanwhile.
You remind me today of a small Mexican chihuahua

#5 HitmanamtiH

HitmanamtiH

    Thug

  • Members
  • Pip
  • 16 posts

Posted 19 October 2006 - 11:23 AM

That didnt come out right... :o Sorry...but anyway i tired every single thing but still nothing happened
  • 0

#6 Bert

Bert

    Gordon Cole

  • Super Moderators
  • 10741 posts

Posted 20 October 2006 - 02:45 AM

That didnt come out right... :o Sorry...but anyway i tired every single thing but still nothing happened


No problem, have you already tried to set your XP compatible with Win95 ?
You remind me today of a small Mexican chihuahua

#7 HitmanamtiH

HitmanamtiH

    Thug

  • Members
  • Pip
  • 16 posts

Posted 20 October 2006 - 09:17 AM

How do i do that???
  • 0

#8 HitmanamtiH

HitmanamtiH

    Thug

  • Members
  • Pip
  • 16 posts

Posted 21 October 2006 - 07:15 AM

How can i put the XP compatibility to Win95??? (Hitman is too fast...) :S
  • 0

#9 Stingray Anderson

Stingray Anderson

    Thug

  • Members
  • Pip
  • 19 posts

Posted 21 October 2006 - 07:19 AM

It's easy so dont worry. Find the .exe file in the program files. Right-click on it and click on properties. Go to the compatibility tab. Check the box that says "Run this program in compatibility mode for:". Once you have done that a drop down box will activate and you can click and select win 95 from that. Click apply and then ok and you are now running it in Win 95. Be aware that you might need to do this with the icons aswell.

Stingray Anderson
  • 0

#10 HitmanamtiH

HitmanamtiH

    Thug

  • Members
  • Pip
  • 16 posts

Posted 21 October 2006 - 07:23 AM

Thanks a lot :o
  • 0

#11 HitmanamtiH

HitmanamtiH

    Thug

  • Members
  • Pip
  • 16 posts

Posted 21 October 2006 - 07:35 AM

Ok i changed the compatibility but still is as fast as it was before
  • 0

#12 Bert

Bert

    Gordon Cole

  • Super Moderators
  • 10741 posts

Posted 26 October 2006 - 03:22 AM

Merging this with the sticky :(.
You remind me today of a small Mexican chihuahua

#13 Katana

Katana

    Professional

  • Members
  • PipPipPipPip
  • 326 posts

Posted 22 November 2006 - 09:24 AM

My problem is that i couldn't change the speed to be perminent while using the ip_timemultiplyer command - i changed it for one level which worked fine, then a few missions later it was too fast again. And .99 didn't work, i had to put .75 and recently .6

Also, maybe unrelated, but before the lee hong assasination mission (and a few others), if i click to view information on the guns i can buy it is blank and just has the background of the laptop, but i can view the items (binocs, compass).

EDIT: Ok, now i've realised the game seems to speed up again everytime i view my map or the mission status - which is very annoying.

I played C47 on my old computer (666mhz intel pentium 3 processor, 512mb Ram, very crap nvidia riva tnt2 pro grahics card (it actually fucked up when i installed more ram, which caused it to randomly reset the computer when i would do things like play games and watch videos), windows XP service pack 1) and it worked perfectly without any stupid sound and speed errors.
Now i recently bought a new laptop (1.8ghz amd turion processor, 512mb Ram, decent ATI radeon express 200m series graphics card, and xp with service pack 2) and this is where the stupid speed error kicks in.
Now if people who are experiencing the same problem can compare their computer specs to those of my laptop then maybe we can nail the thing that is causing this error by looking at the things we all have in common.

I have also tried to run the game in compatability mode (windows 95/98 etc) but the game doesnt start when i choose these.

Edited by Katana, 22 November 2006 - 09:27 AM.

  • 0

#14 Stoney

Stoney

    Pickpocket

  • Members
  • 2 posts

Posted 16 August 2007 - 01:01 PM

http://weblogs.asp.n.../21/428192.aspx

Just run this program in the background while playing the game. It works great for me! :good:

This program simulates excessive CPU usage, so the game runs slower.
  • 0

#15 Regy

Regy

    Gääh

  • Members
  • Pip
  • 11 posts

Posted 12 March 2008 - 07:28 AM

The "too fast problem" is caused by too high fps in game and with newer PCs you have high fps because vertical sync is off. When it's off, your fps won't be limited and with new PCs fps will just be too huge for Hitman 47. When you turn vertical sync on, fps will be limited to 75, 60 or something nearby that. I don't know how vertical sync works with ATI cards but at least I can explain nVidia ones.

nVidia cards:
First open your nvidia control panel, right click your desctop and select NVIDIA control panel. In the left bar you should see different sections, find one called Manage 3D Settings. There you can see Global settings and Program settings. If you want your every game to have vertical sync on/off, you can select it from the Global settings. But if you want to just turn vertical sync off/on (in this case on) only for Hitman, go to Program settings and find your Hitman.exe (you might need to search it from your computer using the Add key). Now your vertical sync should be set on :(. All nvidia cards aren't same so finding the control panel might be different!

Here's some pics that'll show ya what to do:
step1 - http://img84.imagesh...853/kuvamf4.png
step2 - http://img99.imagesh...59/kuva2uc6.png
step3 - http://img99.imagesh...38/kuva3yg9.png

If you just can't find your control panel, download newest drivers for your graphics card. You can also try setting maxed graphics but with latest PCs I doubt that will work. Hopefully someone will post a version for ATI cards as I don't own one/ever had one, or you can just try to google for ATI help. And you shouldn't need to change your compatibility to 95/98/2000 or use any background programs. Compatibility problems are only seen in Vista and in that case you should change it to XP. :good:

Katana is a good example here, his C47 worked perfectly with an old PC, just because it didn't have that big fps, the PC just couldn't have. But with new ones, you know what happens..

Edited by regr, 13 March 2008 - 02:06 PM.

  • 0

#16 joebbjoeby

joebbjoeby

    one post wonder

  • Members
  • 1 posts

Posted 27 August 2008 - 07:57 AM

To Fix the Game Running too fast in Microsoft Windows VistaSP1 / XP.

Locate the Game's .Exe File.

Enable compatability Mode by right clicking > properties > Compatability.

Set it to Run in compatability Mode for Windows 95 or 98/ME.

Finally make sure the checkbox labelled "Disable Desktop Composition"

Now click apply and then OK.

Run the game, You should now find that the Framerate is now Much lower and playable.

(if this does not work try checking the box that says "Disable Display Scaling on High DPI settings" as well as "Disable Desktop Composition").


Do not use the CPU Program that "Simulates" Processor load, I have read through the site and the Program actually does Put Stress On your CPU.

---------- -------------------- -------------------- -------------------- -------------------- -------------------- ----------

I am Running a HP Compaq 6720s Notebook
Microsoft Windows Vista Home Premium SP1
1.73GHZ Celeron M
1024mb DDR2
160GB Toshiba HDD
Mobile Intel® 965 Express Chipset Graphics

I found this out playing around with compatability options and it worked fine for me, Keep in mind that everyones hardware is going to be different so this may not work for everyone.

Edited by joebbjoeby, 27 August 2008 - 08:07 AM.

  • 0

#17 Windows

Windows

    Henchman

  • Banned
  • PipPipPip
  • 152 posts

Posted 01 November 2008 - 07:24 PM

I have this problem. i run codename 47 on windows vista which means that the sound track at the main menu is completely different to the original soundtrack. There is also no sountrack playing when I play any of the missions on c47. If the game runs too fast I just start the game again.
  • 0

#18 sgg847

sgg847

    Shadow

  • Members
  • PipPipPipPipPipPipPip
  • 2152 posts

Posted 21 December 2008 - 05:43 AM

I always use this way.
1. Open folder with game.
2. Find file SETUP.
3. Choose OpenGL or Direct 3D (I often use OpenGL because it better for me) - it is not important.
4. Choose your window mode (full or no) - it is not important.
5. And now change resolution. Choose anyone and press Start Game.
If you see that intro fast (EIDOS must fall at the same time with sound!) > leave game and choose other resolution (from simple till 32 color).
6. If you see correct screen (EIDOS must fall at the same time with sound!) you got standart. If you want change resolution do it in game option.

Edited by sgg847, 21 December 2008 - 05:43 AM.

  • 0

37635e701989.jpg

------ Never Surrender ------

Gamepad settings for PC


#19 merck

merck

    one post wonder

  • Members
  • 1 posts

Posted 25 January 2010 - 09:11 PM

Okay i've looked for the solution all over the internet without any luck.
I've already tried everything posted on many sites on the internet (I've spent almost 4 hours looking and testing many configurations within the windows).

And i had an idea. And it used to be a solution for me. I Guess it will be to many users from now on.
I run a Core 2 Duo Windows 7 64 bits version.
The trick is just use this little program to limit the fps inside the game, works for both the game itself and the movies.

FPS Limiter
http://rapidshare.co...Limiter_0.2.rar

It works only with games running by DX8, DX9 and OpenGl renders.
So used it with Hitman. It's very simple.

You need to have Java for the GUI.
Open the FPS_Limiter_GUI.jar, choose your renderer, mine is OPENGL, so OGL in the dropdown menu.
Locate the hitman.exe into the games folder. Then put the fps amount into the maximun fps box.
i use 30 or 60. Do Not click to log or OSD. Cause it usually crashes.
Click in Create Bat. And the Hitman.exe.limited.bat will be created into the FPS Limiter folder.

For my OS i needed to put this little bat file into Compatibility Mode -> WINDOWS XP (Service Pack 2).
After run it, maybe you won't need to put it on compatibility mode, so just try.
And guess what, game is working like a charm.

NO CPU STRESSING PROGRAM, NEITHER LITTLE TRICKS INSIDE THE GAME.
Maybe this will help many people.
I would like a feedback if it worked for you people. If it's too confusing, i may try to make a Tutorial.
Thanks
  • 0

#20 Chubaka

Chubaka

    Henchman

  • Members
  • PipPipPip
  • 189 posts

Posted 27 January 2010 - 12:47 PM

I had a similar problem with Freedom Fighters. The game ran at like 10x normal speed, and then after like 15 seconds, crashed. The trick that worked for me was to start the game, minimize, and set the affinity of the .exe in the task manager to a single core.

Posted Image

(Paradoxical!)

Edited by Chubaka, 27 January 2010 - 12:48 PM.

  • 0