Jump to content

Huge problems! failed to initialize directx 11

Directx 11 Failed Problem Directx11 Initialize

  • This topic is locked This topic is locked
18 replies to this topic

#1 Johnsjoden1

Johnsjoden1

    Pickpocket

  • Members
  • 4 posts

Posted 25 November 2012 - 05:56 AM

I have update "beta" drivers for my ATI video card : sapphire amd radeon hd 6850. Should work fine. never had this problem with any game before!

Error 3 : Failed to initialize Directx 11

If anyone knows a solution on this problem please post it here. I'm getting pretty annoyed with this.

My computer isn't old or so.

Amd phenom™ II X6 1055t processor 2.80ghz
8GB ram
sapphire amd radeon hd 6850
Windows 7 64x
  • 0

#2 Keyser Soze

Keyser Soze

    Meanie-head

  • Super Admin
  • 11158 posts

Posted 25 November 2012 - 07:15 AM

The Beta Catalyst drivers have been known to break Absolution. Try using the latest WHQL certified drivers.
  • 0


#3 Johnsjoden1

Johnsjoden1

    Pickpocket

  • Members
  • 4 posts

Posted 25 November 2012 - 07:40 AM

Okey thanks, Will try it. But could you maybe link a download page? Been trying to find it for a while now :)
  • 0

#4 Keyser Soze

Keyser Soze

    Meanie-head

  • Super Admin
  • 11158 posts

Posted 25 November 2012 - 09:32 AM

It's in our Technical FAQ ;)

AMD Driver page.
  • 0


#5 Assassin_SRB

Assassin_SRB

    Pickpocket

  • Members
  • 3 posts

Posted 25 November 2012 - 11:58 AM

Johnsjoden1 if you fixed the problem can you tell me how because I have the same problem. :(
  • 0

#6 Johnsjoden1

Johnsjoden1

    Pickpocket

  • Members
  • 4 posts

Posted 25 November 2012 - 12:09 PM

Assassin_SRB Haven't found solution yet.


Keyser Soze You mean download a previous driver then beta? if so i Already had that and it didn't work.

Edited by Charm & Strange, 25 November 2012 - 01:28 PM.
Not a good idea to post e-mails on publicly viewable forums. Also if a solution is found we'd like to see it ;)

  • 0

#7 Jerusaelem

Jerusaelem

    one post wonder

  • Members
  • 1 posts

Posted 25 November 2012 - 01:16 PM

Considering that every other game I currently play seems to work just fine, and it's simply Absolution that seems to having this issue, I'm doubting that the problem we're coming across has sweet fuck all to do with OUR drivers. Windows 7 is up to date, my drivers are up to date, and my computer is plugged in. There. Now that we've gotten the standard tech "support" out of the way, please patch the game already to fix this issue. It is not my intention to sound indignant but I've wasted 3+ hours trying to get this to work on my end, and I'm genuinely beginning to regret the download.
  • 2

#8 Charm & Strange

Charm & Strange

    up, down, top, bottom

  • Tech Support Staff
  • PipPipPipPipPipPipPipPip
  • 5302 posts

Posted 25 November 2012 - 01:31 PM

Considering that every other game I currently play seems to work just fine, and it's simply Absolution that seems to having this issue, I'm doubting that the problem we're coming across has sweet fuck all to do with OUR drivers. Windows 7 is up to date, my drivers are up to date, and my computer is plugged in. There. Now that we've gotten the standard tech "support" out of the way, please patch the game already to fix this issue. It is not my intention to sound indignant but I've wasted 3+ hours trying to get this to work on my end, and I'm genuinely beginning to regret the download.


The reason we do standard tech support is because it fixes the vast majority of problems, just because you're a super smart, leet gamer doesn't mean that those basic steps don't apply to you. We do them for a reason. If you want a patch do something useful like posting system specs and information about your problem so developers have some data to work with when building the patch.

If you want to be useful go and make your own thread with your system specs (preferably a dxdiag) and a detailed explanation of the problem and how it's manifesting for you (also make it clear what steps you've already taken in terms of driver updates etc.) then we can try and help you and the developers :)

If you just want to moan however, well, we'd rather you didn't :)
Posted Image

#9 0sixhundred

0sixhundred

    one post wonder

  • Members
  • 1 posts

Posted 25 November 2012 - 05:14 PM

I have the same problem and considering I built my rig, I know what the hell is in there and on it. Yesterday I was playing Assassins Creed 3 with Directx11 and today upon installing Hitman I get the same error. It is obviously the game as every other AA title running with Directx11 works perfectly fine...Square Enix obviously don't know shit about Directx11

Edited by 0sixhundred, 25 November 2012 - 05:15 PM.

  • 1

#10 Sketch

Sketch

    Damn!

  • Moderators
  • 19479 posts

Posted 25 November 2012 - 05:17 PM

Well Square didn't make the game, but if you want help, please create a thread a post a Dxdiag, so we can get started.

#11 Saba47

Saba47

    Pickpocket

  • Members
  • 3 posts

Posted 25 November 2012 - 06:06 PM

I had the same problem, after searching a lot I found out that the best solution was to update my windows, mine was Win 7 64 bit, but it wasn't Service Pack 1, so I downloaded the Service Pack (around 1 Gb), installed it and after that it worked. There was a topic about this in the official forums, and they said that this solution has worked for most people, you should give it a try. This is just about some DirectX files and updates for windows itself and is not about your drivers or the other stuff, although I recommend updating your drivers too.
  • 0

#12 Charm & Strange

Charm & Strange

    up, down, top, bottom

  • Tech Support Staff
  • PipPipPipPipPipPipPipPip
  • 5302 posts

Posted 25 November 2012 - 06:10 PM

Apologies OP, I meant to add something useful to that little rant earlier! Please could you ensure Windows is fully updated, the ebst way is to load up Internet Explorer (sorry, but it has to be) and go here; http://www.google.co...zGL4HYg&cad=rja

More advice here; http://support.microsoft.com/kb/311047
Posted Image

#13 Johnsjoden1

Johnsjoden1

    Pickpocket

  • Members
  • 4 posts

Posted 26 November 2012 - 07:06 AM

Still many people are saying that even if they have update everything you say we should do it doesn't fix the problem.
  • 0

#14 Sketch

Sketch

    Damn!

  • Moderators
  • 19479 posts

Posted 26 November 2012 - 07:20 AM

It doesn't always fix it no, but it eliminates possibilities and you're likely fixing problems you haven't even encountered yet by ensuring you're up to date.

#15 Keyser Soze

Keyser Soze

    Meanie-head

  • Super Admin
  • 11158 posts

Posted 26 November 2012 - 07:51 AM

Sorry we don't have a magic button guys, but the game is still new and we're still building a database of errors and solutions. If you had read the welcome thread you would have noticed that we are a user helping user support system. We ARE NOT IT professionals, and we DID NOT build the game. We have nothing to do with Square or Io Interactive, though both parties read our boards and give some weight to our input.

If you want help trying to resolve your problem, do as asked, or if you've already done so or have a valid reason why you'd rather not, state that fact pleasantly.

If you want to be an asshole, get the fuck off my forum.
  • 0


#16 Charm & Strange

Charm & Strange

    up, down, top, bottom

  • Tech Support Staff
  • PipPipPipPipPipPipPipPip
  • 5302 posts

Posted 26 November 2012 - 10:16 AM

Johnsjoden please provide us with a full dxdiag report :)
Posted Image

#17 TitaniumSRB

TitaniumSRB

    Pickpocket

  • Members
  • 5 posts

Posted 26 November 2012 - 08:01 PM

Hey i had the same issue, i downloaded the latest directx 11 and Gpu drivers and it didnt fix the problem. i downloaded "windows6.1-KB976932-X64.exe" (Win7 Sp1) about 1 gb. When i started installing it it stopped in the middle for AGES but in the end the computer rebooted and the game has worked perfect ever since. The only other issue i had was no sound in cutsences, but i fixed that by removing a Jack to USB converter and ran the jacks directly in ( Analog) and using a "Stereo" setting rather than 5.1. I hope i Helped
  • 0

#18 AbhiB

AbhiB

    one post wonder

  • Members
  • 1 posts

Posted 28 November 2012 - 08:12 AM

I had same prob. can any one fix it!!!
  • 0

#19 Keyser Soze

Keyser Soze

    Meanie-head

  • Super Admin
  • 11158 posts

Posted 28 November 2012 - 10:36 AM

Did you read anything or just click reply on the first topic?

We have a system in place for a reason. Read the welcome thread (it says read this first). Read the tech FAQ, it says required reading. Read the PC Players thread, it says Read this first.

After having read those threads, you'll know what we expect from users in order to be able to help them. A good description of the problem, a DxDiag report, and your own thread.

This thread is trashed now.

@ OP, please start a new one if you're coming back. Use multiquote button to put relevant info from this thread into your opening post.
  • 0