Bug Report Thread


#3026

I think it can be an enhanced behavior, not a bug.


#3027

Another bug that has been present for the xbox one version of the game is that two achievements a bugged and will not unlock after completing them. The are “One night in Bangkok” and “Drop the Bass”, both of which I have completed but for some reason will not unlock. If anyone at IO sees this can this be discussed cause others on the same platform have had this problem, specifically on the “Club 27” mission only? Thank You


#3028

When you load a save file that was created before a patch, this is what happens. The NPCs may not register the new animations or some sort and will just stand in the normal “T-shape” pose just like when you load their model up for the first time.


#3029

Maybe just a small thing but after taking a disguise from a body, you get the hotkey highlight for dragging, but the key input only reacts after a second or so. It never ruined it for me but if I try to make an highscore it is abit anoying. Still I encunter almost no recognizable bug in my PC version. Good job I guess.


#3030

How can this game include a mode where you have one shot to complete a contract & have incentives to complete it with the best rating but also include a bug that can ruin said rating &/or the entire single run of the contract through no fault of the players. I am of course referring to elusive targets & the bug in question is the subdue/turnaround bug.


#3031

Calling Strandberg from Zaydan’s office is bugged. I got all the kntel related to it but the prompt to call Strandberg from Zaydan’s phone just was not showing up.

i could call zaydan from Strandberg’s phone just fine


#3032

Making multiple people vomit seems to result in making them glitch over the same toilet/bin. Tested on “A House build on Sand” with the Shishas.


#3033

I found another minor graphics glitch on the balcony in the Paris level.
There is a woman smoking on that balcony where Dalia is wandering around, but she is not holding a cigarette in her hands.

[URL=http://www.directupload.net]

[/URL]

[URL=http://www.directupload.net]

[/URL]

I could enjoy the game with the best graphics EVER made, even more if that woman would hold a cigarette in her hands :smiley:


#3034

Sapienza, Pro Difficulty:

If you poison the Pasta Bolognese with ICA Lethal Poison, and ring the Lunch Bell, the eating/poison sequence with Silvio Caruso will just abort (without him eating the food) if you leave while it is ongoing to the point where the conversation between Caruso and the Chef can no longer be heard.

In addition, the plate of Pasta Bolognese will just get stuck in the Chef’s hands and he’ll hold on to this plate forever.


#3035

I havent played in a while, but one of the recent updates has made my game unplayable. Basically all the objects in the game have dissapeared. There are no weapons, tools, etc. Anything that is something you can pick up is gone. This includes weapons and objects on other characters. This first started with the last last Elusive contract in Paris. When I assasinated the target he did not drop the USB, and now upon thinking back, it was also impossible for me to find items to do anything with. I thought it was just my bad memory at not remembering where items were.

However upon trying to play Japan, and Sapienza again, I run up to guards and punch them, and when they pull out their non-existent weapons, they jump into the T pose.

I’ve tried several uninstalls/reinstalls, checking game integrity, etc. Despite that, the game still doesnt load any object files. As such, 2-3 updates later, i’m at a loss of what to do. I really want to play the elusive contracts and finish the story but cannot due to this…can someone help me?


#3036

@Morten_IOI Seems like this is a quite popular & game-breaking one at the moment.

Any word on it?


#3037

WOHOO! So AI have news! Doing a bit more digging, I found that it has been an issue for a while, and found some references here: Not loading thumbnails in menu and empty inventory

I followed the instructions and emptied my AppData Temp folder, then did a verify integrity Cache, and reloaded the game. Now Japan seems to work as it should, as do the other maps.

For those that have difficulty my AppData wasnt in the directory expressed above. Mine was in

users/your_username/APPDATA/Roaming/IO Interactive

I dontb believe roaming was mentioned previously.


#3038

So, is there a new bug with Helmut Kruger (or one I just haven’t encountered yet)?
He refuses to walk the runway. He’s just standing there idling and never moving. This in turn means the fashion show never ends, which removes at least two kill options on Novikov, one of which I was planning on doing (dropping the loud speaker on him when he gets interviewed after the show).

I really don’t know what could’ve triggered this, except for the fact that I killed Dalia rather early.
Does Kruger have to talk to Dalia on the phone in order to walk the runway? If that’s the case then… ugh… stupid.

Anyone else experience this?


#3039

#3040

I believe that Kruger will talk to Dhalia even if she is already dead. I think Novikov will also talk to her even if she’s dead bc when they talk to her she isn’t talking to them, she’s still going around her loop.


#3041

Is he standing backstage right at the runway entrance? He’s gotten stuck there for me a few times. I have no idea what causes it.


#3042

Dropping/placing the phone near a ledge then kicking an npc that is lured by the sound won’t allow me to pickup the phone again even though I could pick it up anytime before I kick an npc over the ledge.

Ps4


#3043

Yeap. Exactly like that.


#3044

I had something very similar whilst I was doing the 47KC in Hokkaido recently. In the medical area there are double doors that go out to the helipad. To the right is a stairwell. If I place a coin on the floor near the rail in that area, lure the bodyguard and/or the two doctors chatting nearby and push them over the edge, then I can’t pick the coin up again. I think it’s only when I place the coin rather than throw it. I noticed it when I threw a coin but it didn’t quite land in the right place, so I picked it up and placed it closer to the edge before the NPC arrives.

On a similar note - and I know others have reported this - non-lethal melee items thrown at NPCs cannot be picked up again in certain areas. One location is in Paris, on the stairs going from the fashion area up to the first floor (with the lone tech guy at the top checking out equipment). As far as I know it’s the second set of stairs where it happens. When I was doing the Fall Season Preview contract it happened every single time. I was knocking out Sato as he went up the stairs by throwing an item as he was going up. Afterwards I could see the item on the stairs but there was no prompt to pick it up.


#3045

I wanted to comment on a few things currently affecting the game on Xbox One (not sure if it’s across all platforms).

Connection to the online servers is currently very poor, especially at peak times in the UK (weekends and evenings).

Now, I’ve considered it may be to do with the quality of our internet; however, the internet and connection to Xbox Live never drops, and other people in the household are online and playing always-online titles on PC and other consoles without any issues.

I’m not sure how many of these are connection related, but here is a list of some of the current problems:

Disconnections (self-explanatory and frequent at these times: multiple times an hour):

NPCs locking up:

You’ll see in this video, I distract the security and he just locks up once the object is spotted. This is currently happening to a lot of NPCs, and they don’t have to necessarily be distracted for it to happen (for example, it can happen to main targets like Jordan Cross etc. in the main missions without any distractions – he will just lock up while taking a call on the third floor).

Throwable Objects disappearing into the map:

If you look in the video above, the wrench is impossible to pick up again, as it has dropped into a ‘dead zone’ on the map. These ‘dead zones’ seem to be increasing, and are occurring on all maps, and seem to be more prevalent on uneven floor textures, map edges, and around large furniture/objects.

Targets and NPCs randomly dying:

I don’t have a clip for this, but if you kill targets or non-target NPCs on one run, then restart or re-connect after being disconnected, there are times when those characters being killed will register on the next run. I haven’t tested it to find out, but the characters ‘killed’ in the previous run are still walking around on the map when you restart. It’s like the game or connection to it has taken an amount of time to register the kills, and also doesn’t recognize that there has been a restart. Again, haven’t tested it, however if those conditions can be recreated it’s potentially exploitable.

EDIT - Here’s an example from this evening:

NPCs glitching on and into surfaces:
These are a few examples from many, in the span of playing the game for a couple of hours:


Menu delay and load times:

They are absurdly long on Xbox. There are times when it can take minutes for a level or contract to load. The menus are also riddled with delay, and awkward to navigate.

Please fix or at least address these. I love the game, and want to continue to play it; however, combinations of the above make it impossible at times, and make me look to other titles (when this is the game I want to play).