HITMAN framerate dropped down


#1

Hi, can you help me?

The situation looks like that:
I had viruses and restored system settings to default and, as you know it deleted everything in the effect. So, I downloaded HITMAN again and ran it for the first time since 10th February. It was lagging very badly. Then, I downloaded Windows 10 Creator’s Update and then it was even worse… :frowning:
FPS are dropping down and lagging like never before… :frowning:
I can’t find a reason.
I disabled fullscreen optimization, game mode and DVR. I reinstalled NVIDIA Graphic Card Driver. Still not good…


#3

Creator’s Update…


#5

I’m really worried about my favourite game… :frowning:

Also, I spotted a small detail - autosaving takes about 4 times longer than before…


#6

i experienced this too. at first i thought it was from overclocking my ram… but restarting the game until the framerate went up back to normal seemed to work

i don’t know if i installed the creator’s update… i don’t think i did


#7

Well, now the only occuring problem is screen being jerked, if you know what I mean… :frowning:


#8

Your CPU usage might be high owing to some background processes. Check in Task Manager if you have any unnecessary background processes running.


#9

Thank you. For now, I am reinstalling the game and we’ll see how it works then.


#10

And… reinstalling changed nothing. :disappointed:


#11

what is your pc spec?


#12

Windows 10 Pro, 64-bit,
NVIDIA Geforce GTX 750Ti,
Intel® Pentium® CPU G630 @ 2.70 GHz,
8,00 GB RAM.


#13

Try using DX11 once. If it doesn’t help, post the graphics settings you are using.


#14

I always use it. :smile:


#15

I played it yesterday again. Nothing changed.
Maybe it’s my CPU’s fault?


#16

Could you post your current graphics settings?


#17

It’s in Polish, but I can translate what you want. :wink:


#18

Hmm, you already seem to have most settings at low… The only things I could suggest trying are changing Display Mode to “Fullscreen” or “Exclusive Fullscreen”, and VSync to On.