4K not working

So some of the map locations are taking up to 5 minutes to load in the 4K detail, while others aren’t loading them in at all. Is this a known issue or something new? I don’t remember this happening a month ago, but it is very noticeable.
I’m playing Hitman 2 on my Xbox One X, on a Samsung 4K UHD HDR LED Smart TV
Thank you.

Have you tried ‘normal’ resolution?
Say 1080p or 720p?
What resolution settings are set in the game and in TV itself?
I presume for the game to work properly the resolutions of console ant TV should match

Yes I have tried that. I think I’ve tried everything, short of buying a new HDMI cable to see if that helps. But I think it’s the actual game, because my other games seem to run fine.

If it was a game itself nobody couldn’t play.
But there are lot of people playing fine on Xbox

I’ve not tried to quantify the resolution but I’ve not noticed problems, I have XOX connected via a Samsung sound bar to a Samsung 4K QLED. Sometimes a coarse texture is seen for a second or two but that’s all I seem to get. You could try the usual - full restart, etc. There is supposedly a difference with some HDMI cables but I don’t really know, I have two “high speed” for the connections so I suppose that’s not going to be an issue for me. Not sure, to be honest, sorry!

Do you know anyone playing on xbox with 4k ?

Everybody does.
I’m collecting online stats

How many people even have 4k display?