Can no longer access H2 maps in H3 - Xbox Series X

Hi folks just wondering if anyone is having the same problem I am.

I own H1 H2 and H3 digitally on the Xbox store with all the additional content as well. (Playing on XSX)

Over the last few days I can no longer access the H2 maps and am getting the please download access pass issue. (Have been playing the maps all year with no issue)

I already have it installed on the console and all the other unlocks are working.

I have tried deleting it and reinstalling (both the access pass and the whole game and expansions). Moving to separate HDD’s. Proper shut down and reset if console…

I’m just a bit miffed about how to fix it… does anyone have any suggestions?

TIA

Hello and welcome to the forum.
This issue (not being able to access the Hitman 1 and Hitman 2 locations in HITMAN 3 even though the Access Passes are downloaded) seems to be plaging a lot of Xbox players. So far we don’t know why it’s happening, it seems to have started after the latest patch. We do know of a workaround though.

If you launch HITMAN 3 and your Hitman 2 locations are greyed out:

  • Go to the Options tab in the main menu.
  • Select Quit Game > you’ll return to the TItle Screen.
  • Let the Connecting process complete and disappear (you’ll see the bar at the bottom right)
  • Enter the game from the Title Screen and see if you can access the locations.
  • If not, repeat the steps.

I can not gurantee that this will work for everyone, I’m not an Xbox player. I do know that it has solved the issue for some.

1 Like

Similar thing happened with me though not quite to that scale with the HM2 expansion pass being unavailable since Wrath was released. And I lost access to Dartmoor since Envy was released. It appears to be a compatibility thing with the update or the digital version is broken.

Thanks for the suggestion. Unfortunately has not worked for me though.

Happened to me yesterday. I had to redownload. Not sure why. It was fine on Monday.

Not sure what is going on but I have no location a in H12 or H3. WTH