Can't connect to hitman service


#42

@Travis_IOI @ioi_christianco
Signed up just to contribute to help solving this issue. I work in IT and will provide some technical details here.

  • I am with Telstra (an ISP) which uses the NBN network (as many ISPs do now in Australia)
  • I am connected with an IPv4 address and my internal subnet is IPv4 only also.
  • Hitman has worked pretty much fine for me until a week or so ago. Now I get permanent “can’t fetch resources” error that many Australian’s are suffering.
  • Although I am on an IPv4 connection, the NBN is a strange beast and a number of ISPs seem to be enabled with stateless IPv6 as well. Telstra have themselves stated as such and I find if I enable IPv6 on my router, although I still connect externally with an IPv4 address, my internal network is issued with IPv4 AND IPv6 addresses.
  • There is a highly likely chance that the fault is indeed related to the fact your servers don’t accept IPv6 addresses but due to the NBN national roll out in Australia the reality is IPv6 stateless addressing is almost certainly going to be forced on everyone in Australia over the coming months/years as full NBN integration takes place nationwide.

If there is any further specific technical details you would like about things please ask and I will answer, even if I have to find out directly from my contacts at various ISPs etc.

EDIT: And when I say internal IPv6 addresses, they are internet addresses, not local link fe80 addresses or the like.

EDIT2: I am not using google DNS, just the Telstra provisioned default ones pushed via network.


#43

@Travis_IOI I’m also on NBN, could be the common cause for those having issues in australia, though seem to be some other people around the world having issues as well.

Dave


#44

I enabled native IPv6 (not 6to4/Teredo) on my router a month ago and I can connect without any trouble since (ISP: Orange FR). I use a stateful autoconfiguration of IPv6 with a DHCPv6 service provided by my router. Maybe you can try to use a stateful conf instead of slaac, if you have the possibility.

Maybe the Xbox One have trouble with SLAAC, i don’t know.

The majority websites and webservices don’t accept IPv6, I do not think that’s the problem, it’s not IOI fault but most likely your ISP.

Here my result with http://ipv6-test.com/

Screenshot_20180203_085741

IOI can’t deploy IPv6 because Microsoft Azure don’t support it for the moment : https://feedback.azure.com/forums/217313-networking/suggestions/4992369-support-ipv6-throughout-the-azure-platform


#45

Thanks for the input.

Are you connecting to the internet with IPv6 though or are you only using IPv6 through a stateful DHCPv6 on your internal network? The reason I ask is this, how are you able to connect to Hitman servers if you are indeed on an IPv6 external address?

The issue with the NBN here seems to be that a number of the ISPs are enabling stateless IPv6 on their own networks parallel to IPv4 and even when connecting to the internet (not internal home lan) with an IPv4 address the ISP will push down IPv6 addresses simultaneously.


#46

WORKING!!!

ON HERE here a couple of people suggested just keep trying to connect.

WHAT I did is load up the game, trued to connect 3 times, left it connected at the error screen came back 15 minitues later and it successful connected. I HAVE QUIT AND DONE A NEW CONNECTION AND IT STILL WORKS. YAY

ORIGINAL
Also in Australia, Victoria, Whittlesea I have been unable to connect for at least 4 days. (May have been out for longer but only started trying to play since then)

I have changed DNS to Google defaults no change.

Same error message as pictured.

I have cleared catch on router through hardware and software resets. I have cleared Xbox one catch through shutdown while holding power button and unplugging power.

I have also deleted save game data from xbox one and then it re-synced so I deleted it from cloud and xbox one.
Ive tried cancelling sync ect. All to no success.

I am connected to the NBN with iinet.
All other online games are working such as ARK.

Network is IP4 and NAT is OPEN.

Edit: Retried this morning with no luck. Ive tried both auto config and Google DNS with no luck


#47

I have both IPv4 and IPv6 addresses.

whireshark

In this example with my computer, Windows use IPv4 to communicate with hitman authentification server (191.233.87.194) and IPv6 to get DNS response from Google Public DNS (2001:4860:4860::88xx).

But if I disable IPv4 in my network adapter properties, Hitman client managed to successfully make DNS queries but can’t connect to Hitman servers, which is expected because IOI servers can not be reached with IPv6.

20180203131239_1

@Aus Are you on PC, xbox or PS4 ?


#48

@Hardware Nice to see a wireshark capture, very useful. I’m on xbox one, the days of PC gaming are long behind this lazy old tech! :smile: Interesting that you are getting external IPv6 and IPv4, that seems to mimic the setup here on the NBN, but you are having no issues. I might have to do a capture too and see what’s going on here. Ugh working after hours…it’s got to be a crime right?

I’ll do it tomorrow. I’ll have to put a switch between xbox and router and sniff the traffic crossing. It’s past midnight now and I am crashing. Seeing yours reminded me I could even check this, thanks.

@Travis_IOI
UPDATE: OK, ran xbox one into laptop via crossover cable and shared the laptop wifi. Sniffed the xbox <-> laptop ethernet interface and did a wireshark capture. It is definitely connecting with IPv4, seems to be handshaking with server too but then throws the “resources not blah blah” as others have posted above. I notice also a number of microsoft and xbox.core addresses including xboxone-service.hitman.io and so on. Perhaps the issue is specific to xbox users? Any way I can send the complete wireshark capture to the support team?

Are there any PC users who are getting the same “failed to blah blah resources unavailable” error?

Sorry for edits, being new user the forum limitations are severe. 1 reply limit! Come on!!!


#49

I am still periodically getting this error on multiple providers and network types. I use Cirrus Communications via fixed wireless at my student accomodation and iiNet NBN at home via fixed wireless (missed out on the high-speed fibre by less than 300 metres) and neither connection is using Google DNS just the ISP provided ones. I ALSO periodically get account authorization errors, version mismatch errors, failed to fetch configuration errors, and the dreaded unknown errors. Eventually the connection works and I am able to get on - however right now seems to be one of the times where I am not getting any connection.


#50

United States. I’ve been getting the same message since the newest exclusive target. I’m on Xbox.IMG_8534


#51

Greetings - I changed platforms from Xbox One to Xbox One x 3 days ago, downloaded/installed the 12 files without problems and cannot connect either. The internet connection is fine and all other games and apps are also working with this exception. Hitman also works fine without connection.

I am running on IPv4. I am located in Alberta, Canada

Message - Connection Failed - unable to connect to the Hitman service. Failed to fetch online resources from the Hitman server. For more information contact Hitman support.

Any ideas to solve this problem short of the pain of in-installing/ re-installing everything would be appreciated. Thanks


#52

Sydney Australia here on TPG ADSL, getting the same issue, haven’t been able to connect in over a week

Highly doubt the NBN is the sole cause


#53

Same here, in Canberra Australia.


#54

Melbourne. TPG via NBN. IPv4. Failed to fetch resources error.


#55

Same problem, Brisbane Australia, Optus NBN , XBox One


#56

Hi have the exact same problem!!!
I think the elusive target update has something to with it…


#57

Well interesting development. I’ve just spent the last few hours completing the Elusive Target “The Gunrunner” and a few other missions and achievements. At about 9pm QLD time it started working. 4 or 5 hours earlier it was still giving the “can’t fetch resources” error. I changed nothing on my side whatsoever. I hope the rest of you have a working game too now.

EDIT: 7am next morning and still working. Have any of you started connecting ok too?


#58

I am located in Canada, Play on Xbox one S and have Fully Uninstalled and reinstalled, still cant connect, i have access to all DLC


#59

New Zealand, same issue. I haven’t been able to connect the whole time since i purchased the game 2 weeks ago. I have changed my router settings to IPv4 with no luck reinstalled it as well. I play on xbox 1 x 20180205_131804


#60

Same problem here in Brazil on xone s.


#61

Signed up specifically to comment on this issue.

I’m in Nova Scotia, Canada, playing on a normal Xbox One. I’ve tried multiple networks in multiple locations, all IPv4, and I get the same message as others:

“Unable to connect to the HITMAN service. Failed to fetch online resources from the HITMAN server. For more information, contact HITMAN support.”

I had seen here and on the subreddit that it was working for some people, and others were able to brute-force their way in, so I thought I would give it another shot.

Even now, less than eight hours before the fifth Elusive Target ends, I still can’t connect, despite being able to play each of the prior ones without issue. I have done a hard reboot of my console numerous times, and am able to play other always-online games like Overwatch and Steep without issue.

@Travis_IOI, it’s probably asking a lot for an extension, especially because the February roadmap is due to be posted this week, but in light of the ongoing situation it would be very much appreciated.