Can't connect to hitman service


#62

I’m from Australia and I can’t connect to the server since yesterday and I tried so many time… I was hoping to get the exclusive target :frowning:


#63

@Travis_IOI can we get an official update from you guys as to any progress made or what you’re up to? Hasn’t been any word for a few days…


#64

Strangely enough mine finally connected yesterday and I was able to complete the elusive target

Default IP and DNS settings
Xbox one original
ADSL
Sydney Australia


#65

Hello,

We are looking into this issue, and have been following some leads, but so far the root cause is not clear.
It seems to be a network error, occurring when the game has to download a large package from the server.
IPv6 is probably not the culprit on this one, but we are not ruling it out completely until we have a sensible explanation.

@Aus If you still have your wireshark traces, we definitely wouldn’t mind having a look at it :wink:
We are having difficulty reproducing the error over here, even when simulating various network conditions.

@Tenebrous, @Dave_Friend, @Steddy, @Matt_Petraitis, @Quiet_Cannibal, @Whirrblatt, @Nebby85, @Antoine_Crivelli, @Patrick_Wills, Aaronstlc, Daniel_Jimenez, idiotnextdoor, A1catraz97, Brayton5079, NemesisCrime, Jono56667, VinnyBL, cppfeiffer, Shane, Scott_Gregory, Brett, cashtrac, blonky, Christopher_Loney, MoltenLlama, lyle, Daniel_Nishiyama, LexingtonDelta, Eyesack, nandoaa, jackie1, Ron_K
Thank you all for reporting the issue and for your patience.

Please do not hesitate to share any update, as we see some of you were able to get in.
Also, it would be interesting for us to know your connection speed, as we only have been able to reproduce the issue a couple of time with bandwidth limitation enabled.
From our testing so far the issue seems to hit randomly, so I would encourage you to retry a few time.
Once you get through, you should be fine for a while as the connection blocks on a file download which is then kept as is until the next game or server update.

Thanks,


#66

I managed to connect again. don’t know if its a coincidence, but I tried to connect the XB1 4 days ago with a 3G modem, and it worked. was very slow but it worked. when i switched back to my regular wifi network, it kept going. didn’t have a problem since.


#67

I’ve actually been able to get in for a few days now, but have experienced
some intermittent issues during contracts and escalation mode. And ive
heard some people are still not able to connect. Thanks for the support


#68

Thanks for the update. @ioi_christianco At my student accomodation I pay for 20Mbps down/5Mbps up but I am currently getting around 13Mbps in both directions. While back at home my parents pay for 12Mbps down/1Mbps up but their connection speeds can really fluctuate between less than 1Mbps down to the maximum 12Mbps on a good day so it is really hard to be accurate with that connection. I havent tried to log in today or yesterday but it seemed to be working properly day before yesterday.


#69

Thinking I have the same problem here, except I’ve never been able to get a successful connection as I only purchased the game 4 days ago. I’m seeing the error ‘Failed to fetch online resources from the HITMAN server.’

Australia here, with average 10Mb/s down, 1Mb/s up (gotta love the Australian internet speeds).

Can’t wait to be able to properly play… offline isn’t quite the same.


#70

Just tried playing today (Xbox One, in USA)…and now it worked, just right after the Gunrunner elusive target is over. So that had to be the problem, right? I see there’s already a new elusive target coming up. Hope I don’t have to miss that one too :frowning:


#71

Still having this problem. From NZ using xbox one. I had no problems connecting about 2 weeks ago, and now i just cant connect at all. I’ve tried uninstalling and reinstalling and called up my isp to set my connection to ipv4. Nothing has worked.

The elusive target is gone now and i never had the chance to start it. I’ll try reinstalling again later, and attempt connecting.


#72

@ioi_christianco I would be glad to share my capture, it is the entire process from the hitman screen where you first press A to connect to your profile and login until it throws the error message about unable to fetch resources. Complete parse with no filtering, about 3100 lines. Now due to the fact it is this large I have no interest in creating a pile of partial screenshots to give the entire collection. I will be happy to send you the .pcapng wireshark capture file though. Let me know how to get it to you.

My network speed is 25Mb/5Mb and although my Hitman connection is working fine now, the speed was unchanged throughout the 5 or so days I could not connect.


#73

I hadn’t played in quite a while. Am uploading a 4.92 GB update. Can’t connect to server either. Status says it’s Ready to start but it won’t connect. My fav game ever.


#74

CI am in australia and can not conect to the server either. i bought HITMAN 3 days ago or so, and the have not been able to conect to the server at all. i have check my router, it is say it is in IPv4 so maybe that isnt the problem, is the server down still or is there something wrong at my end?

Edit: im on Xbox One s and not on NBN, I have and ADSL2 connection

edit: Wait… i dont need an xbox live membership do i?

Edit 8 Feb : I checked just before and it logged in! :+1:t2:


#75

I have the same issue since a week ago
Does anybody knows what to do
? :frowning:


#76

Is it possible that a third party (Xbox live, NBN…etc) may alter the transferred data or alters the communication between the two parties (player <-> server) during the connection ?


#77

@Hardware client to server communication on XBoxOne is protected by a set of platform security features, much tighter than anything on PC.
If a MITM was tempering with the connection, the console would not be able to connect with XBoxLive at all.
Thanks for the help though :wink:


#78

Finally got into game, have tried every night it took 4 attempts to get in, sucks to of missed elusive target event


#79

Small update:

We deployed a mitigation that we believe will fix the issue.

We will continue investigating the root cause of the issue, which seems to be a random network error occurring during large data transfers.

Don’t hesitate to update this thread if the issue persists, but also if it is fixed for you.


#80

More than 24 hours and no replies. Does this mean everyone is happily playing? :slight_smile:


#81

No, unfortunately not. I purchased the GOTY edition before christmas and haven’t been able to play online ONCE. Well, the first time I launched it up it did go online, but I quickly exited again to play around with the graphics options and since then it doesnt work. I only just reinstalled the whole game couple of days ago. Location is Germany, my internet is quite fast with 50 Mbps up and 10+ Mbps down, using the latest router. I just launched the game again to check, seeing the update posted here, hit retry like 5 times and still, nothing. Exact phrasing is (translated from german to english): “Connection to Hitman client not possible, the authorization of your account with the hitman client has failed. For furhter information please contact Hitman support.” With all those elusive targets probably missed and having nothing done online I am in a quite negative mood about all this, I hope this will get solved soon, given that I dont experience this problem with any other game.

I’ll call my ISP now to see about that IPv4/6 thing, maybe they know something. I’ll update here.

So I just ended the call. She said something about not being able to change anyhting because “You just switched to VDSL (we made a new contract a week or two ago and got faster internet) and it is running using IPv6, therefore we can’t change anyhting”. Now I’m no expert in this matter, I asked whether anything concerning the router itself could be done and she denied. Any of the clever guys here have an idea?