Can't play Hitman 2 levels in Hitman 3 (Xbox XS)

Platform: [Xbox One (XS)]

Description : Can’t access Hitman 2 content in Hitman 3 ( HM2 is a Disc version, HM 3 is a digital version)

Steps to reproduce: For me I had HM 1 and HM 2 installed on my XS and then downloaded HM 3 and all content. I followed the steps on the IOI migration page and ensured that I had the HM access passes for HM 1 and 2 and the HM3 access pass for older HM content. When in game I can see HM1 and HM2 content/levels etc., but all I get is taken to the MS store when I try to access HM 2 levels . I have deleted all content, and then reinstalled HM3 first, then HM 2 (from disc) and then HM 1 and the packs for content access. I’ve al deleted an reinstalled HM (digital), HM2 (disc) and then HM 3 (Digital) and all content and access packs and still no luck. I can play HM 1 and HM2 levels in HM 2 and HM 1 levels in HM3. HM3 does not see the levels or content for HM 2.

I have downloaded the access passes for HM 1 and HM 2, multiple times and in multiple orders.

I’ve also tried downloading the Hawkes Bay and HM 2 game without the disc version, and still no joy.

Raised this on Feb 6th and still no answers from IOI.

Frequency : This always happens

Attach or link to any videos or images that will help explain the issue

There is a thread dedicated to the issue and it seems that a fix was finally found. Click below to go directly to the post where I have a link to the Tweet of Core2TOM who discovered it.

So I think I’ve found a work around and thanks to all who helped especially Laurenboers2 who set me on the right path.

If you have the HM disc version, you need to delete the main game and Hawkes bay and the HM access pass from your HDD

DO NOT DELETE ALL OF YOUR HM 2 Content just the 16GB file and the Hawkes Bay lvl and access pass

Then reinstall the HM2 and Hawkes Bay free content - Not from your disc from the MS Store
Then go into the HM2 you have downloaded and get the free HM 2 upgrade for HM3 - should be free and not $110
Then restart your console - not just the game
It should work… or at least is for me right now…

1 Like

This is the first time I’ve gotten any of the guides to work I’ve been trying since the game came out