Challenge not working

So there is a challenge in the game that says that you need to complete the final level of any escalation with a silent assassin rating to get an ICA Tripwire Mine.
However, I did not get it.

I would try with some kind of other escalation and see if it works.

1 Like

I’ve seen other people reporting this bug as well. The solution I think was to complete a 5 level escalation with SA rating, so the description “any escalation” was wrong.

Or, if it’s supposed to work with 3 level escalations as well, it could be a bug. I remember that my SA SO at the Final Test didn’t register for like 3 attempts. Was the only challenge missing. Then weeks later I tried it again and it simply worked.

1 Like

The Final Test escalation is a 5 level but I’ll maybe try another one. Thanks.

Nope. I’ve done the Einarsson Inception and it still does not work.

Well that sucks then because if IO is not planning on making any more updates for this game then you are kinda stuck on not being possible to unlock it.

Yo, i’m here cause i was having the same problem.

You have to complete “The Kotti Paradigm”, do all 3 levels SA just in case, that’s how i unlocked it

Level 3 is hard, I used a lockpick, the pistol to delete the eivdence, coins and i smuggle the Sieker to shoot the two security guys in the stairs, good luck!

I already got the tripwire mine