Elusive Target No. 17 "The Food Critic". 12.30.2016 (30.12.2016)


#435

They should have some kind of a duck that shoots out non lethal or lethal gas around it. Might be OP but it would be cool.


#436

There should be two “consumable versions”… one that blows up in a cloud of sleeping gas and another that blows up in a cloud of lethal poison gas.

And then there’s two “hand held squeezers” … Which you can only use as “Subdue” items that also have lethal gas or sleeping gas.

Maybe a fifth used as Offensive Mace Spray… 47 using a squeezable Rubber Ducky to “mace” guards would be awesome and funny at the same time.


#437

I wonder if IO will bring back new ducks into S2, or will the chewing gum be the new “joke” item that replaces the ducks in S2.


#438

The chewing gum would be a great addition actually. :slight_smile:


#439

Ok that stalker kill was badass. Hats off!


#440

I doubt the chewing gum will ever make it into the game, for obvious reasons


#441

Yeah, it is a little bit OP in a way, would make consumed poison useless, plus poison kills are accident kills. But the picture for the item slots were already there when they were leaked, so who knows. But then you could just drop it in front of someone, and then it would be an easy SA


#442

Could be they added it in to test stuff.

But ye it’s way too OP


#443

I did the same with lethal poison. Nothing.

I don’t get it, it was a newly added cake for this ET, wasn’t it? I saw him eat it in my ‘observing’ playthrough, then on my replay I poisoned it and waited, and waited, and waited, until finally after three kitchen visits he finally ate some. No reaction. Luckily I had already placed a fire extinguisher and a remote door explosive on the planter behind his chair so just blew him up for a cheap SA.


#444

He spits, not swallows.


#445

Amazing. Love how you take the coconuts home with you as a souvenir of a job well done.


#446

I have forgotten whose video it was but I saw someone pull it off and made it look sad easy.

It just took a coin and the audio device.

Dressed as the waiter you crouch behind the table the target is sitting at (near the railing side) and throw the device in-front of the guard. The guard will take the device and leave the target. Take a coin and toss it behind the target near the railing and just push the target over.

Silly easy-made me sad that is was kinda gamey. Nothing against the video creator just…both NPC’s look and turn directly at 47 after both throws but still "forget"and reset themselves to pick up the object.

Not that I did any better. I just put a Galaxy S7 in front of his feet and walked away.

gamey as fuck


#447

On that topic I need to play around with the audio device and see is it’s fixed, I’ve not used it for months because the dang thing was unusable back when it was introduced and I’ve been scared to touch it since.


#448

it works now, finally.

I think they fixed it between Marrakesh and Bangkok.

They pretty much HAD to cause one of the unlocks was a re skinned version.

they let it sit broken for 4 maps.


#449

You’re counting the two bonus missions, correct?


#450

Pretty sure Summer Bonus Episode’s patch fixed it, so they left it broken for Sapienza (when it was introduced) and Marrakesh hueheuhuheue.


#451

Am I correct that this Elusive doesn’t move from his chair?


#452

He eventually moves to the kitchen and starts a cycle of sitting and returning to the kitchen.


#453

Yeah, I noticed that Wen’s bodyguard is the most finnicky AI I’ve seen from this game. I left my gun behind a chair, threw a coin at it so the bodyguard would go to it, and the moment he’d see me (in a waiter disguise), he forgets about the coin, and goes back. I restarted, did the same thing, and he stopped and looked at me, took 3 steps, stopped and looked at me again, took 3 more steps, finally saw the gun and took it away. The entire time I could hear the “tick” sound effect that he got suspicious of me between each of those actions, but luckily it didn’t count towards my score, he was never really suspicious.


#454

Ok, good. I finished it about 10 minutes, but I never saw him move so I assumed he didn’t.
Still, not a very diverse target… hmm.