*fixed* HITMAN 2 Game won't start, codefusion window pops up


#1

Platform: PC
I have access to the game with family share (my brother has the gold edition), I was able to play just fine until the update at 16 of November. After the update, when i press play from steam the menu pops up and when i press play it will either just wont start or a small window about “codefusion” pops up.

Untitled1

It tells me to go to a website paste the request code and the use the response code in that window so that the game can launch. after that the window says “something went wrong” and closes.

I have tried verifying the game files, changing from fullscreen to windowed, I have re downloaded the game but nothing seems to work.

Update:
I already own the HITMAN GOTY so i have the legacy pack unlocked. But that does not seem to make steam cut the family share for HITMAN 2.
I have tested launching the game from the sharers account on my pc and the game works fine. Also, I have used a third account with family share and it also works fine.
Steam downloaded all dlc and in the dlc list it says I own all the legacy stuff and authorized (from family share) for the rest of the dlcs.

I can not understand why it is not opening, because it is not my computers fault.


#2

Sounds like it’s not authenticating with the game’s DRM server. Try having your brother remove and then re-add you to his family sharing list. Make sure the game’s executable is not being blocked by your computer or router’s firewall.


#3

Re adding the family share did not work and firewalls are not restricting the game.


#4

Has he launched the game while connected to the internet recently? I understand that Denuvo (Hitman’s DRM) requires occasional server authentication, something like once a week or every 3 days. Since he’s technically the game’s owner, it’s possible that he’s the one who needs to check in with their servers before your shared copy will function again.


#5

@Travis_IOI please assist.


#6

Yes, he opens the game every day and always online, and he has checked that no firewall blocks anything hitman related.


#7

It might get fixed if I remove the legacy DLCs from my account. But i don’t know if I ll be able to to re-add them for free when I buy the game or I ll have to buy the legacy pack, so I might use a third steam account to play from family share just in case.


#8

I have exactly same problem. Would be nice to have somekind of solution to this :angry:

I also removed season 1 content from the account that I had this problem. It didn’t help

And it’s clear that Denuvo is the primary reason for this


#9

i’m in the same situation as you, feels good not to be lonely

  • got the game from family share
  • own hitman 2016
    If anyone knows how to solve this …

#10

Newest update to game didn’t solve this problem :disappointed_relieved:


#11

Today, I saw a small update 10mb to the game, and then found in the internet that they removed the Denuvo anti tamper, I tried opening the game and it is working just fine. I hope everyone else has their problem fixed.


#12

Nice! Thank you, it’s now working fine for me