<HCCE> Contract Creator Extended [Mod/Tool v1.7]

Hey, I see the tab in fiddler but when i make a contract the page doesn’t open. I set up the https as directed and followed the steps in the video, is there something obvious i might be missing?

WTF is “publish success,save failed?”

Error log here


   在 System.Security.Permissions.FileIOPermission.EmulateFileIOPermissionChecks(String fullPath)
   在 System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   在 System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   在 System.IO.StreamWriter.CreateFile(String path, Boolean append, Boolean checkHost)
   在 System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize, Boolean checkHost)
   在 System.IO.File.InternalWriteAllText(String path, String contents, Encoding encoding, Boolean checkHost)
   在 HcceEditor.FileController.SaveToFile(String folder, String filename, String json) 位置 E:\Files\Programmieren\Hcce\HcceEditor\FileController.cs:行号 35
1 Like

Contract titles with : cause a bug that will be fixed in the next version.


Thx for tell me that.
Btw,is this bug happened when title have a “:”,or briefing have a":",or both?

1 Like

Only the title is affected here.

EDIT: Oh and maybe the Autor name.


Hi, I am trying to get this mod working for the first time to no avail. I followed the instructions by downloading Telerik Fiddler2 (It is v5 I saw it is no longer getting updates so should be newest), I downloaded the zip of your mod and put it in my scripts folder in documents and extracted using 7zip. I went onto Fiddler and did the HTTP options by adding :
and when I launched Hitman 3 it refused to connect to the service and that is the only problem I am having. I saw 502 error in Result but fixed that from a Stack Overflow answer by including tls 1.1 and 1.2 in the Protocols which fixed this issue. This didn’t work so I tried re installing everything and also restarting my pc and that didn’t work so then I added:
In the perform decryption and nothing is working. I am not hating your mod this is amazing work, I feel like I am missing something even though I followed the instruction video in detail. I also do not have any Error logs or folder, as far as I can tell they are missing completely. Yet the H3 Contract Creator Extended tab is showing in Fiddler2.
Any help would be appreciated. Thanks.

1 Like

Sorry to further clarify, the game will not connect to the network if Fiddler is open, as soon as I close it then Hitman 3 works.
My goal is to create a contract inspired from
Trzebiat youtube vid because it is by far the coolest Hitman run I have ever seen (I think he is a dev or something on here so massive fan mate hi from Australia), where he uses the Loud Sniper you get on Berlin SA/SO No knockouts all 11 agents and trying to put that in a contract to challenge my friends.

Have you toggled the bottom field in the HTTPS settings to “perform decryption”? It is “skip decryption” on default.

If you did, do you use other mods that modify the running game process? Such as CheatEngine, localghost or Peacock?


I have done it where it shows perform decryption like in the video and this is my first ever mod for hitman 3. I just have the base game as it is.

I don’t need any dlc do I?

No you don’t.

In Fiddler, do you see the HCCE menu in the top bar? If yes you can open the folder HCCE stores files in, there is also a error folder. If it contains files, send the content of the most recent one in a private message to me.

1 Like

I click Open Folder and it takes me to a Data Folder, there is no error folder

1 Like

@Urben was wondering since i talked to Hassan about it but is it possible some Jsons can’t go through because of certain characters or symbols? still trying to figure out why i can’t get contracts to go through PlayStation.
also what does “argument passed in is not serializable. Parameter name: value” mean?


Anyone have updated your Window 11 to version 22H2? Does that affecting HCCE in any ways ?

Hello, when I used HCCE to save contracts recently, some contracts could not be saved, while others could be saved normally. I tried to check ERROR’s txt and found that their errors were the same:There are illegal characters in the path. I now ask for your help

The contract title contains characters such as : that HCCE has issues with currently.
I will release a patch soon that fixes some bugs such as that one.

1 Like

I know there is this bug,but the contract name I extracted does not include:. Although my request may be excessive, I still hope you can check the contents of the error file to make sure.

What is the contract title you tried to set? Also what is the username you publish with?

I want to withdraw someone else’s contract. The name of the contract is “Duck Or Treat?”,and the author is Grimcula.