HELP! Hitman shuts off monitors

I can play the game as long as I want, and most times it is fine when I quit the game but occasionally when the game shuts down it will shut off the monitor feed. much like it would if I unplugged the monitors altogether.

(1) no, it does not happen on any other game
(2) this has been going on for a while and is annoying

Does anyone know what is going on?

I’m not sure what exactly do you mean by ‘shut off the monitor’, but since I changed my monitor to more modern last month, while launching or minimizing or quitting the game my new monitor goes all black (but it not shuts down) for second or two and then comes back to normal with HDMI2 label at the top left corner.
My guess it loses signal from graphics card for a moment and then catches it back again.
Though it strange, because I never had such a situation with old monitor.
Old monitor was connected as HDMI-DVI, because old one hasn’t any HDMI ports.
This new one is connected as HDMI-HDMI and behaves this strange way.

I don’t know where to dig the problem. Whether it’s monitor issue or cable issue, or game issue…
I haven’t tried yet DisplayPort connection, but something tells me nothing will change.
So I don’t know.

You have similar situation or your monitor remains black forever till you reboot your PC?

Till I reboot the PC
its still running but the Black screen stays there till I reboot

Heres what it does…
Most of the time it does exactly like you mention , but once in a while when I shut down Hitman 2 it turns both monitors off (like I hit the power button on them) and the only way to get it corrected is to hit the power button on the PC and restart the PC.

Did you check connectivity cables? Do they plugged properly and reliably?
What scheme of connection do you have? HDMI-DVI, HDMI-HDMI or DisplayPort or any other?

HDMI on both monitors
both secure
it only ever does this with hitman 2, it never did this with hitman 1 or any other game I play and I play many different games
world of Warcraft
Diablo 2
3
Hearthstone
batman
Rambo
payday
payday 2
Friday the 13th
GTA
and that’s just a few of the games I play, and none of them do anything like this. So I am very confused as to what is going on with Hitman 2. I have spoken with a few other people offline and they have the same issue and no idea what causes it

Ok, then first try to go to NVIDIA Control Panel (if you have Nvidia GPU) and do some adjustments.
Unfortunately I can’t show you English version of screenshots, but I think you can figure out what to do with this example.


In this section in drop-down menu choose Full (0-255).
Save changes

Then go to this section


and in highlighted drop-down list also choose Full.
Save changes and try to launch the game.
Maybe this will help.

Note that this will work only if you have Nvidia GPU.
If you have graphics card of other vendor I’m powerless to help.

Also try to play with game graphics settings.
Change exclusive full screen to full screen (or vice versa), try to change game resolution etc.

my GPU is a AMD will this still work?

AMD GPUs are displaying full color range by default, so rather no

yeah my GPU is a AMD Radeon RX 580

This post was flagged by the community and is temporarily hidden.