HITMAN 2 - 3Dmigoto DX11 Bloom and Post Lighting Effects Mod - PC

Can’t wait to get your mod :star_struck: :sunglasses:

1 Like

Comes in a few days with July update :slight_smile:

1 Like

Cannot open the file with 7zip. :thinking:

I think this mod with a touch of reshade would finally push the graphical fidelity of H2 beyond that of Season 1.

A few things I have noticed:

Embrace of the Serpent looks really wacky with Depth Fog off. Lots of the terrain looks very sloppy and unfinished (fair since nobody was supposed to see it anyway). Lots of other distant geometry looks a little strange as well with it off (the skylines in Bangkok and Miami, mountains in Sapienza etc).

The Bank looks a bit less imposing without God Rays. It doesn’t have the same incredible effect of height that it does with the rays.

However the fact remains that this mod makes every map (especially the legacy maps) so much more playable without having to spam instinct everywhere just to navigate a few rooms. Absolutely outstanding!

It opened fine for me in 7zip :thinking:

Maybe your file didn’t download properly?
Try to redownload it

Did not help, dunno why. If someone would be so kind to repack it and reupload it, or else I look for other tools to open it.

EDIT: Different tool works.

I would not recommend playing with this option off. Only reason I put the option was for testing purposes. I encourage people to experiment. That’s why I made it possible to gradually turn things down. And the d3dx.ini is super easy to modify the values. :slightly_smiling_face:

Find that the first value works great for Sapienza and not the Bank? Key 5 is there as an example for this use. You can add a value to the end of each line under [Key5], making it cycle between 4 presets.


; Custom Cycle (Or Toggle)
Key = 5
type = cycle 
; Bloom
x = .15, 0, 1, 0
; Lens Flare
y = 4, 5000, 1, 5000
; Light Decals
w = 1.5, 6000, 1, 6000
; Sun Rays and Distant Fog
z = .65, 0, 1, .65

Works with WinRAR. Just tried. Unpacked with no problems

1 Like

Great work. Sadly by now I fought my way through the hallways of whiteout and doorframes of enlightenment many times already.

The direct comparison shots still show the ridicolousness of it as on release.

1 Like

Update 1.1:


Whoops I hit the wrong one just say I did post lighting effect

I’m on Xbox so I can’t really can’t have too much of an opinion here but I feel like the picture without the post lighting look the best. What i also think is that some maps like Mumbai and Sgail benefit from this and they were built with this in mind but this can still hinder gameplay, specifically aiming. I feel this should either be removed entirely or only from the legacy pack.

That is how I feel with legacy vs 2018 lighting overall. Even tho 2018 has its “too much bloom” problems it seems like from colors/saturation it was build from the ground up whereas 2016 looks like “change for the sake of change” but they kinda butchered it.


I know it’s a minor inconvenience, but would it be possible to have the effect load immediately instead of having to press 5 to enable it? It’s just one of those things that I always forget and when I load up a level or a save and I have to do something else before I can start playing.

Honestly I quite like the way a lot of the levels look without fog, It almost gives the quality of a really deep DOF. However I just wish IO would have made the background terrain in places like Santa Fortuna a little prettier and more finished because it’s a really nice backdrop to the level. Of course my current setting has it on 0.3 and everything else off.


They are the very first values listed. All the 1s.

Side note for everyone that uses this. On the updated d3dx.ini I forgot to put the [Hunting] setting to 0. While hunting is technically off, it can still be toggled with keypad0. As far as performance goes, I’m not sure if having it set to 2 is the same as having it be 0.


I’ve been playing a bit of a contract in the Sapienza Lab cave and it’s pitch black
Does this lighting mod fix that? I’ve been playing on DX12 which this mod doesn’t work on, but this is tempting me to go back to DX11 if the mod fixes this… it’s ruining my speedrun attempt because I keep running into boxes rather than down the path, and keep hitting space next to a wall instead of on the edge to climb down

It does not fix that, sadly.
You can only use Nvidia game filters to have everything brighter.

What is causing Hitman 2 to open automatically when using this mod?

I want to switch between DX11 and DX12 (for performance reasons) but I can’t because the game opens automatically without giving me a chance to select any options in the launcher.

This also means that after a fresh install, if I last played H2 with DX12 before installing the mod, it will not work, forcing me to uninstall the mod, switch in launcher to DX11, and reinstall the mod before it will work.

If that’s what works for you, then just do it. :upside_down_face:
Welcome to the world of (jumping through hoops for your desired custom experience) PC gaming! :smirk:

But seriously, I don’t have this issue, and can’t imagine why it would be doing this. Hopefully someone else can help you figure it out.