Hitman 2 - constant crashing with 0x80000003

#299

Don’t forget to always be respectful when addressing the developers of this game.

Just because you paid money for the legit copy of this game, doesn’t mean you deserve to play it.
They will decide that for you.

Maybe go back to pirating… since you at least get what you pay for??

#300

Maybe go back to pirating… since you at least get what you pay for??

Maybe that’s the solution - we paid to play a game, and it’s incessant crashing is stopping us from doing so… essentially, the question now is - what the fuck did we pay for???

3 Likes
#301

Any updates on the Crash problem? And do you think about restarting the ETs? Some of us missed them because of Game related Issues.

1 Like
#302

Tested your last Idea with only 1 Audio Device(and all other above) and could play 15 Minutes (ET) without a crash. I will test it later with the Snow Festival. Thanks a lot Dude.

#303

Apparently they removed the Denuvo copy protection today, i’ve definitely seen that cause issues with games before. Wonder if that helps with this? :stuck_out_tongue:

#304


Nope still the same bullshit.

#305

Damn, i really wish they fix this issue already :sob:

#306

Typical, well least the game loads quicker now. So we can get to the crashes faster. Horray!

#307

Hi

I can confirm that if I disable the picture in picture option, then it works without crashing…

#308

Add me to the list of people suffering from this. Moving the game, Playing with various settings, and somtimes but not allways restarts have provided temporary relief.

Also i had it corrupt my graphics driver one time, (which caused several lockups that required a hard reset to fix), and the crash bluescreened windows 10 once as well.

Don’t know what the error code means exactly so not sure how relevant what else i have running might be but i’d be willing to screenshot my taskmanager contents if that would help.

#309

We still cant play… hellooooo? Devs? Are you still alive? There was a Problem (0x80000003)… you remember? Hitman crashes all the time. You wanted to fix it… i dont know… buuuut… its about time we hear something from you, dont you think? I mean… its about 3 Month since we bought your game… with money… the stuff with the little numbers on it… remember? That stuff that grows on threes…

4 Likes
#310

With Denuvo removed and PIP disabled, the game isn’t crashing with 0x80000003 anymore (so far).

However it still crashes with 0xc0000005 (Offset: 0x000000000027cc2f) after playing a map for a couple of hours, the NPC’s get confused and just stand there while staring at an item/gun on the ground indefinitely, and other glitches start happening, then it finally crashes. So that memory leak/corruption problem in 2016 still exists in 2018.

#311

…spoke too soon. It still crashes with PIP disabled and Denuvo removed. Driver 417.71

Faulting application name: hitman2.exe, version: 2.13.0.0, time stamp: 0x5c49a4cb
Faulting module name: hitman2.exe, version: 2.13.0.0, time stamp: 0x5c49a4cb
Exception code: 0x80000003
Fault offset: 0x0000000001163fa8
1 Like
#312

Crashes seem to happen less often for me but they still occur. I was lucky enough to be able to complete the elusive when it’s usually the map where i crash more often. What do you use to identify what error crashed the game?

#313

Open the windows searchbar -> search Event Viewer -> Windows Logs-> Applications

1 Like
#314

Whittleton Creek doesn’t crash anymore after Denuvo removal.

#315

Whittleton Creek crashes just sometimes. Its like Miami. Something with this Maps is different.

For me:

Hawkes Bay: No Crash
Miami: No Crash
Santa Fortuna: Crash every 30 Minutes to 1 Hour
Mumbai: Crash every 10-20 Minutes
Whittleton Creek: Crash every 2-3 Hours
Isle of Sgail: Crash every 5-15 Minutes

Also the Crash seems to get triggered by events. Sometimes i have the feeling its something with the lightning. 7/10 times my game crashes there was a light source nearby. I dont know.
I tryd to recreat a Crash by playn a fresh game exactly the way before but it seems pretty random.

Turning down the Graphics seems to delay the crashes a little.

After a fresh restard of the Computer and starting the game just after windows booted seems to give you more playtime.

#316

I currently download a new NVIDIA driver (418.81). Just in case people want to try that out and it randomly fixes the issue. Can’t tell as I have no problem with crashes.

1 Like
#317

No no fix with the new driver…

1 Like
#318

I’m kind of curious about something, has anyone with Windows 7 or 8/8.1 suffered this problem?

1 Like