Hitman 2 - constant crashing with 0x80000003


Thanks god I am too poor to get a new gpu I guess.


Thanks for that. Wish they’d give us some technical info on whats going on. Just curios tbh.


It can be counterproductive to call NVIDIA out in the public if they (to some degree) are at fault for this. Better work with them in private until the solution is done.


It would be nice, indeed. But IO never talk about internal issues, especially since RTX features seems not ready at all on both developers side and nvidia. Look at shadow of the tomb raider.


Havn’t played Shadows of Tomb Raider yet, but does it also suffer from crashes that are related to RTX series?


Eidos Montreal fix thoses RTX crash with Nvidia in december (Hotfix Driver Version 417.58). But it’s probably a totally different issue.

what I mean is that the RTX features are still not implemented in SOTTR.


Same Xbox one x …


This is very strange…

I was experiencing this anoying crash-to-desktop bug when playing the History mode missions.

However I was able to play during last days on one of those “featured contract” missions without issues.

I though that the issue was fixed so went back to history missions and then the issue came back too. So in summary, in my case this is only happening with history missions.

I have improved the experience by doing this:

  • disable nvidia overlay (on the nvidia experience pannel)
  • diable picture in picture

Now crashes are less often (about 30min - 1h) so I’m able to play in a reasonable way…

I have a RTX 2080 Ti with no OC

This is the error on Windows Event, sorry it is in spanish:

"Nombre de la aplicación con errores: hitman2.exe, versión:, marca de tiempo: 0x5c49a4cb
Nombre del módulo con errores: hitman2.exe, versión:, marca de tiempo: 0x5c49a4cb
Código de excepción: 0xc0000005
Desplazamiento de errores: 0x00000000000f521b
Identificador del proceso con errores: 0x1704
Hora de inicio de la aplicación con errores: 0x01d4bfc091c79702
Ruta de acceso de la aplicación con errores: D:\Program Files (x86)\Steam\steamapps\common\HITMAN2\retail\hitman2.exe
Ruta de acceso del módulo con errores: D:\Program Files (x86)\Steam\steamapps\common\HITMAN2\retail\hitman2.exe
Identificador del informe: d24eb3d4-ab68-4f41-9d1e-ac26ebb99085
Nombre completo del paquete con errores:
Identificador de aplicación relativa del paquete con errores: "


[spoiler] Hi All,

I was having this issue and turned off the nVidea overlay in the nvidea experiance app and now its not crashing.

Hope this helps [/spoiler]

Never mind that only worked for one mission then it started again :frowning:


You’ll get this a lot, fiddling with a setting will cause it to go away for a little while then it will come back.


mines constant crash no error


To get H2 to be stable (on PC), I need to:

Relax the RAM timing (disable XMP, use JEDEC timing instead).
Play in Windowed mode.
Enable VSync

If I enable any one of those three things, H2 crashes about every 15 minutes.
Disabling all those things allows me to play H2 for 2 hours+, no crash.

Reloading a save game too many times also makes the game crash. So if I reload a save more than five times, I restart the game and reload to avoid the game from crashing. Seems like the game has a memory leak or something…


Interesting as i am also using XMP’d memory…

Trident Z 3200mhz CL14 for the curious.


I fixed it with my 1080TI.
Install MSI Afterburner and reduce the Core Clock about -15Mhz. No crashes anymore.


Might not help too many people - I have the CTD bug and I don’t even have Nvidia experience installed.

…but it’s definitely a thought. I remember GeForce experience plagued a lot of Far Cry 4 users with crashes, and it made a difference uninstalling GeForce experience.


The game seems to not have any crashing issue with Vulkan renderer on Linux with Nvidia Driver and my RTX2080.

Nvidia Driver : 415.27
Vulkan : 1.1.84
DXVK : 0.80

So far so good. I will continue to test on Linux, one more week. Game continue to crash multiple times per week (or even per day) with Windows 10 and DX11.


Why can’t Windows users use Vulkan instead of DX ?
It’ll probably fix this 0x80000003 crash…


Linux version use Steam Proton, which uses DXVK (Vulkan-based translation layer for DirectX 11). I do not think there is an equivalent project on Windows.



I’m a bit fed up of waiting on this to be fixed, to be quite frank.

IOI I am going to strongly consider never buying another one of your products again. This is ridiculous.

What a let down.


I agree. That’s a real shame. We’ve had this bug since the launch in november, now that’s february and nothing has changed, that’s not acceptable.
And even if the bug would be fixed in the future, we won’t be able to play older elusive contracts, that’s absurd