Hitman 2 - constant crashing with 0x80000003


#41

Not sure, I just attached the process and the game stopped crashing. I didnt change any settings.


#42

Hmm maybe I should try the nVidia driver that I was using on the 9th because that didnt crash at all.
Not the driver before 416.94, the one before that.


#43

I rolled back my nvidia driver to the one in the mid-2018 - same thing.


#44

Have you guys tried to deactivate your firewall? Friend of mine managed to play hours without any crashes because of it, especially the Windows Defender in win10. I haven’t tried yet.


#45

@JayE Okay I figured out the trick, I added 0x80000003 in Win32 Exceptions list and unchecked the box. Now when the exception is raised, VS2017 catch it and the game continue to run and no more return to desktop effect. I will use this solution until a fix is set up by IOI/Nvidia.

image

And before to close the game, do not forget to detach the process.

Back in the game :cowboy_hat_face:


#46

Nice
-20 characters-


#47

I tried your method with 0xc0000005. Unfortunately 0xc0000005 is a memory violation, and it’s so high risk that Visual Studio refuses to continue the execution. Too bad for the 0xc0000005 sufferers.


#48

Yeah I don’t think this method works with this exception, but you can try it :slight_smile:
The first time exception occur, uncheck the box and detach the process, the game should resume, then re-attach it. Save the project solution to keep this behavior.


#49

Attaching hitman2.exe to VS avoided a 0x80000003 crash for me today.
I doubt IOI would send the PDB file to us but I would be happy to load it and send the crash debug info to them.


#51

(I deleted the last message by error. Undo doesn’t seem to work)
Same issue here :
image
Added :
My config is :

  • Core i7 9700k
  • 32 GB
  • Nvidia GeForce RTX2080
  • W10 Pro

4 days ago, before my migration to my new desktop (with fresh install) , it worked without any issues. It was

  • Core i7 4790
  • 16 GB
  • Nvidia Geforce RTX2080.
  • W10 Home
    I guess it is the new drivers caused this crash.

#52

Visual Studio captured the 0x80000003 breakpoint and provided this info:

D3D11: Removing Device.
Exception thrown at 0x00007FFF6E65A388 in HITMAN2.exe: Microsoft C++ exception: _com_error at memory location 0x000000002D7C5710.
Exception thrown at 0x00007FFF6E65A388 in HITMAN2.exe: Microsoft C++ exception: _com_error at memory location 0x000000002D7C71D0.
Exception thrown at 0x00007FFF6E65A388 in HITMAN2.exe: Microsoft C++ exception: _com_error at memory location 0x000000002D7C7500.
HITMAN2.exe has triggered a breakpoint.

#53

So, do we know any reason for why this is happening yet? Memory related?


#54

I assume something has a debugging breakpoint in the code. Could be the game, Denuvo, nVidia driver, DirectX, VC Redist, or something else. Most likely the game or the nVidia driver.


#55

second rtx 2080: same issue. We need someone to fix this issue, the game is unplayable for me at this time


#56

If its happening a lot, install nVidia driver 416.34
If it still crashes, install Visual Studio community (free) and attach the hitman2.exe process, then untick all the exceptions in the list at the bottom right. VS will allow the game to continue when it crashes with 0x80000003.


#57

Ever since this problem occurred, I have noticed my laptop running very hot while playing games or intensive tasks. I am now also noticing crashes in other games like Skyrim. Also, my temps are running high, as high as 90C.I got a RADAR_PRE_LEAK_64 error when Skyrim crashed. I suspect there is some fault in either the hardware or core system files.


#58

Thanks. Will try the Visual Studio Trick.

For info, I don’t have a RTX but a GTX 970.


#59

I tried this, and it broke my computer so bad I literally had to reformat my SSD/HD and start over with a clean install of Windows.
I have NO FUCKING CLUE what happened, but when I attached the process, unticked all the boxes in the Exception pane, and tried to play, my GPU started crashing every few seconds. Even if I turned the system off completely and tried to do things other than game, hell even after I UNINSTALLED Hitman, the computer would still crash to black after about 10 seconds.
Now here I am, after a fresh install and newly updated drivers, and I still get the fucking crash to desktop when I try to load a mission in game.


#60

I would advise not playing around with Visual Studio to force debugging system drivers unless you are an IT guy.
You may have altered a proper usage of the OS, which is, by the way, using a lot of .Net DLL’s.

Status on the 20/12/2018 :
Unfortunately, I installed the 417.35 on the 15th of December.
I’ve just checked my logs, and the last crash of the game happened the 16th of December. I didn’t play it after.
(RTX2080 for the record)


#61

This seems to work for me as well on my 2080. It is not an ideal solution, but it at least stops crashing to desktop until IOI/Nvidia comes up with a patch.