Hitman 2 - constant crashing with 0x80000003


#62

RTX 2070 here. Latest drivers. Get a 0x80000003 crash 10-20 minutes of gameplay every time without fail. Hope this gets resolved soon.


#63

I think 417.22 driver fixed 0x80000003 issue. After 25 hours with this release, i don’t have crash anymore. Then I tried 417.23 hotfix, no crash and “black pixels shadow” bug fixed.

I recommend you to test it :

https://developer.nvidia.com/vulkan-beta-41723-windows-10

EDIT 12/10 : issue not fixed, crash again…


#64

I didn’t start getting 0x80000003 crashes until the 417.22 driver, so it obviously didn’t fix it for me. I’ll give 417.23 a shot, though.


#65

I’ve just noticed something strange. Sometimes just after I reload a save (auto or manual) I see the message “OBJECTIVE COMPLETED” even if I didn’t do anything at all in that level, even before the reload of that savegame. If I reload a second or a third time, the same message sometimes appears, other times not. I wonder if all these crashes have to do with an issue with the save system (maybe even with achivements unlocked in a previous run in the same level but that aren’t yet “assigned”)


#66

Which level would this be? Isle of Sgàil has an ongoing objective, the “don’t kill X”, which is completed by default. When I reload I get the pop-up for it as well (it’s greyed out from the second load onward). This is just a minor issue, probably not a matter of driver problems.


#67

I tried the Visual Studio method too, but probably didn’t set it up properly (added the exception under Win32, unticked it), but it just made the crashes harder to get over. Tried it with the last three driver updates as well, but the issues keep popping up (with or without VS). At least it’s a bit better now, it’s not every 5 minutes for me and it can evem run for 1-2 hours occasionally. Hope they tackle the issue finally with December patch, I’m not looking forward to start the Elusive Target over and over due to crashes (I do it to get SA enough already).


#68

It’s the three headed serpent level. I start it, move around, then it saves automatically. after the reload of that savegame, I get that message.
I even had a savegame that 8 out 10 times it would crash within 2 minutes from the load. I managed to complete the level and now that same savegame is not crashing anymore


#69

417.22 seems to have fixed this crash for me with an RTX2080.
So I guess those who have an RTX card should use 417.22
…and those who have GTX cards should use 416.34


#71

Update: I decided to run it without VC, 417.23 definitely does NOT fix it. (Same error) Also I have a sneaking suspicion the Picture in Picture part is what crashes the game. because thats what happened right as it crashed. The square for Body found popped up, with nothing in it. Crash.

It has nothing to do with firewall either, need to run it with the VC trick and see if it still happens.

I’ve been having this trouble too with my RTX 2080

on various drivers: 417.01, 417.35

I can sometimes play for ages without it happening but when it does the picture just freezes, I don’t get a black screen - it just stops. eventually it closes itself. I am left with the same error as you guys

Exception code: 0x80000003

in Windows Application logs and Nvidia Driver has stopped responding and has recovered in system logs

I am trying 417.23… This game has a lot of problems with nvidia cards, before that it wouldn’t render water properly (they released a hotfix for that too) then there was the black spots everywhere bug.

I also tried the VC trick at the same time, I was able to play through a short mission without incident but I don’t know whether thats because one of the things I did fixed it or it was just dumb luck.

Please FIX this IO


#72

Does 417.22 crash for you?
I know 417.22 has graphical shader/lighting gltiches in a couple of levels but at least its stable for 2080 cards.
I havent tried 417.23, I dont want the game to start crashing again…


#73

I haven’t tried it but I am absolutely confident that it does crash with that driver because i’m convinced that its not a driver problem.

I’m also convinced of that because no other games have this problem, it is definitely a bug with Hitman 2 specifically.

The more of a rampage you go on the more unstable the game gets, if you’re not getting crashes you’ve gotten really lucky because it doesn’t always happen.To test it properly you need to start a mass killing spree, trigger as many body found windows you can. No subtlety. I found the more this happened the faster the game crashed.

Using VC it seems to be stable, but again that could be due to dumb luck too.


#74

I think it’s a problem in the game that triggers something in the nVidia driver.
Other games run fine, no crashing with 0x80000003 at all.
I think nVidia may have created a workaround in their latest driver to overcome the problem in Hitman2.

I also get crashes when going on a rampage, but it crashes with 0xc0000005, not 0x80000003.


#75

They haven’t.

It doesn’t matter what driver I use, I stated I already tried the latest one and had the same result.

0x80000003. i’ve had 0xc0000005 as well, but not as much as 0x80000003

I could be wrong but I definitely think the Picture in Picture has something to do with it.


#76

I agree, I’m still having crashes with the latest 417.35.
I think it’s game/savegame related, also because the game is crashing exactly a second before the timeout driver recovery so it’s the game’s crash that is causing the tdr, not the opposite.
I also tried the visual studio solution without success
There’s a big thread on steamcommunity too https://steamcommunity.com/app/863550/discussions/0/1742226629859203445/


#77

For those who have the 0x80000003 issue, can you try with Level of detail set to medium ? I think it helps to have less crash.


#78

I think that if it does it’d be a placebo, because the crashes are completely random - also the guy on steam is running the game on low and still reporting the error.

Sometimes they happen after 20 minutes, sometimes after an hour, sometimes not at all.

Also can confirm VC does not workaround the crash. I was playing the Chasing a Ghost level and it just froze with this in the output:

D3D11: Removing Device.
[kbf] Skipping crowd update because no free animation state
[kbf] Skipping crowd update because no free animation state
Exception thrown at 0x00007FF98E9EA388 in HITMAN2.exe: Microsoft C++ exception: _com_error at memory location 0x0000000030055710.
Exception thrown at 0x00007FF98E9EA388 in HITMAN2.exe: Microsoft C++ exception: _com_error at memory location 0x00000000300571D0.
Exception thrown at 0x00007FF98E9EA388 in HITMAN2.exe: Microsoft C++ exception: _com_error at memory location 0x0000000030057500.
HITMAN2.exe has triggered a breakpoint.

I never actually did anything but walk around so i’m pretty confused. Game is unplayable. I’m going to play something else and hope for a patch. Fantastic Job IO.

It’d be nice if at least ONE of the devs would acknowledge these threads. My favorite game at the moment and I can’t even play it, I’m extremely mad about this.


#79

Do you have any information to share about this issue ? @Travis_IOI @Clemens_IOI

Should we expect a fix with 2.12 update next week ?


#81

I played for 20 hours with 417.22, no crashing at all. Seems super stable now.
I haven’t tried 417.35 or anything else after version 417.22.
Maybe the problem has been introduced again after 417.22… at least on 2080 cards. Maybe its a different story with 1080 cards and earlier cards.
(Ultra settings)


#82

Well I’ve been running on level of detail medium all this time so I know thats not the solution

Thats the nature of random crashes, just because you can sometimes run it for an hour without problems doesn’t mean the problem has gone away. I can also play without crashes sometimes…

Is SSAO on for you, I have that on. I run level of detail medium for performance. Might try to turn it off

Even if you were right they should still fix it. I’m not letting them off with it

Random crashes are infuriating.


#83

did you do anything alse besides using 417.22, like updating other system drivers, changing something in the bios, uninstalling some software?