Hitman 2 - constant crashing with 0x80000003


#124

The silence from the devs is just sad. If they don’t fix this soon i’m done with their company and i will make sure everyone i know stays away from it.

I guess they shadow banned this thread to avoid bad PR and people not buying their game.


#125

Nevermind that, for some reason I had the thread ‘muted’, I don’t remember doing that. That apparently hides the thread?


#126

Thought Hokkaido was fine but it crashed at the usual fault offset 0x0000000001150925

IO please look into this issue :persevere:
Maybe you could check if your shaders have breakpoints in them and put a try{}catch(Exception) around the CreateShaderResourceView() method.


#127

No crash since 3 days with my old GTX970, game run just fine. And the framerate is more stable than with my RTX2080. I did not change anything else on my computer.


#128

Then, do you think it’s a hardware issue? Are you going to stop using your RTX card only for this game? Or are you going to return it or process an RMA?.. I still have my GTX 1070 G1.


#129

For now, I only test how the game behaves with my GTX970 until the next patch, I’m not going to return my RTX card, no way :sweat_smile:

This is not a hardware problem. Game instability seems proportional to the GPU’s perfs, that’s actually what I notice.


#130

this is not an hardware issue, for me it happens with two different rtx 2080


#131

Its not a hardware issue. I can run all other games fine on my 2080, and 1080 owners are also seeing this 0x80000003 crash.


#132

Hey. I have this problem too. Hitman2error
I have a RTX 2080 from MSI. I have this Problem in Hitman 2 and Shadow of the Tomb Raider (not so often than in Hitman2). Its very annoying. Its the app crash before the Nvidia Driver Crash ?. If i look at the error times is exact the same for me. First i think its a unstable OC but i change back to stock and problem not solved. I test fullscreen mode …exclusiv mode and all other what i can read on forums…nothing help. I have 2 monitors on my card…one with g sync and one normal… …other games like Battlefield 5 or 3dMark stability tests i can play without any problems. Driver is 417.35 and all my other drivers or bios its up to Date.


#133

I see what you mean with the Shadow of the Tomb raider thing, that’s error code 0xc0000005, I regret getting the RTX 2080, worst decision I ever made. Should’ve just got another GTX 1080

edit: alright maybe overreacting a little, seems to effect quite a lot of people, its a DX12 issue… apparently setting the game to DX11 fixes it.

I’ve tried putting my RTX 2080 to stock speed and it changes nothing for hitman 2. Shame theres no option for Hitman 2 like tomb raider.


#134

hmm…I do not know yet if my problem is now completely fixed but today i can play 3 hours Hitman 2 without the error. Maybe it’s just luck, I do not know yet.
I download the Nvidia Driver new but not from Nvidia Website directly. I use Geforce Experience and install driver 417.35 new about the program. If the problem occurs again, I’ll write here in forum …


#135

I think Chrome messes with my gaming somehow - because with hardware acceleration on and it being open at the same time as some games it makes them juddery, I disabled chrome hardware acceleration and the stutter in shadow of the tomb raider disappeared.

going to try Hitman 2 again

I also underclocked my gpu by 150 so maybe that has something to do with it too, i’m not expecting the problem to be gone tho

Edit: Nope, no improvement. Still crashes.


#136

(1f9c.213c): Break instruction exception - code 80000003 (first chance)
hitman2!CAkMixer::MixOneInNChannels+0x44d035:
00000001`41150925 cc int 3

Got this for debug info. AkMixer eh?

Another member on steam got this as well when theirs crashed.

I think I figured out the fix, or A fix, if this is the problem

Go into your audio settings, disable ALL of the audio devices but the one the game is going to use, you heard me, disable them all. Hopefully the game is more stable for you now, I think it is for me.

When the game was running I switched off a device that wasn’t in use and the sound blipped so its definitely doing something with those other devices.


#137

Until the next crash :rofl:


#138

Its definitely improved things for me. It might not be the only cause of crashes but its definitely one of them.

Ark is way more stable now…

by the way my audio crash has the same offset as your shader crash…

Its likely only a fix for half the issue at most.


#139

Which map was most affected by this audio error ?


#140

The Ark Society is the map I was getting that in


#141

I’ve never had that (which explain why Ark Society is stable for me), I have d3d11!CDevice::CreateShaderResourceView only at offset 0x1150925. Would you like to take a screenshot of your audio devices ? To compare with me.


#142

What level still crashes and what are you doing in it?

Notice i’ve disabled all but 1


#143

Me :

image
image

Mostly Colombia (multiple crash per day, even per hour). Miami and Mumbai sometimes (multiple times per week).

But no crash since 4 days with my old GTX970. I wonder if you should try to downclock or limit your GPU (I do not know if it is possible easily), just to try. Maybe there are two root causes for 0x80000003 crashs, sound and DX11 rendering instability.