Hitman 2 - constant crashing with 0x80000003


#144

I already have my gpu set to -150, i’ll try colombia

yup, that level still crashes.

Right, I’m giving up for now, I’ve said that a few times but I mean it this time. Until a new game patch or NVidia driver, i’ve done all I can.


#145

I’m giving up too. To resolve this issue (crash on CreateShaderResourceView), I just reused my old card, nothing else has changed, I have the same OS, same drivers, same bios, same settings, same Windows configuration. So it’s definitely a driver problem, we can’t do nothing to fix that.

An OS or hardware issue can be easily fixed by the user, a software problem it’s more complicated but it’s still possible with some tweaks or mods. A driver problem is the worst, because it requires to have a low-level knowledge between hardware, constructor logic and game engine architecture.


#146

It is unbelievable that IO still hasn’t acknowledged the issue, and still hasn’t said anything at all.

We bought the game and we can’t play it ffs


#147

I’m coming in to echo the concerns about Hitman 2 CTD w/o error messages. It is constant and completely random; sometimes I can make it through an entire mission, other times the game is instantly crashing every 30 seconds to a minute of attempted play.To ensure it isn’t the savegame bug, I’m always playing on fresh saves at this point.

I’m on the latest drivers on an RTX 2080, and feeling especially frustrated because RTX advertised DLSS implementation for Hitman 2 as a particularly appealing reason to early adopt, yet it seems to have mostly rendered the game unplayable.


#148

OK Guys I may have fixed the crashing issue. I was getting crashes anywhere between 0 - 15 min.

I have been playing for 5 hours straight today and not a single issue!

I disabled all non used sound and communication devices
I closed Nvidia Experience
I closed MSI Afterburner
I closed F.lux (this might be it)
and I operated the game in borderless window mode

I am running on the latest Nvidia drivers on an MSI RTX 2080


#149

we’ve narrowed down the bugs to a couple of different issues

  1. There’s the shader crash that occurs in Colombia? and maybe other levels
  2. There’s the AKMixer crash that occurs in Mumbai and The Ark Society

I’m not sure if anything you did fixed the first one Mouldy, I’ve never used f.lux installed especially.

Some levels are more stable than others

I wish they’d have done an episodic release of this instead like season 1. They’d have had the time to test and debug each level properly


#150

Ca’t say it was level specific for me Scotty. Mine happened anywhere at anytime. During the tutorial, on the first missions, even once in sniper mode!

It was really frustrating as usually someone comes up with a fix via google ~ At this point mine runs without a single hiccup since I did the above steps :slight_smile:


#151

That’s good, but keep an eye out, if you get any more crashes note down what level it happens in

I got a crash just now in the Colombia level after about 30 seconds doing all that, and again…

Third time, did -200 in msi afterburner (I had it closed during first 2 tests btw) and its lasted a bit longer, that doesn’t prove anything though.

…and crash again, nothing to do with my gpu’s clockspeed then.


#152

Hmm I set “Override Memory Safeguards” to ‘Yes’ in the Hitman2 options and the game seems more stable.

Although it did crash with 0xc0000005 in Ghost Mode Miami but I think that’s a different issue altogether.

I have f.lux installed, I’ll uninstall it and see how that goes.


#153

Just had a crash within 1 sec of loading on Sapienza

Had previously loaded the game at least 20 times before a crash though.

I too had “override memory safeguards” enabled.

If I can get 6+ hours out of a session before a crash that’s pretty good :slight_smile:

I will continue to experiment and see what happens


#154

I thought maybe to try putting 2 separate power cables to my GPU just as a final bit of due diligence on my part, it still crashed in Colombia, pretty sure its not an overclocking or power problem.


#155

If you get crashes in Colombia, get WinDbg and attach it to hitman2, you’ll also have to tell it to go from the home menu … make sure to go this AFTER the configuration box shows up, don’t try to run hitman2 directly from windbg. it won’t work

Interesting I just got the stall that usually happens in this level, but it lasted a second and the game just went on, so the game is defying my attempt to debug it

But I can still play it so…? yay?

I don’t get any errors, I just get the usual stall, it lasts a second… game goes on.

Edit: nevermind, got this

(2038.1e40): Break instruction exception - code 80000003 (first chance)
hitman2!CAkMixer::MixOneInNChannels+0x44d035:
00000001`41150925 cc int 3

Thats with only one audio device enabled, so that proves my earlier theory wrong… unless recording devices also matter? I’ll disable those too, blah.

I also set my sound card enhancements off and audio to 16bit 48000hz, I don’t know if its better or not yet, i’ve been farting about for a while in Colombia

–i’ve never seen the shader crash yet


#156

Maybe you need to update your Sound card driver.
Or uninstall it and let Windows Update install the latest driver.


#157

it seems to be more stable already, SEEMS. I bet it still crashes on me XD

Its definitely a lot more stable now, I can actually play the game now - no crashes yet but that doesn’t prove anything


#158

When I was playing I got a body found message with an almost completely black box, it didn’t crash (maybe because I have the debugger active) but that seems like a bug too. Could be related.


#159

No crash since 5 days. #Team GTX970 :muscle:

RTX2080, I will never forget you :sob:

Please IOI, bring muscle RTX cards back to the game :pray:


#160

I can’t get the game to crash with 0x80000003 anymore after doing these two things:

  • Changed the H2 option “Override Memory Safeguards” to ‘Yes’
  • Uninstalled f.lux

Before I could get it to crash everytime simply by using nVidia Ansel in Colorado, and also knifing someone in Colorado in the first few minutes.
But today I used Ansel a few times and knifed the whole map… no crash.
I played ghost mode for a few duels… also no crash (although it did crash with 0xc0000005 because I picked up lots of items).


#161

First off, thank you to everyone who’s offered their input. It’s frustrating when you get a new $400 GPU that crashes your games minutes after it’s installed.

I upgraded from a GTX 970 to an RX 2070. I was getting crashes in Santa Fortuna after no more than 1-2 minutes of game play; sometimes in as little as 10 seconds. I never had a single crash with the 970 after dozens of hours of game play, so the 2070 installation was clearly the factor that triggered the problem. I uninstalled the old driver, and downloaded the newest driver fresh from the web, so outdated drivers were not a factor. I played the Miami and Sapienza missions for about 30 minutes apiece, and had no problems. The problem therefore seems to be limited to Santa Fortuna. I did not try the Ark Society Mission.

After trying several suggestions listed above, I disabled the audio on the GPU via. the Sound Control Panel. For good measure, I also disabled the digital RealTek drivers for the built-in sound on the motherboard, since I have analog speakers. With no other changes made, I was able to play the Santa Fortuna mission for a few hours with crashing, or even a single hiccup. To be fair, the Realtek drivers could be the culprit. I’ll test this tonight. I’l also play the Ark Society mission to see if that causes any problems.


#162

Glad to hear the Audio suggestion helped a bit, I am a bit baffled by that myself because I haven’t changed any of my audio stuff since putting in my RTX 2080 so it really doesn’t make sense to me, unless there is a conflict between realtek stuff and the rtx 2080’s audio chip? Who knows.

definitely seems to be more stable with the audio stuff disabled.


#163

Inventory to full or “bad” items in it?
I had stolen all that stuff in the Ark mission and had plenty of weapons with me. I was close to the end and all my savegames start to crash instant or after a few secounds with 0xc0000005. I was able to load a savegame which didn’t instant crash and threw away most of the museum items and all the big weapons. After that I was able to finish the mission wihtout any crash.
Maybe that helps someone…