Hitman 2 Crashing with 0xc0000005

I am facing the same crash issue with Ark Society mission. Did not face any issue until I spent about 4 hours on the mission. Updating to the latest nvidia drives did not solve my problem. Hoping for a fix.

The game crashes moments after loading a save game in the Ark Society mission. The game worked perfectly fine until this last mission. It might be happening due to the large time spent on the final mission and probably the save file is large. I had spent approximately 4 hours on this final mission without having any issues and am suddenly facing this game crash problem now on loading saved files. I have the latest driver version.

Error logs

Faulting application name: hitman2.exe, version:, time stamp: 0x5bec3527
Faulting module name: hitman2.exe, version:, time stamp: 0x5bec3527
Exception code: 0xc0000005
Fault offset: 0x000000000ec14f8d
Faulting process id: 0x33cc
Faulting application start time: 0x01d47f3de322edb2
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\HITMAN2\retail\hitman2.exe
Faulting module path: C:\Program Files (x86)\Steam\steamapps\common\HITMAN2\retail\hitman2.exe
Report Id: ee4425c2-5f12-4df8-84e2-7236f5a6a6a1
Faulting package full name:
Faulting package-relative application ID:

System config

Windows 10 64 bit
Processor: Intel® Core™ i7-6700HQ CPU @ 2.60 GHz
Nvidia GeForce GTX 960M
Total available graphics memory 12217 MB
Dedicated video memory 4096 MB GDDR5
DirectX runtime version 12

@Bjarne_IOI @Torbjorn_IOI


Having same problem here on Mumbai.

Game crashes right before i get to Dawood Rangan.

He is on the rooftop actually, and game insta crashes few seconds after i’ve reached him…

I’ve managed to temporarily escape the problem by having less NPC interactions or items and going straight forward to the target.

So it might be related to that kind of “limitations” by the game who make it crash?

Too much bodies on the map? Too much in inventory? A Dawwod scripted event is broken?

So much theories not much answers…fun thing is that save will crash at exact same time no matter what you do (even not moving or getting away from building lol).

Game got fixed a bit thanks to latest hotfix, but it seems that this problem is recurrent for lots of players :confused:

Hoping a patch soon…


I have the same problem in Miami and the steam forums are also full of people having the same issue.

I’ve read into what 0xC0000005 actually is and it seems it’s one of those things that are pretty difficult to point down, especially in a big and complicated app like Hitman.
Let’s hope they fix it before the first ET arrives.

1 Like

0xc0000005 errors are usually ms c++ runtime issues. I would recommend u installing all runtime packages and start reinstalling them from the earliest onwards.

Yeah, hope they fix it ASAP. It is so frustrating not being able to complete the last mission.

I think it might be related to the recent hotfix.

Anyways, multiple people are facing the same issue. Hope they release a patch ASAP.

@Lasse_IOI @Travis_IOI

It can’t be connected to the recent hotfix because the hotfix was released on friday, but I have this issue since tuesday. It also seems not to be ralated to a specific mission because I’ve read about too many different cases of occurances of this 0xC0000005 error in just about every mission. On the other hand the more crowded the mission is the more likely it seems to occur. I can’t honestly remember to have read about anyone having this problem in Hawke’s Bay.
As for “crashing after loading”, there was also this other post I unfortunately can’t find anymore, there was a guy who tried to run the game with a Radeon and had no CTDs, but he still had an exception registered in the Windows Event Log. As I wrote in my post where I was describing my struggling with the VS2017 debugger, it seems that somehow the exception doesn’t always cause a CTD. If the game is saved after the exception without CTD, no matter if it’s manual or auto, the save becomes corrupted and the game will CTD upon next load.

I don’t think it would help. I’m not a C++ programmer myself, but as far as I understand “[Access violation reading location XXX]” means the program tries to read from a memory, that is a variable or pointer, that is either empty or isn’t supposed to be read from. Or something like that.
If I had to guess it could be anything really, maybe if there is a list of all items and npcs and one of them would somehow disappear or fall through the map and couldn’t be pinpointed anymore that maybe could cause such an exception. But in the end I have no idea of their code and it’s not my job to fix it, I’m just trying to be helpful.

1 Like

@ALuserX I’m not sure if it’s coincidental but I’ve been playing H2 on PS4 and on the Isle of Sgail (the ark society) I have noticed that when weapons are dropped they don’t appear on the floor in certain areas but are still retrievable.

Invalid pointers would throw an error. Perhaps H2 has substandard error handling.

Seen the same issue last night (Steam). Dropped a weapon and it disappeard.

I’ve been playingtesting again this evening and came to a conclusion that the problem MIGHT have something to do with sounds or “sound queue”.
As I described in my very first post in tech support thread I played just fine for 5 or 6 hours, could take down Robert Knox, haven’t experienced any crashes and none of my saves were corrupted. But as I went for Sierra Know and I entered the VIP area with a huge NPC crowd the sound began to stutter and went mute. Soon after that the crashes started to happen.
As I tested today I noticed some issues that could be connected (or not)

  • whenever I entered a crowded area the game would lag of 0,5 sec and the music would go off, and if I pressed ESC the menu sounds weren’t there
  • when 2 NPCs were talking and I pressed ESC the sound of the one person talking at that moment would go on till it’s finished and when I pressed ESC again to return to the game the dialogue would be “broken” and both NPCs would ignore each other as if they weren’t talking to each other
  • as I went to the hotel area there should have been these 2 medics talking that would trigger a killing opportunity, but as I came near them even though there was a notice “Mission story revealing” they didn’t start talking, their mouths weren’t moving and as I stood there looking at them a CTD occurred after a while and even though it could be a coincidence, maybe I waited exactly as long as they were supposed to be talking, so maybe even though the sound didn’t start the game was assuming it started and as it had to trigger a mission story to be followed it crashed because it tried to “access” the sound that wasn’t actually playing
  • When I tried to disassemble the exception in VS2017 there was a mention of MOV, EAX and RAX, and EAX stands for environment audio effects, right? No idea what RAX means though. Rotating audio effects? Like, “move audio to the rotation queue” or something like that? But even if it has nothing to do with audio, EAX and RAX seem to have different lengths, so maybe that’s the issue.

I haven’t played any other missions yet, but could it be Arc Society and Mumbai also have a lot of background sound action going on and the crashes happen when you’re near that crowded area?

As for disappearing weapons, I haven’t consciously seen any, but there was a test run (can’t call it “playing” anymore because of crashes sadface) where I pacified a person with a flying hammer™ and had a crash the moment the person dropped to the ground. So I assume that might be indeed a possibility, that it crashed when the hammer “disappeared”. If it disappeared. I’m not sure of that.

1 Like

Great to see someone with technical knowledge and competency to at least identify errors.
I have also noticed lost of bugs related to sound. NPC acting like they are talking but no voice, background music/sound completely stopping etc. My game never crashed though.

Where my game kept crashing last night on Isle of Sgail was not a crowded place, just 4 NPCs. And it crashed even if I loaded the saved game and stood there doing nothing.

Thanks, but I wouldn’t say I have neither technical knowledge nor competency, I don’t know C++ and have no idea how Hitman is actually build. I’m just getting desperate since I can’t enjoy the game I waited so long for.

1 Like

But have you visited a crowded place before the crash? I mean, as I tried to load a save where I knew the exact time it would crash, I once tried to run away from the place where I started to the least populated area I could reach and it still crashed. MAYBE because there was a sound that’s supposed to have started and would have ended exactly as it’d crash, like it could be the case with these 2 medics talking. If it’s even connected. It doesn’t really matter where you go, as soon as your save is “marked” with a “black spot” it crashes at exact the same time. Sometimes you’d have 5 minutes to run around, sometimes it’s 5 seconds or right after it’s loaded, but as a matter of fact the save becomes a ticking time bomb of sorts.

No I haven’t. The area I was exploring was inside the castle and very low on NPCs. Like there’s a room with two medics or lab technicians talking. I sneaked into that room dragging a dead body so that I could try to dump it (there’s a crate in that room). Outside that room in the vicinity, there’s just one guard and a lady sitting on a bench. I’ll try to load another saved game that’s 15/ 20 minutes apart and see how it goes (I have to hide another dead body by dragging it into a room upstairs, sigh)

RAX and EAX are low level processor registers. They don’t have anything to do with sound. (Registers are basically temporary storage used the processor to store numbers during calculations; EAX and RAX have different lengths because EAX is a 32-bit register and RAX is a 64-bit register)

It is probably going to be difficult to figure out the cause of the crash just from looking at the disassembly unless you have the debug symbols, which is a database that links the disassembly back to the original source code, so instead of low level instructions like MOV EAX, which are effectively unreadable in a complex modern video game, you get the original C++ function that was called, which might give you a clue to why it is happening.

1 Like

Thanks a lot for clarifying that, dude.
Always a good thing to learn something new.

Tried another saved game which was pretty far off the ones that were crashing and fortunately that one worked and I was able to finish The Ark Society without further drama.

yeah I might have to resort to that but such a waste of time doing the same thing again

Ok so I noticed one more thing, my PC makes quite a bit of sound while loading the Ark Society save file now since the crashing problem began. It is like the processor is under a lot of stress. Not sure if that is related to the problem.