Hitman 2 - Low Frame Rate & Stuttering [SOLVED]

I’m sorry this is so long. I haven’t played the game in ages and since I’ve come back I’ve been having huge frame rate issues. Even at 720p, I can’t keep anything close to 30fps. The game seems to stutter all the time, especially when I take my gun out and shoot, it drops to around 1fps. I can’t walk for longer than 3 seconds before the frame rate just plummets and the game practically freezes for a second or two.

Sometimes it runs perfectly and I hit 60fps, but it’s so inconsistent.

My Specs:
CPU: AMD Ryzen 5 1600 Six-Core
GPU: Radeon RX 580
RAM: 8GB

I’ve tried:

  • V-sync on and off, half and full.
  • Supersampling is at its lowest.
  • Simulation Quality is set to ‘Better’ since I have 6 cores, but I didn’t notice a difference between that and ‘Base’ anyway.
  • Tried Direct3D12, but it just crashed before it loaded the level.
  • Windowed, Fullscreen, and Exclusive Fullscreen.
  • Every setting is at low or off.

Nothing I’ve tried has made it close to playable. It never ran perfectly when I bought it, but I did finish the game and replayed it a bunch of times shortly after it came out, and now it just seems so unplayable. I have some custom settings on the AMD Radeon Settings program, but I don’t understand what or if I should change any settings there.

Does anyone have any suggestions? I really want to play the game, I’ve been a fan of the series since I was a kid, so this just sucks. Thank you!

You do not have enough ram. Look your memory usage. I recommend 16GB with this game.

Is it bad that my computer with 2GB RAM runs about the same as yours, @Michael?

Steam page says minimum 8GB though, are you sure that would make much difference? It’s got to work better than this surely if they say minimum 8GB :roll_eyes:

Cannot go by minimum. Always go by Recommended.
Steam recommends 16GB RAM

Hitman 2 fills your Memory usage to 100% if you alt+tab too.

8GB RAM should be fully enough, I been playing HITMAN 2 without big problems even on 8GB of RAM.
But if you have such a minimum RAM, you shouldn’t open much applications and programs alongside the game.
Ideally while playing HITMAN 2 on 8GB RAM you should close everything else and run only a game.
Then problems should be gone. At least such was for me.

According to the specs of your CPU and GPU, it should be fully enough for the game.
First thing you should try is to free the RAM whilst playing HITMAN 2 as I said above by closing all other apps and programs.
If performance will increase, you just have to increase your RAM memory and the problems will be gone

Other than Steam open in the background, I don’t have anything else open when I play Hitman 2. Thank you though, and everyone else for your suggestions so far.

Solved it. I knew it ran perfectly fine years ago. I’d done a windows update and for some reason, it had allocated over half of my ram to “Hardware Reserved” - you can check this out in the Resource Monitor. I just took my RAM out, blew on it, and put it back in.

Works perfectly now, I can get 60fps on medium settings. Deff didn’t need 16GB of RAM.

4 Likes