HITMAN 3 - Bug Report Thread

Just want to confirm this bug for me as well (PC). With mission story guidance off, the prompt to talk doesn´t show up, not even if I do the story the exact same way as if the guidance is on (1. listen to conversation, 2. get form, 3. get board member´s disguise). The prompt is there if guidance is on.

Other mission story related bugs I´ve had (in both cases guidance was off):

  1. Dubai - when doing the “Bird of Prey” mission story, after showing the picture to the assistant, she told me to follow her but wouldn´t leave her desk (reloads didn´t help, though I was able to complete the MS regardless by going upstairs myself). Subsequent re-tries have worked properly so far (both with guidance on and off). Also, on that particular occasion, she had a water bottle “stuck” to her hand (had the same bug with Stuyvesant and a glass of wine).

  2. Mendoza - in the wine tour mission story, the lead winemaker wouldn´t go start the tour after tasting the grapes (restarting the game fixed it, but I haven´t tried since to see if it repeats itself or not).

Edit: 3. Mendoza - the option to interact with Diana after disposing of the upper floor guards was missing, hence the mission story (guidance was off) was not progressing properly. Happened only once so far.

Additionally, in Dubai, instead of hanging, I had 47 fall off the building after scaling some of the railings (will have to check which exactly).

Also, having the invisible laundromats in Chongqing just like everybody else it seems.

2 Likes

PC
Chongqing (Contracts Mode)

For some reason sometimes the doors to Core Chamber just do not open, even if you have the tier 3 dongle and have scanned it

I was just messing about for a while, not sure what specifically led to this happening. Disabled the two servers but I didn’t think that resulted in a door lock, does it?

1 Like

PC
Chongching

When you take the clothes of a Masked Guard, they stay fully clothed!

Set off core meltdown, kill a guard and take their clothes

1 Like

PS5
Berlin

If you KO/kill Agent Rhodes in a Biker disguise, even though he is wearing the same disguise - the game gives you the option to take his outfit rather than locking it out because you’re already wearing it.

Platform: PC | Location: Situs Inversus (Hokkaido)

Cubemap reflections are extremely low resolution.
You can see the difference quite clearly especially with them next to the SSRs.
The cubemaps were not this blurry in 2016 / H2.


Location: Chongqing

@InfrarerSun is correct. The head model for 2016 suits seems to be different than for the H3 suits.

While wearing the Raven Suit in Chongqing, his head is magically immune to raindrops or getting wet, even though his suit becomes soaked, unlike in the Signature Suit, where his head becomes wet along with his suit.


7 Likes

Location: Sapienza
Mission: Landslide

“The Gig is Up” - kill Marco Abiatti on stage by electrocution cannot be unlocked.

“Urine for It” - kill Marco Abiatti by electrocuting him while he’s peeing cannot be unlocked.

5 Likes

I remember having that issue when playing in H2 Legacy. I ended up getting it by using the sniper rifle that you unlock in Paris. I don’t think all sniper rifles that were added after Paris in 2016 “work” for the challenge.

1 Like

I didn’t do the progress transfer I just used Jaeger 7 for the kills. Think that’s the one you can unlock in Paris.

Platform: PC

Location: Dubai

Bug: Versatile Assassin is bugged. I got the drowning challenge in the escalation and it wasn’t counted.

Platform: Xbox
Location: The Game itself
Bug: I don’t know if it is really a bug, but every time I start the game, online mode is just not avaliable for me.
Steps to reproduce:

  1. Quit the game and go to network settings.
  2. Restart my network on Xbox.
  3. Try to start the game and it still fails to load online mode.
    Frequency: From yesterday evening, all the time I try to load it.

Platform: PC

Location: Chongqing

Description: If I go to the guide I can lean like you do towards a wall but I did it against the guide and with a little air between us.

Frequency: It ALWAYS happends.

Second floor of the Swedish consulate map and the abandoned school map are not displaying at all.

6 Likes

Platform: PS4
Digital copy
Location: Dartmoor
Description: when I exit the mission from the gate I get an error message until I have to exit the game. Only happens when I do the detective story line. It can’t reconnect at all

Frequently: every time I try to do the detective mission story.

Platform: PS4 Pro
Digital Copy, with carry over from the disc copy of Hitman 2 and digital of Hitman 1
Location: Dubai
Desc: Lucy Phillips went through a wall and vanished after giving her a sedative in the private bar.
Location: Berlin
Desc: Could not use the sewer exit to leave after completing the mission. The prompt appears, but pressing triangle does nothing.
Location: Chongqing
Desc: After the 2 targets meet, the handler mentions we can listen to them talk, since she hacked one of their phones. The targets talk to each other, but I couldn’t hear anything.
Location: Romania
Desc: It’s snowing inside the train if performance mode is used on the PS PRO. Switching to quality in the graphics options fixes this, but at the loss of fps.
Also, npcs seem to walk through each other quite a bit. I didn’t notice this happen in previous games.

1 Like

Platform: PS4
Digital copy
Description : some challenges (tier 2, 3 and 4 but not tier 1 :thinking:) related to featured contracts are already unlocked even if I never play any featured contract in H3.

Platform : PC

Location : Dartmoor

Description : Challenges don’t unlock

I have discovered every location on the map though the discorevy challenge is blocked on 13/22, I cannot complete it.

And, I tried like 3 times to escape the mission with the motorcycle, and the corresponding challenge doesn’t unlock either.

Frequency : Always

How to reproduce : No idea, might be related to server connection issues I’ve had

1 Like

Plat. Xbox One
Location. All.
Reloading a save while having the pre order ICA19 Black in your inventory will cause a floating white object to appear next to it when equipped.

3 Likes

Platform: Stadia

Location: Mendoza

Description : “Estate Wines” challenge not recognising 47 picking up the 3 wines

Steps to reproduce:

  1. On first playthrough of The Farewell, 47 picked up a bottle of Malbec and Cabernet Sauvignon, and the “Estate Wines” challenge progress bar showed 2/3 wines collected
  2. On picking up the Pinot Noir to complete the challenge (still on same initial playthrough), the progress bar did not fill out with 3/3 wines and the Estate Wines challenge remained uncompleted
  3. On subsequent playthroughs, picking up any/all of the 3 bottles of wine does not seem to register as a progress bar for Estate Wines and the counter in the Challenges menu (in-mission) shows 0/3 collected

Frequency : Always, after failure of challenge to pop on initial first playthrough as described above

Link to video example including Stadia game state: https://stadia.google.com/capture/f7877957-f4f0-4baa-ac07-63e842c1481f

7 Likes

Same issue on Series X. ‘Showstopper’ challenge doesn’t pop. Tried 4 times on different missions. Clearly crushed by the light rig but challenge remains stubbornly uncompleted.

2 Likes

I did exactly what you said and erase my local data and relaunch the game but nothing happened. My progression is still 16 in dubai with all challenges completed and in dartmoor I am level 6 but I should be 10-11 I guess…this is so frustrating. I think it’s better to stop playing and wait that they fix everything…

1 Like