HITMAN 3 - Bug Report Thread

On which platform are you?
I did it on PS4 last weekend and I obtained the SA achievements for the three sniper maps (+ two for 1 million points) without any issues.

1 Like

Platform: PC (Epic)
Location: ICA Facility (Freeform Training)
Description: This NPC is always standing incorrectly in Freeform Training. She should be facing her friend whom she´s talking to (as seen on the other screenshot taken in Guided Training), but instead is standing to her side and talking in a completely different direction. Her friend with the phone is also standing in the wrong place, being closer to the corner than she should be.
Frequency: Always.

1 Like

Shouldn’t this mission take place in 1999-2000? Why are the NPCs still using smartphones :roll_eyes: :face_with_raised_eyebrow:

3 Likes

Guess the ICA has always had access to advanced technology :smiley: (Also, are you suggesting IO should make a new phone model for one single mission? :shushing_face: )

1 Like

Nah, just disable the NPCs from using smartphones / tablets, should be an easy tweak :wink:

1 Like

Thanks for the reply. I’m playing on Xbox. I tried it a couple more times without any success, but after I quit the game and restarted it, I was finally able to get SA and the game me the proper score I deserved (over 2 million). I am still unable to get a rank on The Pen and the Sword, but I was able to get a rank on Crime and Punishment. Very strange.

1 Like

Very strange indeed.
Do you finally obtain the achievements?

1 Like

Yes, thank you. That restart seemed to allow everything to work as expected and I’ve now unlocked all of the achievements. Yay!

4 Likes

Playing on PC, with XB controller. The camera seems to have a problem with slightly shifting upward in small increments while moving. Other than being annoying, it gives me a slight feeling of being sick (like motion sickness). It’s definitely not my controller, and I’m not sure when it started happening.

In this particular instance they would also have to cut the dialogue though, since the woman with the phone says “Have you tried this texting thing? It´s quite/pretty addictive.” Would lose the “sophisticated” joke :smirk:

1 Like

Platform: PC (Epic)
Location: Isle of Sgail and New York
Description: Clipping issues with some of the disguises. In Sgail, 47´s head clips through the initiate disguise, as do his legs/lower back occasionally. Additionally, female NPCs in Ark Society robes also tend to suffer clipping as well. In New York, when disguised as elite security, the suit clips through the badge. The most glaring persistent clipping issue is probably 47´s swimwear in Haven, but I assume that one is well known…
Frequency: Always.

Location: Isle of Sgail (and others)
Description: Punching unarmed NPCs still sometimes results in one hell of a physics glitch.
Frequency: Sometimes.

Location: Sapienza (World of Tomorrow)
Description: This lady still tends to spawn on the railing. (Gotta admire the balance though)
Frequency: Sometimes.

The same also happened for me once with this lady in the laudromat in Chongqing:

Location: Isle of Sgail
Description: I believe this wasn´t an issue in H2… When subduing/pacifying/KOing NPCs in the the security room on the architect floor (the room with camera recording and two raiders where Sophia regularly comes to check on the decryption progress) too close to the wall separating it from the room full of raiders (which Sophia comes through), the enemies in the adjacent room will hear it even if the door is closed and will come investigate. I believe they should only hear the noise if the door is open, but I might be mistaken. IIRC, KOs on that side of the room (with the door closed) never attracted such attention in H2… More so, unlike the guys in the next room, the other guard in the same one doesn´t notice it (see screenshot).
Frequency: Always.

4 Likes

Platform: PC (Epic)

Location: All

Description: Suitcase or stash can not carry ENRAM HV CONVERT MK II and TAC-AR AUTO, please fix this problem as soon as possible, thank you

. Frequency: Always.


No ENRAM HV CONVERT MK II

No TAC-AR AUTO

3 Likes

Platform: PC

Location: New York

Description: IT worker outfit and NPC missing big slippers.



4 Likes

Platform: Xbox One; digital

Location: Sapienza

Description:

Mansion door (keycard) won’t physically open.

When you leave the ICA safe house through the back, slide down the pipe and go up the stairs where the kitchen assistant is taking his break.
This door to the mansion, which requires a keycard, won’t physically open. It says door unlocked, but it doesn’t open.
An electronic hacker card won’t work either.
What DOES work though is placing a coin so that a NPC opens it or when you throw an explosive at it.

Opening the door from the INSIDE does work perfectly; the OUTSIDE is the problem.

Frequency: Always

5 Likes

An NPC in Paris that talks to a model doesnt move if you distract them because they dont resume conversation which triggers the move. The dealer has a similar thing where he cant respond to distraction if you talk to him and then dont follow him. A big bug I found is the chawls in illusions of grandeur are no longer considered trespassing. I’ll put all these in my next ticket with more detail just want to leave them here to make sure I remember them

1 Like

Still? After half a year?
Damn…

2 Likes

Platform: All

Location: Whittleton Creek

Description: When 47 takes the bus exit (near the default starting location, by the street intersection), there is visibly nobody else on the bus, nor is there a driver.

I suppose the easiest solution would be darkening the windows of the bus, even just at the front, in order to hide that there is no driver. Otherwise it looks kind of creepy to see this low-tech bus drive itself.

4 Likes

It’s always been like that even in H2, the bus out of Santa Fortuna is also mysteriously empty.

1 Like

platform: all platforms

location: romania
after killing arthur edwards you can inject yourself with the serum and the secret ending plays out as normal as if arthur edwards never died

to reproduce:
start game
enter romania
get to the final cart in romania
kill arthur edwards
equip serum and hold for 47 seconds
left click when the game presents the inject self option

this happens every time

3 Likes

This door in Sapienza won’t unlock from this side. Leads near the kitchen area in the Caruso mansion
even with a keycard.

5 Likes