HITMAN 3 - Bug Report Thread

Platform: PC (Epic)
Version 3.140

Failing mission despite all conditions met.
Freelancer Hard-Core

This has happened to me on a couple of occasions. This time in Mumbai. I complete all the objectives perfectly, but the mission still fails (notice the red background). Why is this happening?


Platform: [PS4, Xbox One, PC, etc]
Xbox Series X - virtual (not disc)

Mumbai (maybe other places too – need to confirm)

Game abruptly throws an Exit Mission prompt on the screen that I CANNOT click out of. I’ve tried restarting the game and also switching profiles, but it is inevitable and kills my entire playthrough.

Steps to reproduce:

  1. Start the game
  2. Load the Mumbai mission
  3. Play for 30 minutes
  4. Exit Mission deathblow

Replicated twice and also before this time.



Platform: Xbox Series X (Disc)

Location: Various

Description: 47’s tie when wearing the signature suit with gloves will disappear through the suit when standing against cover. On some occasions, the tie will also disappear through the suit when walking in different directions.

Steps to reproduce:

  1. Use cover by standing against cupboards/walls etc

  2. Walk in numerous directions and 47’s tie will also on occasions disappear through the suit. This doesn’t occurs with the Blood Money or Absolution suit.

Frequency: It happens quite frequently.

1 Like


If you leave a location before all targets are killed and you’ve not failed the Prestige Objective (ie the timed ones haven’t had the timer reach zero, you still held SA rank when you exited), the game will still award you the XP for “completing” the objective even though the mission was a failure.

1 Like

Platform: PC
Map Chonquing
Mission End of An Era

I got a bug with Hush when I knocked out JunLi so Sister Le will turn up the voltage and kill Hush.
When I knocked JunLi out Hush walks in and keeps looping dialog then he walks off.

I’ve reproduced this by wearing the perfect subject disguise and tellng JunLi I was ready. She summons SisterLe and Hush and dismisses the other subject. I distracted Jun Li to the cabinet, knocked her out right before Hush walks in. I walk over and he waits for SisterLe to arrive.
He asks about JunLi and Sister Le says she can handle it . That’s when Hush goes into a loop.
He asks about going to 60% walks across the rom then reverses and says same line.
He should I think get into the chair. My character doesn’t get a prompt to get into the chair either.
I made a short video clip. This is game breaking if I’m supposed to be able to induce him to be electrocuted. Hitman3 Bug: PC;Chongquing; End of An Era. Hush goes into a dialog loop - YouTube

1 Like

Platform: PC v3.140.0
Location: Multiple (Screenshot taken in Bangkok)
Description: After poisoning an npc’s drink they will pull out a duplicate, non-poisoned drink from the same spot rendering the poison ineffective.

Steps to reproduce: This seems to happen if I am a far enough distance from the target when they perform the drinking animation, though this may be coincidence. If you have another poison item you can apply it to this second “ghost” cup and it will work as intended. I do not believe there was an option to poison a second cup before the NPC attempted to drink.

Frequency: Has happened twice, both times during Freelancer mode and most recently in Bangkok. Shares similarities to posts #392, #562, #3482, and #3485 in this thread, and someone posted a video of the bug here

Not a big issue in normal career but can be very annoying in Freelancer where you have limited resources. Will attempt more testing outside of freelancer using saves.

EDIT: Tried to add links to all the relevant posts but apparently new accounts can’t do that. The post number on the side does not match up with the URLs that link to the posts, causing a bit of confusion on my part. The numbers in this post are now the ones you have to type in to reach the relevant posts (ex. HITMAN 3 - Bug Report Thread - #3485 by thrison)


This goes for baseball bats as well. It would be nice if you could put them back in the briefcase, but the main story mode is the same way.

1 Like

platform: xbox one, digital.

location: all, hardcore freelancer game mode.

description: timed prestige objectives do not register properly when exiting a mission causing the campaing to fail.

steps to reproduce:
1- start a hardcore campaing in freelancer.
2- select any timed prestige objective that resets the timer on specific actions (timed: get disguises, timed: silent takedown or timed: hide and seek).
3- kill all targets and exit the mission without failing the prestige objective.
4- the campaing will often fail and you will be back at the safe house the same way you would be if exited the level without completing any mandatory objective.

frequency: most of the time.

video: campaing failed despite completed objectives - YouTube

Freelancer Mode Bug Report
PS4 (probably other platforms as well)

Bad Intel in Showdown

Two examples

Example 1:

The first image’s suspect matches all the physical characteristics. He was the ONLY ONE that did.
The tells we’re wrong.

He was not the Leader.

The second image’s suspect matches 3 of the four physical characteristics. ( He had Earrings, not Tattoos).

He had the correct tells.

Turns out he WAS the Leader.

Example 2:

In the image above, the woman in white matched all the physical characteristics (BALD, HAT, NECKLACE, EARRINGS) and was the ONLY ONE to do so, but she did not have the correct tells.

The man she is meeting had the correct tells, but was not matching the physical description (BALD, HAT, NECKLACE, TATTOOS).

Both were there for the same meeting type.

So… which one was the target?

Answer. The man with the tattoos.

In Conclusion: This is a serious flaw/bug/glitch in the game, when the information on the leader is wrong.

1 Like

Freelancer Mode Bug Report


Isle of Sgail - Final Showdown

Spotted in the distance from the coastline of the island, a lone figure with a Suspect tag over their head, was seen walking into the sky.

While the identity of the individual could not be identified, rumour has it that this was the elusive Eric Torrence, that was asked to phone home, back in Chongqing.

No floating note was discovered on the scene this time.

The guy in your 2nd screenshot definitely does have a tattoo. Right there on his neck. Like a web with a V in it. No issue with that one.

1 Like

Platform: PC
Location: Dartmoor
Briefcase tossed gets stuck between ladder and wall.
Bug: Briefcase tossed off building gets stuck between wall and ladder

I tried to toss the briefcase from the ledge so I could take it. I made the arc kinda shallow but it seemed to drop. I heard a thunk and one of the guards on the floor below heard it also with a “?”
over his head. I got to the bottom confused where it went until I looked back up.

I don’t know if it’s reproducable I’ve only ever does this once.


If you turn the minimap off, the icons to the right of it (for alerted area and assassin/lookout nearby) don’t move further left like the SA/difficulty icons do in the normal game. They stay in the same position.

Platform: Steam
Location: Safehouse
Description: I can’t pick up the screwdriver on the makeshift DLC’s table even if it is highlighted in the instinct
Frequency: Always

Platform: Steam
Location: Safehouse
Description: Sometimes the suspect will walk in the air for no reason
Frequency: Sometimes

Platform: Steam
Location: Freelancer Showdown: Isle of Sgail
Description: 47 is cleaning the plate that is probably added in the showdown.
Frequency: Always

Platform - Xbox SX, Digital Copy

Location - Menu/inventory/weapons and gear


Ever since Freelancer update some items (pictures) wont load, even clicking on show details the picture doesn’t show

1 Like

Platform: PC (EGS)

Location: Safehouse

Description: A decoration in the bedroom seems to have no entity so that Mr. 47 can stand through the tiger’s head.

Frequency: It always be.

1 Like

Platform: PC

Location: Freelancer

Description: When pouring the water out of the water tanks, 47 can use his magic to make the water run outside with the lids tightened. Also, we can tell that Mr. 47 is eco-friendly because he still wants to save some water in the tanks even though he cannot take them out for the second time.

Frequency: Always.

1 Like

Platform: PC (Epic)
Location: All locations, Freelancer
Description: This woman has a tattoo, that is very badly visible, as it clips through her arm. I thought it was issue on my side due to my PC, but others reported this problem aswell. This can be very annyoing during showdowns and can cause failing whole campagin.
Frequency: Always