HITMAN 3 - Bug Report Thread

Marrakesh, school, 2nd floor.
Minimap and bigmap are absent

Platform PS5

Location Mendoza

Description Rich Harvest PlayStation trophy not awarded, all mission stories including hidden story have been completed

1 Like

Closing Statement is not checked as completed on your last screenshot.
Maybe that’s the problem.
This challenge is tied to secret mission story.
And well, secret mission story also still hidden for you, so you didn’t complete it.
Once you find it, it appears in Mission Stories tab

When I look at this wall even slightly from an angle it goes weird and is probably showing reflection maps or something. it is in Bangkok birthday room

Platform: PS5 (digital)

Location: Chongqing

Description : I am disguised as the ICA Board member, have the P41 papers, but when I talk to Royce’s assistant, it doesn’t prompt me to take the tour of the facility.

  1. Start the game
  2. Load the Chongqing mission on Mastery Difficulty
  3. Disguise self as Board Member
  4. Pick up P41 papers in Board Member’s apartment
  5. Try to talk to assistant to start tour

Frequency : Always happens

Platfrom: PS4 (pro)

Everytime I attempt the challenge ‘There was a Fire Fight!’ (Confront Agent Montgomery), about 10 seconds after 47 kicks the desk, the game crashes. Every single time. It seems to alwasy crash as I am shooting at montomery and he is about to die, but I don’t know if this is related. There are useally about 5 agents in the room including him.

Edit: upon further testing, it appears killing montgomery any time during this opportunity, even if it is as he enters the room without sitting at the desk, causes the game to crash.

To reproduce:
After 47 kicks the deck, attemtp to shoot and kill montgomery.

Happens everytime, without fail for me.

Santa Fortuna

The crowd doesn’t gather when you do the statue mission story when Andrea and Rico take the stage. Only guards turn up.

Have you already killed Tremaine (the sniper) at this point in your save? I had the same issue, but on subsequent runs I just avoided killing Tremaine and everything was fine. I found some more discussion on this via Reddit.

Trust me I’ve definitely completed Closing Statement I’ve done it a handful of times or starting from different scenarios (listening to the waiters phone call and at the end of the tour) it just won’t work!

1 Like

I’m doing the mission and trying to complete the challenge to kill every agent, and this bug makes it impossible.

Yes I had. In my last run, where u killed montgomory via the dj kill, I had not killed Tremaine…

Knocking agents out after they are ordered to leave the area counts as killing them fir challenges. So you can get this challenge by luring him and the others to the room with a phone call, killing everyone else then chucking a hammer at him or something.

1 Like

Platform: Xbox Series S (Digital)

Location: Dubai

Description : Can’t load any of my saves. Keeps saying there’s access issues to Hitman 2 Gold. I am connected online.

Steps to reproduce:

  1. Unknown. Was loading saves okay for a little bit, bit then on my 3rd run or so through Dubai, loading saves seems to have stopped working.

Frequency : Happening consistently now, even after quitting and restarting the game.

Pacifying or eliminating the last agent in any way crashes the game immediately, i’ve tried poison, explosions, shooting, subduing, throwing, drowning, falling, electrocution, and dropping stuff on him.

Are you talking about the Clean House challenge? If so, you don’t need to kill all of them in one run if I remember correctly, you just need to have killed them all once. So I’d suggest killing Tremaine plus four others and not Montgomery in one run, and then for the rest of your runs, just ignore Tremaine, unless you need to do a specific challenge for him.

Yea, from reading other people’s reports on Reddit, it looks like Tremaine is the common denominator that breaks the chain.

Just tried it as well and it hasn’t unlocked for me either. Seems to be quite a few challenges that are not unlocking when they should.

1 Like

Yep, same. Also on PS4.

Platform: PC (EGS)

Location: Everywhere

Description: When I use my Dualsense controller the config doesn’t allow you to access the map using the Share button, like with the Dualshock 4 config (Where the touchpad goes to the notebook and share goes to the map).

Steps to reproduce:

  1. Start the game
  2. Load any mission
  3. Try to access map shortcut with the Share button.
  4. Nothing happens and I must use the touchpad to go to the notebook and then tab along to the Map.

Frequency: Always.

N.B - I really love using DS over DS4 since I prefer the sticks and triggers on the DS, having the DS prompts and controller graphic on the pause screen is amazing work so soon after the DS has been released but fixing this small oversight would make it perfect.

Hi, I played 13hrs and decided to buy access pass. My frames have been in the 100’s the entire time now my frames are at 1 to 2. Please help