HITMAN 3 - Modding Thread

I hope this is the right thread to ask in (sorry if it isn’t, I haven’t used this website before), but I need help getting the “Freelancer Variations” mod to work and the ZHMSDK mod to work.

Freelancer Variations says that the SHMSDK mod is needed to work correctly, but when I install both and open the game, the menu for it appears in the top right for a few seconds, but nothing is clickable. Then it flashes rapidly before dissapearing permanently.

The hotkey to open it does nothing but show the cursor.

I’ve installed the SMF and the SDK for Freelancer Variations, I’ve installed Simple Mod Framework for the mod. I’ve enabled and deployed the mod in Simple Mod Framework.

I’ve changed my resolutions settings, I’ve turned off HDR, I’ve turned off G-SYNC, V-sync is off. The github talks about a mods.ini folder that is put into the game’s Retail folder, but no file like that exists.
It doesn’t come with the mod so I don’t know what they’re talking about

Any suggestions or guidance on how to fix this would be appreciated!

2 Likes

New and improved briefings that are a tad more truthful of each of The Sarajevo Six’s respective routines, and have been updated to reflect current maps.

Supports all languages the original briefing had. Comes in RPKG Format and SMF format.



As a matter of record, I did use ChatGPT AI to batch-change the timings of lines, but that is all. No translations or other uses of that sort of AI were used.

These were used as background footage for my Sarajevo Six review:

5 Likes

hi, i’m a newb to hitman modding

i’m using the RPKG tool for the first time. i’m trying to find the model for the requiem suit, but i cannot for the life of me find it. where do i look?

the RPKG files have suits for everything except this one. is it under a different name?

Just installed the Chongqing Noodle Massacre. When I hit ‘Apply’, I got this message:

Warning

Mod Chongqing Noodle Massacre replaces a base game entity file (00FE367C6557D3E1) with a raw file. This can cause compatibility issues, it makes the mod harder to work with and it requires more work when the game updates. Mod developers can fix this easily by using an entity.patch.json file.

Should I worry?

Only if you’re in the area the Police Sniper can see you being naughty. But otherwise, nah.

It’s actually a message from the SMF author to nudge mod devs into… doing whatever that message says.

1 Like

Offline Mode Enhanced & Custom Mission Pack 1.6.5 - Peacock Upgrade

Things have been pretty broken in Peacock for a while, and no one ever gave me a clue why until the past week. The error still makes zero sense, but I found a way around it. And thanks to AnthonyFuller you can find all the missions in Peacock in Campaigns->Bonus Mission->Modded & Offline Content (Again).
All Offline mission enhancements (starting locations, difficulties, VR, etc) now apply to Peacock if this mod is deployed (If this becomes an issue I can make it optional later. It was just easier this way). And lastly The Sarajevo Six contracts have been given Difficulties and VR.

Changelog

  • Integrates Peacock Plugin to SMF mod (And makes it actually work)
  • Adds difficulties and VR to The Sarajevo 6
  • Offline mission enhancements now apply to Peacock

EDIT: Some of the vanilla mission improvements are causing crashes in Peacock for dumb, stupid reasons

2 Likes
12 Likes

14 Likes

I would unironically want that shirt if IOI was to make it :sob:

That’s genius

5 Likes

Time of Day Mod 2.2 - Midday NY, Sunrise HB and small fixes

Changelog

  • Adds New York - Midday
  • Adds Hawke’s Bay - Sunrise
  • Fixes crash when loading Hantu Port rainy night
  • Dartmoor: Adds Wrath’s boxreflectioncache to night ToDs to hopefully reduce instances of indoor lighting being bright red/orange
  • Berlin Sunset: No longer deletes ICA agents (Re-download if you grabbed it in the first four hours)

I am aware of an issue where latest version of Offline Mode Enhanced & Custom Mission Pack causes certain vanilla missions in Peacock to crash. I do not know when it will be fixed.

7 Likes

Request.

I thought of a mod today while waiting for a number of (non-target) NPCs to come up to the 2nd floor.

What about a mod that made NPCs run whenever checking out a distraction?

As for which running speed? I know there is the “run” that is a bit of a somewhat hurried walk speed. Or the female NPCs escaping run speed. :roll_eyes:

Then there are the panicked runs speeds where they seem to sprint! :joy: This would be the preferred speed, but I don’t know if certain NPC types are coded to have top speeds or whatever.

Anyway, I thought it’d be more funny while at the same time being a bit useful in some instances.

Edit: I also thought of all NPCs always running, but I think that’d mess with things like routes. Might be hilarious tho.

I’ve been trying to see about a semi-auto assault rifle/SMG mod for a while, and someone has tried to make one. But instead of the weapons firing in semi-auto when you turn full auto operation from true to false, they’ll burst fire (2-3 round bursts instead of one shot). I was then told on Nexus Mods that if you also alter a sound file it might do something. My friend tried it and it apparently made no difference, either.

Would anyone have any idea what governs this, or is full-auto operation hard coded to the point where it can’t be completely defeated?

Hi. It is possible through the RPKG tool extract all the video cinematics, like briefings etc? If it is, what files i have to look for? Thanks :slight_smile:

You need for this VGMToolbox

Ok but for what i saw, i need to extract the GFXV files from the rpkg, right? Or i can just use VGMToolbox directly?

P.S: Nevermind, found everything. Thanks for the help :slight_smile:

1 Like

Recently, I noticed that the “choose your own adventure” options for Sapienza and Marrakesh have disappeared, and Ambrose Island isn’t showing up on the menu for locations in Hitman 3 now. Is there something going on with a mod?

Sounds like you have an old style (RPKG) or outdated mod. Like Offline Experience Refined, Offline Missions, something like that.

I only have the Offline Mode Enhanced and Custom Mission Pack mod. I only noticed the Choose You Own Adventure things were gone the past couple of days, and Ambrose Island was missing today. Is there a fix for it?

I did some more looking, and the Choose Your Adventure missions show up in the campaign menus, but Ambrose Island still doesn’t. I considered re-downloading the mod to update it manually, but I got some type of warning that I decided to err on the side of caution. Namely something about the Peacock plug-in taking control of the computer or something along those lines (I don’t use Peacock, I just play offline).