Hitman Contracts OpenGL issues

#1

Hey guys. I’m trying to get Hitman Contracts to work properly (Windows 10, Ryzen 3 1300X, GTX 1060, 16GB RAM). The game had issues with Direct3D - the FPS would skyrocket anywhere between 300-600 and the game would slow down, and locking the FPS caused microstutter. So I switched the game to use OpenGL instead - in-game works perfectly. But the intro movies are all black (sound only) and loading screens (and cutscenes) flicker EXTREMELY. I have no idea what to do. Hitman 2 which is older works perfectly with OpenGL.

0 Likes

#2

I guess you may need this:

0 Likes

#3

I’ve just checked the Control Panel and it seems I’ve got the 2005, 2008, 2010, 2012, 2013, 2015 and 2017 versions of Visual C++ installed. Edit: tried installing all of them again, nothing.

0 Likes

#4

OpenGL wasn’t properly implemented in Contracts.
Try this: https://fdossena.com/?p=wined3d/index.frag

0 Likes

#5

Any source? I have only seen one other person complain about this.

0 Likes

#6

Same problem on Windows 7, plus it got dropped in Blood Money. Try the wrapper from my previous post.

0 Likes

#7

Have you tried it and does it work?

0 Likes

#8

I tried it myself a while back and it worked but performance was poor, but then again i don’t have a video card. Let us know if it works, please.

0 Likes

#9

But there must be a way to get it working properly with OpenGL. It’s suggested almost everywhere. :frowning:

0 Likes

#10

I tried different OpenGL dlls from previous games with no luck.

0 Likes

#11

Damn… then I guess nothing can be done.

0 Likes

#12

You need to stick to DirectD3D unfortunately and work your way with wrappers. Dgvoodoo is another option and this is a DirectX 8 game iirc, so it should work as well.

0 Likes

#13

It seems to be working fine so far with dgVoodoo.

0 Likes

#14

Yo, could you help me with this? https://www.vogons.org/viewtopic.php?f=59&t=66311

0 Likes

#15

Disable anti-aliasing in HitmanContracts.ini, set it to 0 and check.

0 Likes

#16

Still happening. Stopped forcing resolution, still happening. Tried the advice from the vogons post - still happening…

0 Likes

#17

I’m going to try to recreate the problem and report back if i find a solution.

0 Likes