[MOD] Chongqing Noodle Massacre

Hmm, I use Epic too

Are you doing it via Mod Manager or manually via deploy.exe? Sometimes with big mods in SMF You gotta do it once in deploy.exe, it gets stuck so you quit, but then you double click deploy.exe again and it works

I’ve done it through both, actually. I use Mod Manager mostly, but I tried deploy.exe and got the same issue. Double clicking still does the same thing: it keeps stopping at that precise file.

More specficially, I get this error message
TypeError: Cannot read property ‘1’ of null
at C:\snapshot\SMF emergency patch\deploy.js:1025:77
at deploy (C:\snapshot\SMF emergency patch\deploy.js:1023:9)
at async doTheThing (C:\snapshot\SMF emergency patch\main.js:253:2)

For reference, I have the game installed on a different drive, not C. Not sure if that’s the problem, though. The fact others are able to install it makes me believe the mod works, it’s just not installing for me personally.

For HCCE I also experimented with non-latin (and I think non-cyrillic) characters and could not make it work out - it is unreadable. It would really interest me what the issue is and would appreciate if I was tagged when a solution is found! :clap:

Great work with this mod, well done! I hope to find time to play it soon. :smiley:


The game’s fonts only have a specific set of characters. I don’t think it has a fallback.

What mods do you have enabled?

Looks nice, hopefully it gets brought to console.

Does anyone know if mods work with the Xbox Games for PC / Windows Store version?

1 Like

I heard months ago they figured out how to bring Simple Mod Framework to Gamepass but can’t remember if it got released, the answer might be over in the Framework thread :thinking:

1 Like

The framework should work with gamepass now, use the latest release.

1 Like

Thanks @Kevin_Rudd and @AnthonyFuller. I’ll have to read up on it and take a look later.

I’ve removed all of the mods I had enabled to just do this one all by itself and that didn’t change anything. The mods I usually run lately are the Sarajevo Six, Offline Image Pack, Classic Signature Suit, and Legacy Agency Pickups. These were all disabled when I tried the mod here by itself after I originally received an error message, assuming one of these conflicted somehow. Still no dice.

This is beautiful! Wanted to do a sniper mission but the rifle at the lookout doesn’t work. At all. Bullets just go through NPCs.
Other than that: I love it and will play this a lot, thanks!


What you mean by go through NPCs? :thinking

Thanks tho :slight_smile:

I kind of imagined this to be a thread from the spoiler category and someone digged it out from the game files… I thought this is official the moment I saw this thread…
And I see it’s Kevin Rudd who post it… :sob: damn how I wish to see bonus mission produced by ioi :sob:

Must have been a weird bug or anything. Tried to do it again and it worked this time. Will test some more…

Awesome work. Wish I still had a gaming PC to try it out.


It’s possible there’s a bug where if the sniper fires the rifle it doesn’t work on NPCs when you pick it up, but I thought we fixed that :S


FINALLY. The mission is live, pog. “It will be ready in March”, yeah right. Also where do I get the Peacock plugin?


If anyone streams their first playthrough rn, please @ me and send the link, really interested


I had one witness left to take care of, but I’m not sure who it was. I was tired and gave up/exited. Do the red skulls over their heads only appear if you’re so close to them? There’s no orange highlight like when you’re compromised. So I’m not sure how else to find 'em without scouring the place, or maybe randomly kill until the counter goes down.

Yeah we don’t know how to increase the range of the ‘witness’ symbol without increasing the range of everything (like Sniper mode) where all enforcers will be visible from anywhere on the map :s
Sadly in those situations you gotta scour the map, they usually would be orange but if you change disguise or anything they won’t be. At least with the ICA Facility bkocked off and The Block empty that narrows it down slightly :stuck_out_tongue:

It’s all on the Nexus, my boi


Absolutely wonderful! Been waiting for it since February. Good job Kevin.

@Clemens_IOI @Travis_IOI pls have a talk with the devs and bring this crazy accomplishment to consoles, please!