Need Help With a Bug


#1

In the Colorado Legacy map, I completed SA/SO, No Evidence and Sniper Assassin, all these challenges have a check mark now, however the challenge “The Classics” is still locked, this happened after I finished the Sniper Assassin challenge, when i left the mission the game got stuck on “Fetching” and I selected to go back to menu. I’ve tried finishing the mission again and restarting the game but that doesn’t seem to work. I’ll include a screenshot if the explanation isn’t clear.

I’ve contacted IO about this 2 weeks ago and haven’t got a response, WB support tried helping me but ultimately just forwarded me to IO again.


#2

From the looks of your screenshot you also haven’t finished the classics on the higher difficulties… Is the ‘bug’ just not having completed it for the Casual difficulty?

At any rate, once you complete these on the harder difficulties - the lower/easier diffs will be checkmarked. So you might try to go for that anyway if you’re planning on doing that eventually.

Edit to add: If what you say is correct - then my post here is not an answer to your question, really. But since you will still have to complete the higher diff, then…


#3

I completed the challenges on Master, so everything should’ve been unlocked


#4

Screenshot of the other “the classics” challenge: