No access to envy

I have buyed Seven deadly sins act 6: Envy, but when i open the game Escalation is grayed out with get access message, like i didnt buy it at all. I have contacted Epic. From their side everything is fine. Dlc is listed in add-ons, it is activated and installed. 3.70 patch installed also.


Have you tried to verify game files?
If you have updated the game I see no reason for you it to be unavailable and it’s strange

I have verified the files , reinstalled DLC but nothing happened

Then I recommend to open a support ticket at HITMAN 3 Player Support Hub

Also, did you try simply to reboot your PC?
Who knows, maybe it helps…

reboot it just now, but no help, should i try to reinstall the game? cant see any other solution…

You may try, but no guarantee it will help.
Maybe do it while you’re waiting a feedback from IOI Support if you already reached them

I will try to reinstall the game… Now im full of envy because i cant play. So in some weird way DLC is working :slight_smile: Thanks for support man

1 Like

So did it work after you uninstalled the whole game and reinstalled it? Because I’m having the same issue right now

1 Like

i have reinstalled the game and still no access, dont know what else to do

Sorry if you already mentioned this, but I didn’t see it in a previous post: have you uninstalled and reinstalled just the Envy dlc, rather than the whole game? (Sorry if unhelpful)

First the DLC , then hole game, but still cant get accesss.

I posted the very same problem in the Technical Support thread HITMAN 3 - Technical Support - #1127 by Ligox

No access to Envy despite it being owned and installed per my Epic Games Library.
I’m buying each individually (not the pack) and all have worked so far. This is the first time it doesn’t with Envy and now others are facing the same issue.

I tried all the verifications of game files, selecting and unselecting this DLC specifically, restarting PC. Everything but downloading the entire game again.

I’m also buying each individually. First time im having this problem. I have verified the files,
try to reboot computer, reinstall DLC, reinstall hole game. I have contacted people from Epic.
They have manually reset the DLC and tell me that on their side everything is fine. DLC is purchased and in library, but in game menu is grayed out with message Get Access.

I imagine it is as everything in Epic’s side seems ok. Problem looks to be within the Hitman game, so we’ll have to wait for IOI’s solution

I bought the DLC :Envy yesterday but in my game it is locked .Can anyone give me the solution

It seems as if everybody who bought the Envy DLC by itself cannot actually play it for some reason. This is more of a problem on H3’s side rather than Epic Games’ side.
I guess everybody who bought Envy will have to wait for a response by IOI.

I’ve moved your post here where other people with the same problem are discussing it.

If you’d like, you may also want to submit a ticket with IO Player Support.

Not like, it’s recommended so they see that problem is massive and will get to it faster

Hey everyone just FYI this is happening to me too. Ive logged tickets with both companies but each one of them so far has told me it’s the others issue so im a bit stuck. it seems to me the issue is with the server not recognising the content as paid for. please let me know if anyone works out a fix or something. thanks