Official HITMAN 2 Bug Report Thread


#1

Welcome to the official HITMAN 2 Bug Report Thread.

Please use this thread to report any bugs that you experience when playing HITMAN 2. Please only report bugs here. If you are having technical issues, please use this thread: Official HITMAN 2 Technical Support Thread

When reporting an issue, please include the following details:

  • Describe the issue in as much detail as possible
  • Tell us what platform you are on
  • Provide any images or videos that might help

Please remember that you can also report issues to the HITMAN 2 publisher, Warner Brothers, through their dedicated customer support page, found here: https://wbgamessupport.wbgames.com/hc/en-us/categories/360000132307-Hitman-2


HITMAN 2 Bugs So Far
Ambient sounds disappearing in Miami level
#2

So back when the ICA Facility was changed in HITMAN and Diana’s voice was artificially altered to sound younger - there was a single line of dialogue that wasn’t altered. In Guided Training when you take the disguise of the mechanic, the line “You took his clothes, that’s a first…(it continues on from there)” is still the original recording.

This oversight has been carried over into HITMAN 2.

While not a “bug”, it’s something I was expecting to have been fixed.


#3

Follow up to the PM: on PS4

Here’s the enemy stagger animation colliding with the geometry boxes. It’s glitches them to hell.

It’s seems like Cassidy has amnesia and can’t remember 5 seconds ago. He’s stuck in a voice loop and can’t progress with him or the story/opportunity.

I assume, he’s hit a trigger to another set of dialogue while I interacted with him.

Even has the cheek to say “you’ve said this already” :joy:

When Janus’ head of security locks you in the study, the doors lock as normal. However, if you return and go int the study the doors luck every time you enter the room.

I assume it’s a “player enter/collide” to the invisible trigger box which automatically shuts and locks the two doors. The trigger box needs to be destroyed on short timer when the player touches it.

The guard is suspicious of me from the start of the level. I’m in a allowed space, yet this guard is suspicious. I’m on Master difficulty but I haven’t seen/read that guards/enforcers are suspicious of you in your suit from the get go.

EDIT: The police are suspicious of me too from the start

Apple glowing as interactive yet not able to pick up or destroy.

The reflection off the far window doesn’t show the barrier I am hiding behind, you have your full reflection.

47, is truly a ghost…


#4

Steam version, after the couple go to sleep, after a while they appear floating. I didnt do anything, just wait


#5

“She is a normal girl aside fro the fact that she sleeps above the covers. Five feet above the covers!!”-Bill Murray, Ghostbusters

Also there is an apple on the ground floor observation room that cant be picked up.

Also the news projection in New Zealand have stopped appearing for me (PS Pro)


#6

I’m having a problem with controlling 47, he keeps walking forward and I have to use the left stick the stop him. It’s definitely the game because I’ve tried a different controller and a different game. ???


#8

I don’t know if this is a bug or not, but it is pretty annoying. In the steam version, under different situations this little symbol appears for 1 second, I don’t even know what it represents, can’t save game maybe?

I found it in 3 cases for now:

when you are about to throw something

When under cover, you change your direction of looking from one side to another, just for a little moment

When just walking next to objects (not a blend in bench here)


#9

If there is no one to pick up the weapons that fall on the ground, he freezes. And does not react to bullet impact


#10

Steam version, noticed that when playing with a controler, if you want to leave a cover you can press B or press down with the analog stick.

If you use the keyboard, you can only choose to press space bar key, if you press down (‘S’ keyboard key) nothing happens. If I remember correctly, in the previous game pressing down worked.


#11

I’ve just downloaded Hawkes bay, the basics and Miami so far as my internet is very slow (Australia) I have played through Hawkes bay fine, but it keeps crashing to desktop when I try to load Miami and won’t play the mission briefing :frowning: Trying to download the rest slowly to see it it helps but it’s literally going to take me days.


#12

I believe it’s basically showing that you cannot save the game in the middle of an action, or sometimes, an animation.


#13

Steam version, the texture of the water is blinking, appears and dissapears all the time. My graphic card is an nvidia gtx 970


#16

#17

Speaking of bathrooms, have they fixed the problem of NPCs throwing up in the rubbish bins, instead of in sinks?


#18

Hello Travis or anyone from IOI.

Ok I solved 1 of my 2 problems. I have the GOTY legacy pack checkmark on hitman 2 and can play all from season 1 on hitman 2.

However the expansion pack how do I get that to check off? it says there is no content item might not be for sale yet, or no longer for sale.

I have collectors edition and did enter the code and redemmed.


#19

Hello to anyone from IOI, there seems to be a loading bug with season 1 levels.

I have GOTY legacy installed, I’m able to go into legacy Paris, I’m able to choose a suit, pick what gun I want, etc.

then I hit play, I see it loading , normally it will load in about 1 min. However after 5 min it still says loading.

I had to restart ps4.

I’ll try it again.


#20

Ok the retry worked.

the black loading bar on the right, I saw it go from white to black and finally it loaded.


#21

Hokkaido water is bugged.

Chef outfit has bad clipping around the ankles.

Minor spelling error in the tutorial for hiding in foliage (“of you stay low”).

Also, the intro cutscene to Hokkaido has subtitles appearing above the black bar. Haven’t checked other levels for this.

Finally, there’s no sound effect when hitting NPCs with certain weapons, like wrenches.


#22

this outfit includes a sick stache


#23

Hello, I am currently placed 1st on the Leaderboard of the Contract of “Featured, ICA Facillity, Final Test”,
With a score I made in 7;00 seconds.

Later on, I have succeeded twice in completing the Contract in 6;00 seconds.
But, the score is presented with 0 POINT!

Please fix this!
Thanks!
Taljacob