Official HITMAN 2 Bug Report Thread


#16

#17

Speaking of bathrooms, have they fixed the problem of NPCs throwing up in the rubbish bins, instead of in sinks?


#18

Hello Travis or anyone from IOI.

Ok I solved 1 of my 2 problems. I have the GOTY legacy pack checkmark on hitman 2 and can play all from season 1 on hitman 2.

However the expansion pack how do I get that to check off? it says there is no content item might not be for sale yet, or no longer for sale.

I have collectors edition and did enter the code and redemmed.


#19

Hello to anyone from IOI, there seems to be a loading bug with season 1 levels.

I have GOTY legacy installed, I’m able to go into legacy Paris, I’m able to choose a suit, pick what gun I want, etc.

then I hit play, I see it loading , normally it will load in about 1 min. However after 5 min it still says loading.

I had to restart ps4.

I’ll try it again.


#20

Ok the retry worked.

the black loading bar on the right, I saw it go from white to black and finally it loaded.


#21

Hokkaido water is bugged.

Chef outfit has bad clipping around the ankles.

Minor spelling error in the tutorial for hiding in foliage (“of you stay low”).

Also, the intro cutscene to Hokkaido has subtitles appearing above the black bar. Haven’t checked other levels for this.

Finally, there’s no sound effect when hitting NPCs with certain weapons, like wrenches.


#22

this outfit includes a sick stache


#23

Hello, I am currently placed 1st on the Leaderboard of the Contract of “Featured, ICA Facillity, Final Test”,
With a score I made in 7;00 seconds.

Later on, I have succeeded twice in completing the Contract in 6;00 seconds.
But, the score is presented with 0 POINT!

Please fix this!
Thanks!
Taljacob


#24

You might get stuck in this wall, take care:


#25

Don´t know if it´s a bug or maybe intended but after aiming the dot jumps upwards and the gun doesn´t aim where the dot points to. This causes 47 to just aim higher and higher when aiming in and out


#26

yeah i noticed that, very annoying


#27

Invisible Wall here


#28

If you drop a gun in the jungle bushes, the guards will spot you


#29

Guards walk through doors after loading a save file. Noticed on hokkaido legacy pack.


#30

Miami

as a mechanic , at my station, I get the phenumatic gun and then add a explosive device, I chose the pale duck, and 2 x a blue error message pops up on my ps4.

I have to restart the game.

not good,

you guys need a major patch


#31

The frog’s placement model is a pill


#32

Steam version, sometimes the music just stops (at least in Miami). I have to reload the latest savegame to make it start playing again.

Edit: not only music, people background speaking ambience sounds also stops


#33

Steam version

  • 47 can’t walk slowly on stairs
  • music/speeches/voice sounds/facial animations disappeared map-wide during “The New Army” mission story (returning to main menu fixes that) (see post above me)

#34

Items and you become invisible here


#35

I’m having an issue where the Columbia Mission saying I do not have access. I’m on Xbox One. I have it installed. I uninstalled the map and then reinstalled it and still have the same issue. I was able to download the legacy pack with no issues. It’s just that one mission.