Official HITMAN 2 Bug Report Thread

I’ve only ever had the ‘Piano Man’ challenges pop by using the Fiber Wire; never any other strangulation device. I’ve always assumed that this is simply because the Fiber Wire is made out of a Piano string whereas the other devices aren’t.

is anyone else having the problem of not hearing explosions from bombs and also not hearing the gas station pumps explode in columbia? pc player on steam

2 Likes

Status goes from Compromised > Combat > Compromised > Searching…

Seems to be a bug with the compromise system.

2 Likes

Looks like latest nvidia driver (418.81) broke water again. Same happens in Hokkaido. What I find weird is that I didn’t encounter this bug at launch (when people reported it), only now. Tried veryfing files and it didn’t change anything.

Just noticed someone else also reported it and has the same driver :slight_smile:

Platform: PS4
Can’t progress the discovery challenge. As u see, my Nightcall Mastery level is already reached 5/5, but the discovery progress still stucked at ZERO. I have completed the game for many times, other challenges were doing fine except the discovery.
I also tried reinstall the whole game (with and without updates) and deleted all game saves, but nothing worked out, couldn’t trigger the discovery challenge either.

I’ve had this locked for 4 weeks, I’ve completed every single challenge on the game on every difficulty, and there hasn’t been any solution to it, I talked to WB Support for a whole week, and they just redirected me to IOI, I’d really like for this to be fixed, for it’s getting extremely frustrating. I’ve tried everything. I’ve copy pasted this from this this thread I made.

20181218194820_1
@Travis_IOI
@Clemens_IOI

1 Like

I used all of the explosives in the game. Replanned multiple destinations multiple times. I used everything from the breaching charge to CX block. I tried placing the explosive on doors and in front of doors. I have used both normal explosives and concussive bombs. I have even tried multiple explosives like making stacks of propane tanks or fire extinguishers. Also am I the only one that has noticed fire extinguishers no long kill people? Did the devs change it to a concussive bomb?

Ive had 0 issues with explosives opening up doors.
You could be either placing the explosive wrong or its a door that can’t be blown up like certain keycard only doors.

Examples of blowing up a gate and door

Gate 2:00

Door 00.30

Fe is non-lethal and only knocks them out since launch

Before the upcoming Patch in February 8th, I want to remember the Developers that when the enemy fires with the Shashka A33 H, there’s NO Sound Effects, only bullet impact are heard. and there’s NO Sound Effect when you Stealth Attack enemies with the Wrench from Behind.
Please fix these Bugs as they honestly ruin my experience with the game. Thank you.

Genuine question: are you saying that you’ve been having the same problems with explosives not opening doors or that you haven’t been having that issue?

Yes, im missing explosion sounds in Mumbai esp those carts a the gas canisters, also other places w gas leaks & even cars if enjoy them instead of shooting the gas leak, it’s actually so irritating to the experience. The tiny bugs feel like death by a thousand cuts.

Wow. Good catch. I never would have noticed.

Currently experiencing a water bug again, as of latest NVIDIA drivers, on Season 1 missions. I would use more technical verbiage, but I’m nearly certain I wouldn’t use it correctly, so here’s a picture instead.
On Windows 10, PC. Can post hardware if requested.

You need to downgrade your driver to 417.71
https://www.nvidia.com/download/driverResults.aspx/141906/en-us

Clothed Sean 2 could really use some socks… or legs in general.

3 Likes

No table shadow :sob:

20190207153340_1

1 Like

Spoted a couple bugs om Hokaido (Sitius Inversius).

  • Satring in the morgue with the winter sport gear will get you hunted without leaving the bed.
  • The 5mm custom can be reloaded (+infinite ammo): didn’t test it on other levels
  • Water still bugged in the couryard.

Other spoted bugs:

  • Striker & Silverball not chrome anymore
  • Conceleable batton and mesuring tape inventory icon bugged
  • Fish not in the weapon side of inventory

You’re not alone with that bug, I’m on Windows 7 and have the same issue with water.

I’m on PC, and I took this screen-shot just the other day. I was not able to reload this gun. Not even dropping it and letting a guard take it would reload it (that used to work in 2016). Are you on a console version?.. Or maybe there’s some other factor that determines if this gun can be reloaded.

The gun started in case (ICA drop). An it’s the PC version