Official HITMAN 2 Bug Report Thread


That’s why I said RollBACK not forward. Nvidia driver 418.91 is the current release and it’s broken for this

You either need to use an older driver that isn’t broken or wait for Nvidia to release an even newer one with a fix

Selecting 418.91 is one of the broken drivers

I’m back on driver 417.71 without any problems and I’ll be waiting a long time before I bother to update.


Like Kunovega said, in 418.91 water is still broken and nvidia lists this as an open issue, so at least they acknowledge it.
So we might get the fix next time. At least I hope.


I’ve been having the game crash while playing in Sapienza, Landslide. PC/Steam.

I’ll try some other missions to see if it’s happening anywhere else.

ETA: In Sapienza, The Author - I keep losing ‘Never Compromised’, even though I’m never spotted. But one strange thing - I get a ‘Body Hidden’ Bonus when (the book guy) is release by his body guard (in his body bag) in the morgue.

Edit2: No. It’s that f_cker Jeff. So now that we lose SA because he suicides, there’s a new hidden objective… Save Jeff. :sweat:


Heck atleast I’ve delivered the info to this local that 418.81 / 91 are no good.

Magazine half loaded ammirite? <.<


I’m getting a non-target killed penalty whenever I blow Sierra Knox up in her car. I’m positive I’m not accidentally killing any other NPC’s, and I’ve tried blowing her up at different points on the race track. I’m on PS4 by the way. Thanks!


Yea cause you killing the car’s AI.


=D nah jokez



I did the cheyo calibration to get the siege 300 ghost sniper and i lagged out while exiting the last level when i came back to the screen it said i had completed the escalation and even got the feat for doing but when i got to my inventory the sniper was nowhere to be seen this happend on december last year and i have tried redoing it contact wb support and i still dont have my promissed sniper


I see a lot of complaints to do with challenges. Maybe IO should introduce a feature that allows you to reset a challenge, minus the XP. It would also be a welcome feature for challenge guide makers.


I know that it’s not really the solution, but you have the Sieger 300 Tactical. They’re essentially the same to my knowledge.

Edit: Apparently the Ghost has an extra zoom level and is slightly quieter.


Hope it’s okay to post this here as well.

So I downloaded the legacy pack through the in-game store in Hitman 1 (I think, may have been through 2), received the requiem pack in the list of downloads, along with the episodes of course, but when I booted up the Hitman 2 prologue the briefcase never showed up. I would love to start a mission with a briefcase, and I plan on buying 2 as soon as I can afford it, especially after playing these maps in 2’s engine and seeing the homing briefcase videos. As you can guess, I’m on PS4 and now have season one thanks to Plus.

HOLY SHIT IT WORKED!!! So for anyone else who finds this topic just make sure you play at least the Paris mission using Hitman season 1, complete it and then when you load up Hitman season 2 it should pop up.


Did you try to reset the Escalation to Level 1 and complete it again from 1-3?
I know it’s already shown as completed in your challenges but maybe that triggers the unlock.

Sieger 300 Ghost:

  1. Lethal bodyshots on every range (All Sieger all have medium lethal bodyshot range)
  2. Can open doors from every range (All other Siegers can only open doors from a medium range)
  3. Slightly lower fire rate than the other sieger 300
  4. Same sound range as all other Sieger 300 (in Hitman 2016 the Ghost was silent as the Krugermeier)


Try resetting the escalation, and replaying and hope that your internet is a little more stable as you finish up.


If anybody knows their sniper rifles, then it’s you. :grin:


Catalina Delgado drinking her wine never counts as a poison kill. (Location: Santa Fortuna)

During contract creation I noticed that if you used a consumed poison on her wine glass, she would die, like this:

But the game only records it as “any method” like this:

Now I am aware that often “during” contract creation targets will say “any method” (that’s probably it’s own bug, it happens often for various poisons and accidents like electrocution) but that upon exit your summary screen will (usually) adjust to the actual kill method. However, with Catalina and consumed poison this was never the case (sorry, didn’t screen shot it, but my summary screens were always “any method”.)

To rectify this (since I planned on making a 5 kill contract with all “poisons” I discarded the contract, started over and killed her with a lethal syringe. During final setup I changed all targets to just “poison” and removed all the consumed/syringe requirements.

This worked as far as contract set up was concerned. However, when attempting to actually play the contract, I’m seeing the same results as when I was creating it originally:

Here I have killed the target with a consumed poison, but failed the requirement of using a poison:

I’ll replay it and jab her with a needle and it will likely function, but it’s clearly a bug that her consumed poisons are not counting as poison kills. (it’s also kind of a bug that several poison and accident kill types don’t show as results during contract creation until you exit and reach the summary and final setup screen)

Platform: PC (windows 10, steam)

If it helps these bugs were experienced during the creation of and then while playing this contract:

The Divination ~ A Shaman’s Tale

I can make a video for you if you can’t recreate the issue for testing


Was trying to do the Shaman Shenanigans challenge where you poison 5 people, but there’s a bug at the Shaman’s hut, where as the hippie man just stands there when you take the Shaman’s disguise, and he doesn’t move (let alone drink from the ayhusca)… wasted so much time trying to get him to drink from it, but he just wouldn’t!


I just got the new Shaman powder from the challenge, but I think something is wrong.

I saw a video of someone else using it on the PS4 version and the power exploded and made everyone around unconscious. However I am playing on a PC with Windows 7, and whenever I use the Shaman powder it just acts as a harmful explosive killing everyone. No unconscious people, just lots of dead bodies and angry guards.

I really hope this isn’t intentional because sleepy smoke explosions would be absolutely fantastic when I’m running around with my Isle of Segail suit pretending to be the Phantom of the Opera!


I would much prefer an item that makes multiple people instantly unconscious rather than makes multiple people dead, the latter is not very sneaky and already exists in the form of several funny looking bombs!


Here. Go to 21:42

He’s playing on the PS4 version of the game.

In the PS4 version of the game the Shaman Powder knocks people unconscious, but on the PC version it simply kills them. I think the PS4 version is more obviously how the item is intended, and that the PC version is bugged. An item that knocks people out would be a lot more useful since we already have at least 5 different unlock-able explosive devices.

split this topic #2671

46 posts were split from this topic.