Official HITMAN 2 Bug Report Thread

There seems to be a chain of events that causes the bug. I just got the achievement by:
0) starting as an Investment Banker

  1. b-line to her office.
  2. Turn off the wi-fi in her personal cafeteria,
  3. when she sits down, turn on the gramophone and retreat back to the coin displays.
    *) If she gets a question mark above her head, she’ll be distracted.
    **) Make sure to save as she doesn’t always check out the reward!

My understanding is that she just cannot be distracted - this method works? I am not going to be able to check for a while, maybe someone else can look into it.

I just finished Another Life for the very first time, and I noticed that I got the Priceless and Someone Could Hurst Themselves challenges without doing anything to actually achieve them. I never delivered any pachage to Batty, and killed the targets by drowning Janus in the toilet and used the insecticide to pacify Cassidy and snap his neck.

1 Like

I don’t know about Priceless but you get Someone Could Hurt Themselves by killing a target with an accident kill, which you did to Janus.

1 Like

Never noticed that drowning a target in the toilet also counted as an accident. I got both Hold my Hair and Someone Could Hurt Themselves.

What buggy about it?
It always was like this.
You might have mistaken with a thread.
The right one is here:

It was not a mistake. I initially posted this as a bug report a few posts above, then Ibbe040 told me that it was just like that, and then I replyed to him again.

Ok, but still, this is not a bug.
It’s ok

Not really a bug, more like a curiosity with the level design but don’t know where to post it.

In Miami there is a spot with an invisible light source

This is where the light should come.
ApplicationFrameHost_XJf2GLBBM7

the place is behind the flamingo hotel.

4 Likes

Platform: PC
Location: Isle of Sgàil
Mission: The Ark Society

I encountered a bug which prevented me to get SA rating while playing on master difficulty. I tried to kill Zoe Washington during the wake, while disguised as Janus’s body. Near the end of the event, the Constant SHOULD say a few words and leave, allowing me to kill Zoe in peace. However, he decided to go AFK in front of the coffin after saying his words, leaving me with the choice to either kill him (and fail the mission) or stand up and get spotted. This seems to happen randomly, I played through the event a couple of times and it occurred twice in total.

For some reason my game crashes when I select the cashmerian suit, antique knife, flash phone and emetic grenade. This happens when I bring them into a level all together. It almost f-ed my ps4 up. No matter what level I’m in.

PS4, Santa Fotuna

There is a house when you can ring the ringbell.
After ringing, the girl inside the house comes to the door (as expected), but the door doesn’t open even if the girl stands front of the door. The girl stays for a couple of time at front door, “merging” into it. After a certain time, the girl goes back to her occupation. However, you can’t ring the ringbell anymore.

Location of this house:

2 Likes

I have found another strange behaviour. I have received the Breadkcrumbs Trail challenge, but I didn’t even found how to unlock the Breadkcrumbs Trail Story. I didn’t discovered the story yet, nor is it marked as finished. This has to be a bug, right?

I really don’t know if that’s only my experience but the Golden Handshake has been very subpar in terms of animations and general polish. The whole level is very poorly optimised and runs by far the laggiest of all the łevels. I’ve been holding off reporting this because I thought you’d patch it to working order but that hasn’t yet happened

The NPCs look like cartoon characters with these over-the-top facial expressions and it just looks plain terrible. I know this isn’t a sudden shift in tone because other models you’ve used in the past still look fine and like normal people.
I’ve had the hobby of taking beautiful screenshots in the game with Ansel because this game usually looks amazing but this level is such a sore I couldn’t let it be like this

I’ve just attempted the Master Mode SASO on “Isle of Sgail” while using the Cashmerian suit.
Although I completed the mission SASO, i was not awarded the challenge. i tried multiple times without success. When i changed to the standard masked tuxedo and attempted again, the challenge “popped”.
I guess the cashmerian currently doesn’t count towards SASO?

1 Like

Alright let me just sum up what I believe are the most urgent issues

  1. ACCIDENT KO
  2. TRANQ GUN WHILE SITTING
  3. CASHMERIAN/SUAVE SUMMER SUITS IN CONTRACTS MODE
  4. ATHENA NOT REACTING TO DISTRACTIONS
3 Likes

ALL 3 ARE KNOWN ISSUES AND ARE PRIORITIES FOR THEM.

Tranq while sitting is new and it hasn’t been reported as much so unless they saw the one or two posts about it then it will take a while to fix.

Tranquilizer on a sitting npc will count against No Bodies Found

6 Likes

The Emetic Grenade has the wrong preview image.

image

3 Likes

Atm Cashmerian and Summer Suave don’t count towards SASO

I would say Emetic Grenade has the wrong actual in-game image.
Preview image is that that should be in-game