Official HITMAN 2 Bug Report Thread


#2030

Another thing, the cannabis joint that you give to Mr Caruso does not make him lose consciousness and go to the balcony, instead it triggers an alarm and an evacuation. It must be really potent stuff if it makes him go into a panic mode immediately and run to the underground lab with his guards! This has been encountered on Master Difficulty in Sapienza.


#2031

The Constant keeps bugging out randomly for me.

THere’s some weird takedowns happening with physics laws in this game.


#2032

PC. Obv. needs to be closer to tub to sulk for whatever reason.


#2033

at funeral, chairman finishes speaking his final words to the “dead man” aka you. and keeps standing there and looking around. have found no way around the bug whatsoever, am on pc. Slightly annoyed because i was trying to finish the game on my day off and can’t possibly do anything about it and i’m sure as hell not restarting the mission. have reloaded into different save points and done different things to try and get around it but to no avail.


#2034

Has Demian been hanging out with the Shaman a lot recently? I don’t think he should be able to walk that far underground, or rubber-ball back to the surface in this fashion after such a big fall.


#2035

I remember that happening to me on Xbox. Meant to put it in here but forgot.


#2036

Sapienza has this. Run up to the room Francesca searches, she enters with one guard and another goes back to the room with the fireplace. Choke the guard immediately on entry and nothing happens but as soon as she’s knocked out or killed that second guard immediately comes out of the room by the fireplace, it’s triggered by her going down.


#2037

Are you waking up the waiter? I did it yesterday on Master and Casual and it worked both times. Go to the sleeping waiter, switch on the radio, then go off to poison the food, job done.


#2038

Dear IOI customer support and developers,
I (and from what I could find out tons of other people) am experiencing a bug with one of the challenges for the Legacy map Paris. The Challenge in question is “Photobomb”. Whenever the interview is about to start and the Reporter puts her camera down, she just walks away. Novikov still sort-of walks up to her camera but then walks off almost immediately. He doesn’t even get close enough to the camera to possibly get hit by the explosion in the first place.

This problem is on PC, happened to me today (01/01/2019 - Happy New Year!)

I created a short, concise video showcasing exactly what is going on. Everything I do is time-stamped in the video description. I hope I can help out.

One final thing, I tried bumping into the reporter until Novikov arrived (not on video) and it didn’t do anything either.

Thank you very much for reading this.


#2039

I started playing Mumbai just a couple of days ago and upon finishing it, I got 4 stars which really surprised me because I do not remember being spotted by anyone. However, I still unlocked the Silent Assassin by some weird virtue.

Played it today for the 2nd time, very carefully to ensure I wasn’t spotted even with the current, flawed state of the suspicion/trespassing mechanics but its the same thing once again.

Here’s a screenshot for proof. I haven’t received 5 stars in either of my playthroughs despite unlocking the SA challenge. This is complete BS. How do I fix this?


#2040

Can anyone tell me the conditions to achieve Sniper Assassin?
Yesterday I was playing Landslide, and after getting Abiatti to the graveyard, I shot him on the head with a Sieger 300 Advanced.
Thing is, when I exited the level by the gate with two guards, even if it told me I had gotten Silent Assassin, Suit Only, the Sniper Assassin challenge wasn’t unlocked. I got five stars by the way, no one saw anything.
Is Sniper Assassin still possible in Suit Only runs?


#2041

Item sizes and briefcase issues:

A New Bat: can only be brought into a mission as smuggled, so you retrieve it from a briefcase to get it. But it can not be placed back into one as if it’s too large

Meaty bone and sacrificial knife are “large” during mission set up, the only way to bring them into a mission is with a briefcase/smuggle location, but they are actually small once you have them in your hands and can be holstered like any other small item hidden within your suit

Also note: A New Bat seems muted, the noises it makes are very soft compared to what I remember from the previous game, could you tweak them to be louder? The only point in using the bat is the funny noises


#2042

It should be, sniper assassin does not even require silent assassin or suit only, doing those on top of the sniper requirements should not change anything

Sniper challenge only requires that you use the sniper for the kill, no non target kills and not be spotted committing a crime, not being spotted is already a requirement for silent assassin along with no non target kills so meeting the requirements for SA (which also includes no bodies found) would mean you met both requirements (and suit only is its own thing, not required for either sniper or silent assassin ~ nothing requires SO except the challenges that actually state suit only)

Read the challenge in game, it tells you what the requirements are. If that doesn’t work, it’s bugged


#2043

Weird. I’ll try to get Sniper Assassin later today if possible, then.
Thanks for the info!


#2044

Zoe Washington and Englehorn occasionally freeze completely during their conversation


#2045

Wet Bandit Challenge appears to be broken

Challenge requires you to kill a target by dumping them down a manhole on Whittleton Creek, but doing so no longer unlocks the challenge


#2046

That one is weird because Ive seen livestreamers fail to get the challenge but in the next same attempt, they got it.

Challenges can be bugged if you do them in a loaded up save so restart and try to do it without loading up a save and see if it works


#2047

Rarely in a Ghost Mode it can be a situation when a target mark appears, but there is no human target exists.
For all the time I’m playing Ghost Mode it happened to me third time today


This time the target mark appeared outside the playable part of the map


#2048

I have experienced a bug in the Hitman Legacy Hokkaido level, where NPCs will phase through doors without having to open them. So far, I have seen this in the wooden sliding entrance door to the restaurant and in the hospital area. I am playing on Xbox One and I have a clip to show as an example. Hope it can be fixed. Click on the link to a video: Example of Door Phasing


#2049

Platform: PC
Issue: Explosive gunpowder doesn’t ignite when cigarette is thrown (second animation).

NPCs appear to have two different smoking animations. One where they smoke and put out the cigarette by stomping on it and another where they just throw away the cigarette. On the first animation, the gunpowder ignites and works perfectly fine but on the second, no matter how well I position the gunpowder, it never ignites. Its weird because I can get the big one the spark perfectly in both cases. Please fix.