Official HITMAN 2 Bug Report Thread


#2050

Is there something wrong with the NPC crowd AI in Mumbai? I went on a shooting spree, and they all just stood there. I think one person bothered to go grab a guard. They ran away in Miami, if I recall.


#2051

Crowd npc arent real npc, they are just “background crowd” if you know what I mean. They have no script so they cant tell a guard or something like that. They just move away or run away if there is chaos. If you hold the instinct button pressed you will see that the crowd npc dont have any outline but the normal npcs does, those who have outline are the only ones capable of telling a guard if there has been a gunshot

For example, the crowd in Miami cheering for the race are just filler crowd, they dont have any real script


#2052

When setting off the winch for the chandelier to kill Zoe with it will always give you hunted or spotted, no matter where you are. Here’s an example below, I can make more extreme ones but it should suffice.

All of the bombs and even shooting it (the winch) will result in being compromised.


#2053

Since the last time I reported various bugs, I have continued to play through HITMAN 2 and as of right now, I’m working on completing all the various challenges in the locations. I have encountered a variety of odd bugs, all at Whittleton Creek and I’d like to report them. The bugs I reported last time all seem to be fixed with the exception of the loadout screen inconsistencies. Xbox One player.

  1. As Janus’ odd ball nurse, there is a very specific spot within Janus’ house which is considered trespassing. At the top of stairs leading to upper floor, on the landing, towards the left-hand side of the top of the staircase is a small-ish area which is considered trespassing. I have been “found trespassing” twice as the nurse and have went into combat once. It seems to only occur on one side of the landing as the other is completely fine to traverse. This is not the only incident of weird trespassing boundaries as on multiple occasions I’ve found areas where I shouldn’t be trespassing count as trespassing and areas where I’m blatantly trespassing as completely fine. A few examples that I can remember would include:
    -Paris: As Palace Staff, there is weird spot on the staircase underneath the red carpet which Viktor Novikov walks down, which is considered trespassing.
    -Santa Fortuna: A few places in Andrea’s compound isn’t trespassing when in suit.
    -Sapienza/The Author: While behind Craig Black’s book reading, there are a few places right up against his Cassandra Snow boards which don’t count as trespassing while in a suit.
    I’ve only reported this nurse instance since it is first to really impact the game and it seems to also be the largest oddity in trespassing boundaries (the other examples I listed aren’t very large in size).

  2. Car Batteries are acting extremely weirdly on Whittleton Creek specifically. While I was looking for a way to electrocute Nolan Cassidy, I encountered some difficulties with electrocuting him with a car battery at a leaking fire hydrant. I spent about 45 minutes trying different methods of getting him electrocuted. First, I tried to shoot the car battery while he was investigating the leaking fire hydrant. He just went into lockdown and ran away. Secondarily, I tried shooting the car battery prior to him investigating the fire hydrant. Which also didn’t work. Last, I tried to throw the car battery into the puddle as he was investigating. Which needless to say, didn’t work. I decided to look at this more closely.

I set up the trap as per normal. Fire hydrant leaking and car battery shot. As 47, I walked into the puddle in the exact same manor as Nolan Cassidy… and died. At this point I was getting a little confused. Was Cassidy immune to any form of electrocution or 47 is just extremely susceptible to electrocution? I followed up this experiment with an attempt to electrocute a random civilian and citizen of Whittleton Creek. I set up the trap in the exact same way and got a random woman to investigate the leaking fire hydrant. She survived. However, at this point I noticed something about the car battery. I now looked like it been burned which implied that the car battery did give out an electrical charge, but it didn’t kill anyone… except 47. This makes it even weirder when I considered that nothing of this nature occurred in Mumbai when I was setting up a puddle kill against the Maelstrom. It may have something to do with source of water being a fire hydrant or the puddle drying up after the fire hydrant shut down, but I have no exact conclusion.

  1. The Wet Bandit challenge doesn’t seem to be unlocking for me. I have dumped Nolan Cassidy down the manhole in two different ways. Once while he was unconscious and once while he was dead. In both instances the challenge failed to unlock which was extremely concerning. It should be noted that I did use the very same manhole as an exit, but I fail too see if this would inhibit me from unlocking the challenge.

Thank you for fixing some of the few bugs I previously mentioned and excited for whatever surprises await in January for HITMAN 2.


#2054

I think the fire hydrant electrocution kills are bugged as is. The car battery seems to work fine when you use it on overflown sink puddles. It’s like a beta solution for now but it should work.


#2055

Can’t collect the explosive package from the safe. There is no prompt for some reason.


#2056

Not sure if it’s a bug or just said because I was already hunted, but “drop the scissors”? I’ve also heard “drop the syringe.”

Edit: also want to mention this new taser item is so OP. Should have been electrocution ACCIDENT if it was in water, like the big one was. But directly kill like this should not be an accident. It should count towards noticed kill (if seen), should count as bodies found (if found). Way too easy to kill guards now. The illegal handling of it does not pose much of deterant to use or threat to get caught.


#2057

I had no issue with it on Xbox…


#2058

When I start a Mission, the Shadow effects are just pixels (I play on highest resolutions)


#2059

Update your gpu driver.


#2060

That’s because they are a vampire shapeshifter.


#2061

Concealed Baton from the Legacy Pack also has this issue where it needs a large supply drop but is small enough to fit in 47’s starter pockets.


#2062

Security disguise in Mumbai has TERRIBLE clipping issues. Whenever performing actions such as climbing and dragging etc you can see 47’s skin through his outfit.


#2063

I can’t collect the secret key from the Nightcall mission. I’m unable to complete the challenge as a result. Anyone else had this and find a way to get it to work?


#2064

I dont think this is right thread for you not able to find a hidden key since its not really a bug.

If its the “under the mat” challenge
Spoilers

Its in a vase you can destroy in the pool house


#2065

I know where it is. The game will not let me pick it up.


#2066

Ok I thought you meant that you couldn’t find it. It is a bug then.
Have u tried to restart the mission or your platform?


#2067

I restarted game but not console, I will try that later thanks.


#2068

I used a pistol instead of an uzi and it let me collect it. Maybe the spray from the uzi was bugging it out.


#2069

I’m on Xbox and can’t even get that far. Tried multiple times. Diana says he should be along shortly finishing the story mission. The problem is the lady sits down the camera and walks off. She even walks by Victor like there is no more interaction between them yet he will go and wait for her for a few moments before getting mad and leaving. I can’t get him to come pass the last tree near the camera.