Official HITMAN 2 Bug Report Thread


#2070

Hector and the sheikh are just stuck in a constant loop. Trying to take out Hector on a contract. I love this game but damn is it full of annoying bugs.


#2071

Im having this on my end too, I tried restarting 20 times, same result every time.


#2072

Hello, I found a bug that occurs during (at the very least) on “Nightcall” in Hawke’s Bay. If you start the level with The Kalmer Tranq Gun stashed in the beach drop point. Then break into the saferoom, get the Kalmer from the safe room, proceed to the beach drop point and pick up the Kalmer you arranged to be stashed at the start of the mission the game crashes. I assume it’s due to the Kalmer being limited to 1/1 ammo and if you have one Kalmer with full ammo and go to pick up a second Kalmer, instead of ending up with a Kalmer 1/3 ammo readout, the game crashes since the ammo is maxed at 1/1 and it doesn’t know how to reconcile it.

Game: HITMAN 2 (on Steam)
Platform: PC (Windows)


#2074

Hey guys! I’ve found a tiny issue in Mumbai (PC) that I thought might be super easy to fix. Just not sure how to explain.
There is an alley you can come through, but it seems to be “blocked” on the map. Take a look at the screenshot, the marked “house” (dark grey) is actually not there and the alley should be all light grey. Dunno how to explain it better than that.

I have just started Mumbai yesterday and I play without minimap.


#2075

why do the guns look exactly the same as hitman 1 why its just called mk 2 look now but it is exactly the same ?


#2076

Guard has heart attack and dies… cost me an NTK… :stuck_out_tongue:


#2077

He must have heard you were coming and got scared :joy:.


#2078

PS4. Just realized I do not have the PS4 trophy for doing all the mission stories in Mumbai despite actually doing all of them. I had the same problem with the same trophy in Marrakesh but I fixed it somehow, I will try it fix this one too


#2079

Columbia, Delgado Mansion, in the basement storage room just off the kitchen is an ice machine plugged into an extension cord that can be tampered with to create an electric hazard.

The ice machine works even when the wall socket it’s plugged into is turned off

The extension shuts off if you shut off the wall switch (so there’s no power running to that), but the ice machine which plugs in after it works no matter what position the wall switch is on or off


#2080

your graphics driver is not up to date


#2081

Mission: Marrakech
Location: consulate
Platform: PC

On the main stairs there are usually 2 guards who search you for weapons. I dropped a gun and a civilian called the guard on the left stair (the stair on the bathroom side) to take it. With a coin I attracted him in the room where the masseur is usually at the phone and I neutralized (not killed) him. Now left stair should be free…but it is not so! When I arrive at the place where the guard usually stood the “hold X to be searched” still appears. If i press X 47 just stays still for a 20-30 seconds, without the possibility to move or cancel the interaction and then he spread his arms and get searched by an invisible guard! If I try to pass the stair without getting searchd I get attacked.
In other words, even if the guard is neutralized the perquisition script remains functional.

Sorry for no pics but I overwrited the save.


#2082

Further info on the bug with shadows not rendering on specific outfits in Hitman 2 maps: They kind of render but only at a very specific camera angle. Not entirely sure what’s going on there. Here’s hoping it gets fixed soon, I really want to rock the Raven suit in more maps but my shadow existing as only a floating head really throws me off, hahaha.


#2084

I don’t think you should be reporting bugs cause you’re just gonna delete your post within 24 hours anyway lmao.

Edit: And I was right


#2085

(Xbox one) Tried it aswell, she does the same thing here just drops it and walks away Novikov turns up walks untill the single bodyguard standing at the fountain and turns around and start walking his normal route.


#2086

Hello there,

we are playing PC version of Hitman 2 and have noticed that the explosive rubber ducks are not deadly any more, neither when the NPCs pick them up nor when you directly place them on a body. This makes the rubber ducks quite useless. Hope it’s just a bug and will be fixed.

Greetings


#2087

I watched somebody using it in a stream last night. Are you sure you’re not using the concussion duck?


#2088

oh damn… you’re right… our mistake. Didn’t notice there is a new type of duck, since the desciption don’t mentions a difference, sorry.


#2089

Platform:PC
Mission:Showstopper(Playing this mission from Hitman 2 Legacy Pack)
Location:France

I got the disguise as Helmut Kruger and went to meet with Dalia Margolis and when she was speaking on phone I poisoned the wine on the table with Emetic Rat Poison and when she drank it she just started walking in a direction through walls and literally everything in her path and finally she was walking in the sky outside the palace.(sorry for the video being soo laggy because I have a slower PC)https://youtu.be/ELcVhHWSX6k


#2090

PS4 pro
All maps, inc legacy maps.
All audio starts in instinct
(This was in HITMAN™ 2016 as well and never got fixed).

Missions sometimes start with all dialogue (and all other audio in-game like shooting, blowing up things, everything) with echos. I believe it’s from instinct because when you use instinct around NPCs talking, their audio is echoed. If you shoot or blow something up in instinct, it has that “background” kind of weak sound effect. So it’s as if ALL audio is stuck in instinct mode.

So when I start a contract and I’m getting this bug, I just use instinct real quick then let go of the button and it’s back to normal for the remaining of the contract but just that specific run, because if I restart, there’s always a chance it comes back when the contract starts again.


#2091

I play on an Eyefinity triple monitor setup, the resolution is 6048x1080. 6048 = 3 x 1920 + 2 x 144 (bezel compensation)

There is absolutely no problem with graphics, I mean 3D, the game itself. It is displayed on the whole screen, centered OK, and takes the bezel into account.
However, the HUD and other menus do not. Indeed, the menu is 1080px wide and starts from the right edge of the left screen instead of the left edge of the middle screen, as if there were no bezel compensation.

You can see below that the menu and objectives are shifted to the left, so they are hidden by the monitor bezel.
The center dot is shifted as well (i.e. it is not a center dot anymore, you can see it on 47’s head), so it is difficult to aim.

Note that I had no problem whatsoever with the same setup on Hitman Absolution.

Thank you in advance.