Official HITMAN 2 Bug Report Thread


#2092

Hello,

The challenge Photobomb from the Paris mission’s Hitman 2 version is bugged. It may have been broken during a November update. When Lana Caprice, the blogger, sets down her camera in preparation for her interview with Viktor Novikov, she walks away and the interview never occurs. This happens as soon as the “mission story” completes.

I know several others who are having the same issue.


#2093

Hello. As you said yourself, many are having the same issue. IOI knows of this already and most likely are fixing it with the next patch.
The latest patch messed up her routing somehow.
Be on the lookout for updates, maybe we’ll get a date on the patch in the roadmap


#2094

I was playing a Miami contract on Xbox yesterday, and noticed a dead zone in one of labs where it’s impossible to detonate explosives. Tried to catch a few examples here:

Seems to be anything around or behind the wires on the floor.

Also, I was messing with gunshot distractions in that area, and some of the guards around Knox can register where the shot is taken from and investigate your location (rather than where the shot lands, even with silenced weapons, in cover and unnoticed).


#2095

Same thing Santa Fortuna


#2096

I am playing the season 1 missions in the legacy pack that came with Hitman 2. A couple of bugs so far:

  • people not being poisoned with emetic rat poison: I have encountered this twice. First, in Italy in the underground lab, there are scientists working at a table. One of them walks away from time to time to drink from a water bottle near a guard. These are the scientists closest to the portable toilet. When the woman scientist drinks from a bottle I poisoned, nothing happened to her (I tried several times). I could see that when she was drinking, she was holding a bottle to her mouth but there was also still a bottle on the table. The second time this has happened is in the Morocco mission. At the embassy, in the room with the massage therapist, a man in a suit keeps coming in and out to drink from a cup of coffee. I poisoned that but nothing happened to him.

  • another bug is in the Bangkok mission, with the Tuk Tuk mission story. I fix the tuk tuk. But when the gardener switches it on and sees that it works, instead of walking away to fetch Morgan, he steps back and tells Morgan that it is working and to try it himself. Meanwhile, Morgan is roaming around elsewhere on the map. I tried three times, same thing happened each time. I even punctured the barrel and walked away to see if maybe it would work while I was off killing Cross, but it never did.

Edited to add: playing on PC through Steam


#2097

Two bugs I’ve noticed:

  1. As of December patch, the magazines of AK rifles held by NPCs are glitched:

  1. In the Final Test, the white dots of enforcers don’t disappear when they’re dumped into containers, unlike the other maps where the December patch fixed this (however, it also didn’t address white dots appearing for unconscious enforcers in the open).


#2098

PS4 pro
Starting on the barge with suitcase

When you slide down the ladder, 47 has the briefcase teleport into his hand afterwards. Video:


#2099

Unsure if intended, but the thrown frying pan behaves like a knife: it plays the same sound as a sharp lethal object being removed from a body when picked up (after throwing it at an NPC).

Also, with the horizontal angle of the pan 47 that holds, it clips through his model often.


#2100

PC, Mumbai:
The pot plant stash in the chawls is displayed on the (mini)map as located on level 3, while it really is on a balcony on level 2.

Really minor point, probably related to it sitting elevated on the balcony fence (when you climb through the window, you get displayed as being on level 3 for a split second aswell)

I simply noticed it when trying to find the stash for the first time ingame, located once it is no problem.but it might confuse new players.


#2101

In the one with the politician in Sapienza there’s the same drink problem with the vendor near the toilet, the one that has the car key. Two bottles.

For the tuk-tuk I can’t remember for certain what happened in Hitman 1, whether the gardener went to find him, but I wondered what was going on this time around as nothing appeared to happen. He DID eventually make his way to the tuk-tuk, though it took a couple of minutes. Maybe just wait a bit.


#2102

Thanks for the response. For the Tuk Tuk, I did wait about 3 minutes and the gardener went to go sit on a chair. I then just walked away to a different part of the map and the death was never triggered while I played that save (another 30 minutes or so it took me to kill Cross). Did find one other complaint about the same thing on Reddit so think it is a bug.


#2103

Hm . . . maybe I did it before the last patch, probably did actually, but I burned him when he got there. To clarify, I meant it worked in Hitman 2. The gardener didn’t go to get the lawyer and I wondered what was going on, the man was wandering around a long time before starting down the side of the hotel. I was on my way out when I realised what was going on, ran back and got the challenge/feat/whatever.


#2104

For some reason, the Wet Bandit feat in Whittleton Creek won’t unlock for me. I’ve pretty much tried everything but I still can’t get it.


#2105

Ive read many having an issue with it and seen a livestreamer dumping one of them in the manhole and it didnt work, after 30mins, he dumped the target the exact same way and it worked.
I dont know what triggers it to work and prevents it. Restart your platform and dont do the challenge on a loaded up save file. That works sometimes for some challenges. Or wait and just do it another time


#2106

The game will still mark the Mission Story as complete if you finished it while you weren’t tracking it and issue the relevant challenges - but they will not count towards the trophy. To get the trophy, you must complete them whilst tracking it.


#2107

Just got it. I just kept on reloading my save file when the feat didn’t pop up until it finally did.


#2108

First I had issues when I tried to launch the game in windowed or borderless. The issues is I hear sound and when I do inputs I get sound as feedback, but I just see black. So I rebooted my PC to see if that fixed it, still nothing. Turns out it only works in fullscreen (exclusive). Then I get into the game and I can’t go online no matter how many times I retry, but like I’m pretty sure I’m online unless I’m able to post this while I’m offline. :woman_shrugging:

Game worked fine after the “save menu” patch and I don’t think there has been more patches? though maybe there was because the game isn’t working as expected.


#2109

I keep seeing these kind of things where guards bugs out trying to pickup briefcases i leave around the map, here was the Church in Sapienza.


#2110

In Whittleton Creek, found a couple of bugs:

  1. James Batty’s voice completely switches VA/accent when speaking on the phone while he’s seated at the planning table.

  2. Unlike other vehicles, this specific one (north part of the map) does not respond to the detonation of any explosive, whether attached to its body or left on ground.


#2111

Ratings are bugged, I was not spotted and the mission XP awarded me Silent Assassin, but the detailed score failed to list it as Silent Assassin and gave me no points for “never spotted”

Here’s the details score page:

And yes that’s a fresh run with no left over XP from restarts

Platform: PC (steam)

Here’s a video of the play through, I don’t see anywhere in the mission where I was spotted

Mission is Patient Zero in Hokkaido

Also: In this video the nurse never reacts to the gun dropped on the ground, I’ve done this method before and she normally walks off to find a guard, for whatever reason this time she bugged out and ignored the gun on the ground (twice). That glitch is unrelated to the spotted issue though because I’ve repeated this run and similar and while she normally goes and gets a guard, the end screen always shows me without silent assassin (and no score for not being spotted)