Official HITMAN 2 Bug Report Thread


#2174

Yup, bugged for me too. As for a few other people too (Reddit).

Also, the steam achievement for completing 10 contracts won’t pop-up…


#2175

A few bugs that may have already been mentioned:

  1. Some NPCs walk on top of static objects.
  2. Sometimes an NPC will glitch in a wall after being shot.
  3. In Isle of Sgàil, showing The Constant the blueprints with an apple equipped causes 47 to, comically, present an apple with the blueprints hoving next to it. This may apply to other objects as well.

Thank you for all of your hard work on the game. ^^


#2178

In the middle of combat in Mumbai in Xbox one game crashed suddenly right after Boyz n da wood challenge unlocked and kicked out to main screen game reloaded completely Romain menu and had to pick profile and start all over wth? Game lags as well.


#2179

Issue: “Discover Paris” Challenge locations is bugged, stuck at 38/39, with no remaining visible “undiscovered areas” on any level of the map or on the legend.
Platform: PC and PS4 (likely Xbox One as well)

Description: So I think I know what’s going on with this one. On my initial playthrough (on Steam/PC), I did holiday hoarders and showstopper, explored every area Except the sniper tower and I was at 38/39. Then on a second/third playthrough I used a lockpick and got to barge/sniper tower area and it triggered 39/39 and the Challenge completed.

One of my friends, also on PC, was doing holiday hoarders and got stuck at 38/39 as well, except he had already opened the barge/sniper tower area, and at that point no remaining areas were visible.

Then I got the PS4 version, loaded up Holiday Hoarders, took a look at the map and counted every area. There were like 43-44 different undiscovered locations at the beginning, but as I did a couple of playthroughs/completed holiday hoarders/secret santa, suddenly I was stuck at 38/39 with no remaining locations. So several areas seemed to disappear or not check off in between runs. This time, however, I had opened the barge/sniper tower during one of my first playthroughs, so I couldn’t go back there to complete a last area. This seems to be the only consistency that I can account for with my PS4 run and my friend’s PC run: we both opened/discovered the barge/sniper tower area first before getting stuck at 38/39.

It may have also been related to holiday hoarders, because that was the first mission I tried on PS4 and friend tried on PC and they share the discover paris challenge with the main showstopper mission. Both my PS4 and Steam account have all of the hitman 1 and hitman 2 dlc/passes (my friend does as well).

So as of right now, my PS4 version is stuck at 38/39, friend’s Steam version is also stuck at 38/39. I also saw some other people on the steam forums and reddit mention they were also stuck at 38/39 with no remaining areas to unlock for legacy paris inside Hitman 2.

This bug aside, I LOVE this game! So much so I bought it on a second platform!

Thank you!


#2180

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#2181


Update to the floating magazine bug, now i just found out that the G1-4 Rifle has the same floating magazine bug, which is not attached to the rifle.
As stated before, the Shashka A33 rifle has the same bug, plus no sound effect when the enemy fires at you


#2182


Location:Miami, next to the musician who is under the overpass.
The coin is placed outside of the tipping hat. It would make more sense if the coin was inside the hat


#2183

Maybe someone tosses and missed (=


#2184

Bug: “No running on the tiles!” challenge ( https://www.youtube.com/watch?v=hGK59aI0kmw ) not properly unlocked in Hawke’s Bay.
Platform: PS4
Game version (from PS4 menu): 1.07
Description: when completing the No running on the tiles! challenge the game UI does not show the completed challenge, and checking the menu also shows it as not completed. However, if all other challenges have been completed the game unlocks the trophy for the completion of all challenges in Hawke’s Bay.
I guess the game does register the challenge as completed, and the problem is relaying this information on the UI.
I can show you some screenshots of the menu where the challenge is still marked as not completed, but I don’t think that would help.


#2186

You have to go all the way to the right and press D when you are at the most right item. It will go to page 2 and you can select it there


#2187

Thank you. UI so dumb.


#2188

thanks for the info on some of these bugs, very helpful moving forward


#2190

Isn’t it the right key to this door?
Which fits then?

#2191

On Xbox One X
I have completed all Mission Stories - Whittleton Creekof the mission stories on Another Life but the game hasn’t rewarded me with the Kalmer 1- Tranquilizer.
On the challenges menu it says I have completed 2/3 mission stories.


#2192

You need to complete the mission story you are missing step by step without doing other things to complete it. This only happens to some mission stories for example, Lights Out in Paris, you wont get the mission story challenge completed with exploding the light rig, you have to sabotage it with a crowbar.

Go to feats to find out which of the 3 mission stories you are missing in order to get the unlock then do that mission story step by step as the hints tell you to do.
Its either A dress To Die For, Picture Perfect or Broad Strokes

You can find a similar solved situation here


#2193

Bad translation for the italian version; it should say: “Un dispositivo esplosivo di medie dimensioni. Esplode quando il raggio laser viene interrotto. Fare attenzione nel posizionarlo.”


#2194

Bad translation for the italian version; it should say: “Un dispositivo ad impatto di medie dimensioni pensato per somigliare ad una paperella di gomma. Detonazione remota. Fare attenzione nel posizionarlo. Insospettisce chi lo nota.”


#2195

Hello please fix that ^^ héhé


#2196

When I place or throw a remote triggered explosive device, in around 50% of cases I have the trigger in my hand afterwards but there is no prompt to ignite the explose. I haven’t figured out what causes this, sometimes it acts normal, sometimes the option to trigger just is nonexistant.This does not get fixed by reselecting it after something else in the invenotry menu.

Happened on Napoleon Boomaparte, Various rubber ducks


#2197

Some triggers are bugged, when holstered they don’t appear in the inventory.