Official HITMAN 2 Bug Report Thread


#2384

In Hitman 2 Sapienza) After destroying the virus by increasing the temperature (all targets eliminated), 47 can get stuck blending in the showers and is unable to stop showering. This is on PS4 after the Winter Festival Update.

I know we all have our instances where we just don’t wanna get out of a hot shower, but this is a bit extreme, 47.


#2385

im not sure if this is a bug or technical issue. when im playing hitman 2 you know when two people are having a real interesting conversation? anyway, when i face them i can hear them loud and clear and i can see there conversation text. but when i turn my back to them there voices get lower and i really hate that. does this happen to anyone else can a hitman 2 pc steam player check when they get a chance on there pc? my audio on my pc is working just fine.


#2386

Think it’s supposed to work like that. Human hearing is fairly directional and this mimics the effect. I noticed something similar and that was my take on it.


#2387

You know that room where you hit the radio and she comes in to investigate? That’s how I got the challenge. I turned on the radio, she was alerted. I just stood there. She came in, saw me. I didn’t move and eventually the challenge popped up.

This video helped me:


#2389

Some audio bugs with missing sounds:

  1. No sound when stealth attacking with the Handyman Wrench.
  2. The Shashka A33H is silent when fired by NPCs.
  3. No music in Whittleton Creek during Contracts Mode.

#2390

I have completed everything for the secret achievement for Isle Of Sgail “Doing the Rounds” yet it never unlocks. I’ve completed it 3 separate times but nothing.

This is the Steam version too. I had an issue with Party Pooper but a restart fixed it so I hoped restarting this would fix it but after 2 more attempts; nothing.


#2391

This way I also passed, did not help (((((((((((:tired_face::tired_face::tired_face:


#2392

I was playing the mission “Landslide” in Sapienza and wasn’t able to obtain the car keys because the emetic poison wasn’t working on the chef/server. I can poison the bottle but when he interacts with it he picks up a 2nd bottle from inside the original. The duplicated bottle doesn’t allow the poison to work. This is frustrating because trying to get a faster SASO time by using the car exit.


#2393

Another bug I ran into in Sapienza on the mission “Landslide” is I can’t drag the stage crew guys into the dumpster where the “Stage Fried” mission story is revealed. 47 enters an animation to drag them but the bodies are stuck on the ground in one spot, not able to move them.


#2394

You can come across this bug in any location at any time.
47 attepts to grab the body’s hand but the same second he releases it and that’s it.
Sometimes it happens when he attepts to grab the leg, but not so often as the hand grabbing


#2395

I am aware of that bug, this one is different. With this bug 47 actually stays in the dragging animation but the body won’t move. 47’s arms go all over the place and I’ve only seen this bug in this spot at the dumpster. It happened multiple times, see for yourself.


#2396

In Bangkok, the note from Dexy Barat reads a different (and incorrect) description in the inventory menu:

It should read as the following text according to this dialogue:

“Basement linen room. Call me when you get there. Dexy Barat.”

Checked on PC.


#2397

Can we just talk about the colours and icons of the items and suits in the menus? Half of the black suits look blue, some of the items STILL don’t have their actual models, and some of the colours of the backgrounds for the items are off.

Plus, all of the Pills are facing different directions. IOI pls fix, make like emetic pills, 10/10 game is unplayable worst game 2014


#2398

I found the same problem. I think my solution was to inject him to get him to go and be sick, pretty sure that there’s a few seconds where all NPCs are looking the other way. I also have a vague memory of poisoning the bottle twice, either before he goes near it/them so whichever one he picks up works (less sure this is right, though) or after he drinks once (more sure that I tried this and it was successful).


#2399

I don’t hear explosions from mines, ducks and propane flasks anymore. I turned the “Music” to 0, maybe it is classified incorrectly. Might edit this post once I tested that.


#2400

Having problem with Photobomb challenge - it never pop-up even after I took all the steps to complete.

In this run I carried ICA remote explosive and followed the steps. Interview goes well but Novikov never gives me that challenge. I tried different bombs(C4, that bomb in attic), different detonation timing, and had no luck.


#2401

That is strange. Tried restarting your pc?


#2402

Hello!
first of all my english is not that good so im just saying. :grin: .

so, I played this game a lot of time (HITMAN 2) and a few days ago, before the new exclusive target came to the game (The Appraiser) I logged off and on the other day when it was suppose to come, i logged in and I could not log in to online mode . The message is : “CONNECTION FAILED (the title) Failed to fetch configuration from the HITMAN2 server (the text)”. I thought that it was server issues but ive seen people streaming the game on youtube so that was the time that I realized that It is a bug for only me. I dont know what to do, my internet works well on google, youtube, other games, etc. if someone can help me I would appreciate it. cant wait to play online again xD.
p.s. I play on PC (steam) and my username is " Thekingtal " and im from Israel (maybe it’s because where i am from i dont know).

thank you!
Tal


#2403

Can you access online features with other games in steam?


#2404

@Ibbe040 do you talk to me?