Official HITMAN 2 Bug Report Thread


#2509

Well, if you want to delve in the possible game logic, you could assume that because a Politician is in the area, all residential buildings from where an assassination might take place are accessible only to residents that have had a security check done on them and since the ICA has only recently rented the room, 47 has no access. Realistically, it’s likely been done to make the mission slightly more difficult.


#2510

For people that don’t get it, let me quickly explain with pictures.

Picture 1 You have a key to the apartment.

Picture 2 Building is locked in Landslide and requires a lockpick even though we have a key to the room.

Picture 3 This is considered a crime obviously even though you’re just entering the apartment that being rented by the ICA.

Picture 4 The apartment room itself is accessible with our key.

Picture 5 It is not considered trespassing to stay in this room, much like how it isn’t in World Of Tomorrow or to stay in 47’s hotel room in either Bangkok mission. This is because it’s being rented.

Picture 6 In The Author we do not have a key to the apartment because we’re not renting it.

Picture 7 In The Author we are trespassing because it isn’t 47’s room anymore. He isn’t renting it.

Why would an apartment building lock out a person staying there and force them to either illegally pick the lock or trespass and climb up a pipe? If they locked the door for security reasons (which they don’t in any other variant of Sapienza), surely they’d provide a key for the front gate. Apartment buildings don’t lock out paying residents from accessing the building itself.


#2511

Simple answer: He lost his building key. :laughing:


#2512

If you really want to get through that door without suspicion, then you can manually place a coin as close to it as possible. There’a a bug (or a feature? :stuck_out_tongue:) whereby NPCs open locked doors in the process of picking up the coin.


#2513

I know about the exploits but it’s still just weird. You can also pick the lock when no one is watching which is possible.

But imagine if the only way to get into your Bangkok room was to use a scrambler or to force an NPC inside and then follow them.


#2514

There are plenty of ways to unlock the door but that’s not point. 47 has an apartment key on him, apartment keys also works on ground floor entrances.

So if you would want to smuggle your lockpick, you wouldn’t be able to get it lol


#2515

Here’s another thing I’m not sure if it’s a bug or an oversight.

I was trying to draw some guards over to an area past this point where you can vault and (I’d presume) be hidden… Because I was spotted when I was already over the edge.

Edit: The same thing happened in Mumbai… But this was in the elevator shaft. I was hanging on the edge, but was spotted by the crew-member girl. Perhaps she spotted my fingers, and I guess that’d make sense for that… but it shouldn’t happen with the place in the pic I’ve attached.


#2516

Minor bug with the Quickdraw: it doesn’t seem to trigger the “Piano Man” challenge.

Did a Featured Contract on Marrakesh at night, the optional kill condition was Fiber Wire. I used the Quickdraw, because the standard wire is boring. The kill condition was met, but the Piano Man challenge didn’t ping – used the standard wire on second attempt, the challenge popped.

I’m guessing the problem is specific to the Quickdraw, because the measuring tape in Mumbai and the necklace on the Isle of Sgáil did complete the challenge.


#2517

I’ve only ever had the ‘Piano Man’ challenges pop by using the Fiber Wire; never any other strangulation device. I’ve always assumed that this is simply because the Fiber Wire is made out of a Piano string whereas the other devices aren’t.


#2518

is anyone else having the problem of not hearing explosions from bombs and also not hearing the gas station pumps explode in columbia? pc player on steam


#2520

Status goes from Compromised > Combat > Compromised > Searching…

Seems to be a bug with the compromise system.


#2521

Looks like latest nvidia driver (418.81) broke water again. Same happens in Hokkaido. What I find weird is that I didn’t encounter this bug at launch (when people reported it), only now. Tried veryfing files and it didn’t change anything.

Just noticed someone else also reported it and has the same driver :slight_smile:


#2522

Platform: PS4
Can’t progress the discovery challenge. As u see, my Nightcall Mastery level is already reached 5/5, but the discovery progress still stucked at ZERO. I have completed the game for many times, other challenges were doing fine except the discovery.
I also tried reinstall the whole game (with and without updates) and deleted all game saves, but nothing worked out, couldn’t trigger the discovery challenge either.


#2523

I’ve had this locked for 4 weeks, I’ve completed every single challenge on the game on every difficulty, and there hasn’t been any solution to it, I talked to WB Support for a whole week, and they just redirected me to IOI, I’d really like for this to be fixed, for it’s getting extremely frustrating. I’ve tried everything. I’ve copy pasted this from this this thread I made.


@Travis_IOI
@Clemens_IOI


#2524

I used all of the explosives in the game. Replanned multiple destinations multiple times. I used everything from the breaching charge to CX block. I tried placing the explosive on doors and in front of doors. I have used both normal explosives and concussive bombs. I have even tried multiple explosives like making stacks of propane tanks or fire extinguishers. Also am I the only one that has noticed fire extinguishers no long kill people? Did the devs change it to a concussive bomb?


#2525

Ive had 0 issues with explosives opening up doors.
You could be either placing the explosive wrong or its a door that can’t be blown up like certain keycard only doors.

Examples of blowing up a gate and door

Gate 2:00

Door 00.30

Fe is non-lethal and only knocks them out since launch


#2526

Before the upcoming Patch in February 8th, I want to remember the Developers that when the enemy fires with the Shashka A33 H, there’s NO Sound Effects, only bullet impact are heard. and there’s NO Sound Effect when you Stealth Attack enemies with the Wrench from Behind.
Please fix these Bugs as they honestly ruin my experience with the game. Thank you.


#2527

Genuine question: are you saying that you’ve been having the same problems with explosives not opening doors or that you haven’t been having that issue?


#2528

Yes, im missing explosion sounds in Mumbai esp those carts a the gas canisters, also other places w gas leaks & even cars if enjoy them instead of shooting the gas leak, it’s actually so irritating to the experience. The tiny bugs feel like death by a thousand cuts.


#2532

Wow. Good catch. I never would have noticed.