Official HITMAN 2 Bug Report Thread


#2898

I had this once in San . . . thingy (three-head serpent). Jess Franco was way off the map to the left.


#2899

Had a similar bug myself. Was doing the new challenges in Patient Zero/Hokkaido when I realized the reason I couldn’t find Klaus Liebleid was because he was off the map in the mountains in the distance.

EDIT: disguises aren’t bugged, just couldn’t find motorcyclist.


#2900

On the ‘Santa Fortuna’ mission, the Assassination challenge called ‘The Secret Ingredient’ cannot be completed due to a bug, at least I haven’t been able to. In order to complete the mission you need glue to fix the ‘cocaine bus souvenir’ that you poison and give to Jorge Franco. This cannot be done because you never actually receive it from the lady that gives you the glue. There is only an animation of her handing you the glue but it doesn’t appear in your inventory afterward. Here are images of the lady that’s supposed to give you the glue.


#2901

She hands over the glue to you but it doesn’t show up in the in-game inventory. It only shows up in the inventory tab

Did you get the glue and repair the bus, or did you think that since it didn’t show up in the in-game inventory that you didn’t have it.

If you picked it up and couldn’t select the glue when you pressed the prompt to repair then it’s bugged

There’s a mission story to follow, you can get another glue from a mechanic near gas station store.


#2902

I tried using the glue on the bus but it didn’t let me. I don’t recall it even showing up in the inventory menu, so it has to be a bug. I’ll try getting one from the mechanic. :thinking:


#2903

Updated to the latest version (Feb 27 2019). The progerss of unfinished map discovery has been reset to zero. But the previous discovered area before the update has not reset to “undiscovered”. That means I am unable to complete this discovery anymore. I believe this is a bug. My platform is PC. Thanks


#2904

Seems the Sniper updates…did nothing.


#2905

Another update, and still you CANNOT hear NPC’s firing at you using the Shashka A33 rifle. More and more disappointing, and people seems to find more and more bugs. And this is 90% a single player game, how is this possible? How can it be so broken, i expect this stuff from a Battlefield game.


#2906

This was posted in “Known Issue” in the Patch Notes. Hopefully they’ve fixed it with the next patch


#2907

Tuk-tuk exit in Bangkok does not work for
There is only the exit icon showing up when you repair it but there no button to select.
Tried in Club 27 & contracts mode, tried with both wrenches, tried after Ken looked at it.
There should be a grey exit showing before you repair it but that doesn’t appear in the screen.


#2908

Have the same issue on PS4. For instance, I’m at 48/52 on Discover Mumbai according to the map, but in the challenges menu I’m at 0/52. I went to one of the remaining 4 and it incremented to 1/52. I’ve visited locations I’ve already discovered and it isn’t popping for those.


#2909

Platform: Xbox
After the most recent update, all of the “Discover…” challenges have become broken. All of my current progress on them has been reset to 0. When I discovered a new location, it only registered as my first discovered location. However, since I can not rediscover locations, I will be not be able to complete the challenges. The ones that I have already completed have not been reset.


#2910

PS4:

Updated to 1.10 and now I have guards discovering bodies behind closed and locked doors. Happens during Club 47 in the little room connected by balcony to the lounge where the drummer waits. I knocked out the drummer and a guard in that room, and now security coming down the stairs outside the room spots the bodies through the closed and locked door and goes to investigate. This didn’t happen before the update.


#2911

Probably something like that happened? The author of this screenshot wrote that this happens when poisoning Robert with a Modern Emetic Syringe


#2912

Yeap, this exit was broken before patch as well.


#2913

Like others I am having issues with the discover [location] challenges. The only 2 locations I never completed this for were Mumbai and Santa Fortuna. Weirdly Mumbai reset the counter to 0 but Santa Fortuna doesn’t even have a counter.

@Travis_IOI @Clemens_IOI You guys need to get on top of this. This is the PC version on Steam.

EDIT: Apparently I hadn’t discovered all of Colorado as I was in the process of 100%ing the location pre-patch. I won’t post the screenshot but it too is like Mumbai and currently displays “0/21” even though it should be around 17-20.

20190228173610_1


#2914

I’m having issues with the Discover Mumbai challenge. Prior to this week’s patch I had been to most areas in Mumbai but not all (don’t know the x/52 number, I’m afraid, but it would certainly be at least 26/52 or higher). Then playing Mumbai last night I went to an area that I hadn’t previously visited (bathroom on the interior mezzanine floor above and overlooking the level housing the painter and his room in Dawood’s tower), and the Discover Mumbai challenge tracker popped up with progress of 1/52.

This would be no problem if the challenge was genuinely reset, but I am getting no Discover progress beyond 1/52 when visiting areas that I know I have been to before, so I fear that if I visit all my actual Undiscovered Areas the challenge progress might cap at, say, 13/52 and leave me unable to complete the challenge.

IOI please can you fix this?


#2915

Yeah–same here. Blargh…


#2916

Has Owen Cage always died when you inject him with emetic poison, or has it been broken at some point?


#2917

First time doing custom contract “Lost My Patients” since update. It has mandatory complications of things like no bodies found etc, and I completed the mission and exited, yet it still says body found, even though I completed the no bodies found complication… And yes, there was plenty of time between me getting the last accident kill and exiting the mission, 10 seconds or so.

ALSO as has been happening before the patch I was ‘compromised’ briefly by a target, who was alone with me and saw me aim a gun at them in the second before they died. And yet it says I am compromised in the end screen? I thought you guys were meant to have fixed this ages ago. It’s completely random, sometimes it won’t say you’re compromised if they see you kill them, sometimes it will. Annoying when I’m trying to speedrun my way up the leaderboard just for this to happen at the end :’(