Official HITMAN 2 Bug Report Thread


#2918

Okay, this is a bit of an odd one, and I’m fully aware that it’s incredibly niche, but when using analogue control via Xinput for movement and mouse control for camera, there’s some weird mouse acceleration stuff going on.

I recently got my grubby mitts on a Wooting Two keyboard, where the keys can act as analogue inputs. In most games I’ve tried it with so far, it works perfectly, with WASD providing analogue movement and the mouse moving the camera.

But Hitman 2, the game that would possibly benefit from this control method the most, has some weird mouse acceleration kick in when moving both 47 and the camera. It’s not unplayable, but it is jarring.

If you move the camera without moving 47, it’s fine, so I’m guessing the game’s making a very clear distinction between playing with a controller and playing with M&KB.

I’m not really holding out much hope for a fix, but figured that if the devs don’t know about it, then it’ll never get fixed :slight_smile:


#2919

Well I tried to reproduce MrFreeze’s sniper results…PS4 Latest Patch.

3/3: Carried out the briefcase: ! everywhere, shots fired.
3/3: Left the briefcase behind: Searching. Nobody panicked.

This would suggest maybe NPCs can see through the briefcase if it contains a suspicious weapon, after shots fired? Anyone who can try this on PC?


#2920

Hi, I came across a bug in Hawke’s Bay. The platform is PS4.

As there is a challenge for revealing all 6 undiscovered locations, the system only recorded one of those 6. Although all 6 have been revealed and labelled as their names, the challenge progress bar still shows 1/6. I heard you managed to fix the bug in the recent update, but it does not seem to work. Thus, I STRONGLY RECOMMEND TO DELETE SUCH CHALLENGES. They really make trophy-collecting players feel uncomfortable.

Hope you can give a response asap, thx!


#2921

for what it’s worth - I’m a trophy collecting player and it didn’t make me feel uncomfortable.

I also collected 500 bounties in Diablo 3 and it never once crossed my mind to go onto the internet and moan at blizzard to make the standard for completion easier.


#2922

As you can see here, the body of 47 is clipping through his suit. This happens on multiple maps (Isle of Sgail and Mumai so far) without any reason that I know of. You can see it while walking/running. When standing still you can’t see it.

Imgur

Imgur

Imgur

In these pictures here above, you can see the camera angle is way down when aiming down sight and stays ‘weird’ when Agent 47 just walks as you can see in the last picture. The camera is supposed to be higher. This happened when I was crouched moving by a body and picking stuff up all at the same time and trying to do it fast. Maybe because of that the camera glitched and stayed in this weird position.


#2923

I was missing just a few areas to achieve the challenge but now it’s just 3 out of 56. And no spots for undiscovered areas on the map.
Anyone with similar issues?


#2924

On the statistics menu, I don’t think the arrival section is supposed to be a mission, it looks weird just to have a non-mission here and displays a ‘non-completed’ status as there is no way to ‘complete’ it (no challenges).


#2925

Same thing happened to me yesterday after completing Isle of Sgail on SA: 0 points
PS: I’m on PS4


#2926

Oh, sorry for my bad wording. What I wanted to say is they did not fix it since the release of the game, even though in the newest update they did not completely fix the problem. Why not just remove the challenge to make the work easier. I DID NOT say revealing the undiscovered locations makes me uncomfortable.


#2927

Appreciate the updates, but noticed some new bugs with this latest update. The biggest one that I’ve seen is on Santa Fortuna (XBox One). Whenever I try and shoot a car battery to setup an electrocution kill for Andrea Martinez, it doesn’t work. Car battery remains to be dead.

This is set up in a water puddle on Andrea’s route to the statue from her “base” (example: See CJ’s run for Santa Fortuna).

That said, I must imagine this is true for PS4 and PC as well. Car batteries in general have been buggy in this game (see my previous video on Whittleton Creek: https://www.youtube.com/watch?v=Y8lzzUFvju8 where the same thing occurs)


#2928

We don’t talk about making something easier.
Players, who open whole map, can’t get challenge they deserve, becaurce it is broken.
Dev’s promised fix, but they just broke it more.
So, if they cant fix this bug for 3 months, it will be better to remove such challenges from game.


#2931

Did you shoot the target in the face?
Because when you kill a target from the front with a close range headshot you get compromised, noticed kill (!) and body found (!).
This bug is in the game since release: https://youtu.be/DPmgZO7eD_k?t=3m59s


#2932

Since the game only allows up to 299 real NPCs in the game, fake NPCs that are extremely limited in capability are often used to make sure areas like populous plazas aren’t deserted, because the real NPCs are usually spread around the map (since the maps are so large, and there needs to be a challenge.) When using your instinct thingy, (ctrl) real NPCs will be highlighted. If you still want to avoid this issue, places like Whittleton Creek and Hawke’s Bay don’t have any fake NPCs!


#2933

This is mostly unrelated, but one time when that specific guard was attacking me he was using the American voice lines. Was a bit surreal.


#2934

This is happening to me as well. I was up to 50 or 51 places discovered. I discovered a new place (Train yard building roof in case that matters to the devs) and my counter reset to 1. But I can’t redo the places I had already found, since they don’t show up as undiscovered anymore. This happened to me prior to this newest patch


#2935


https://www.ioi.dk/hitman-2-february-update/


#2936

I am on the PC version of the game.

I have tried to get the sniper assassin challenge on master difficulty in Mumbai multiple times now and even got silent assassin rating last night using a sniper rifle. Every time I finish the level the sniper assassin challenge does not trigger. I check off all the boxes required but it does not trigger. I have tried different approaches and even completed it in one complete run without loading from a save. I seem to remember mention that sometimes reloading from a save can prevent some challenges from triggering. I don’t know if this is a bug but it sure seems like it.

Follow up: I completed sniper assassin using the same tactics as before, but I had to wear a disguise other than the suit for each kill. If I did not use a disguise for each kill the challenge did not complete.


#2937

So I was playing on xbox on mumbai, and when I started on the train my legs where being stretched out of existence and they stayed like that for the whole playthrough. I guess all that crouching morphed his legs


#2938

Ps4 Pro (1.10)
Hawkes Bay.The infamous floating bug is back :stuck_out_tongue: Orson tries to impress Alma!!


#2939

The house’s AI is doing that. It just doesn’t like guests … :slight_smile: