Official HITMAN 2 Bug Report Thread


#2961

I have same Water Texture Blinking problem with Nvidia GTX 780 Ti. Issue started when I updated to latest drivers to re-enable Shadowplay.


#2962

Probably done on purpose since they are not physically a piano wire whereas the Fiber Wire is.


#2963

I already posted a comment about this bug, I’m adding a screenshot of the debriefing.
I killed 3 targets in Mumbai with Sieger 300 ghost, i did it suit only and silent assassin in master difficulty.
And I still didn’t unlock sniper assassin…
I’m experiencing this bug for months.
I’m playing on PC (steam)

EDIT : I added 3 answers below which give more explanations and how i bypassed the bug.
If you’re experiencing this bug, check @clckr’s advice and @Hatch’s answer too.


#2964

They died from a sniper bullet right? It doesn’t count otherwise, it has to be from the bullet

Post an image of the detailed xp


#2965

Yes, headshot on everyone. For now, I don’t have any issues in other location to get sniper assassin challenge except in Mumbai
In hitman 2, i got sniper challenge in every location except Mumbai (bug) and the last one (didn’t do it yet)

I’ll do another run again to post the detail, i was pissed off so i closed the game after i did this screenshot


#2966

In Patient Zero, while holding the Door Scrambler, it became activated and visible a foot or so from 47’s hands, and remained so even when 47 was holding something else.


#2967

@Ghrifter
Try the following:
Do your (silent) sniper assassin run but before you exit the mission safe the game.
Exit mission. If you don’t get sniper assassin, reload the safe and exit again.
This worked for me in one mission where the game didn’t give me sniper assassin.


#2968

You are right. I found that I haven’t unlock the Mission Stories-Bangkok. Thank you.


#2969

The game seems to have a weird issue on the Destinations tab where the location progress that shows the number of total challenges in the location is just wrong for those that have multiple missions.

ie Hokkaido has 84 challenges in Situs Inversus and 19 in Patient Zero, which totals 103. Not 102 that the game displays in this tab.


#2970


#2971

If you take the butcher’s clothes in Sapienza, you’re considered trespassing… in your own shop…


#2972

Last mission suit with the mask, the shirt clips constantly through the jacket.

In whittleton creek is almost impossible to do a fire hydrant + car battery kill. The “hitbox” of the water is very small, even tho it seems larger.

Suppressed SVD in mumbai, if you pick it up, the silencer will be on the magazine.

Some times when reloading the weapon, the magazine wont appear at all. Some dropped weapons dont have a magazine either.


#2973

I’m finding that using keycards (in-level item, not the Disposable Scramblers or Electronic Hackers) is counted as an Illegal Action even when wearing a disguise that would normally be allowed to use it. Examples are the Pit Garage doors in Miami (when wearing the appropriate mechanic outfit) and the keycard door to the room where the Painter waits in Mumbai when wearing either a Local Security or Bollywood Bodyguard disguise.

This has pretty much killed keycards for me as a tool to use in a level and I’m sure this isn’t intended behaviour, so reporting as a bug.


#2974

@clckr
Thanks for your advice, I finally got sniper challenge.
You gave me a good lead on the way to solve my problem.

For any reason, if i was saving the game during this mission, before killing any target or after killing 1 or 2, it locked the challenge.
Same if any corpse or stunned ennemies was spotted, which it isn’t supposed to do.
I had to hard try the level (like speedrunners do) and clear it Silent Assassin Suit Only without saving, which is kinda hard and frustrating in master difficulty.

I just did master sniper assassin challenge in Isle of Sgail without any troubles, i saved between killing both targets, I got spotted once or twice after I saved. I reloaded the game and it worked as intended and unlocked it.

Master sniper challenge worked fine in every location of hitman 2 except in Mumbai. There’s a big problem in Mumbai’s sniper assassin challenge.


#2975

not only yukata have this problem, but sgail suit too (white shirt is going through suit)


#2976

Press disguise is bugged too in ghost mode.


#2977

Did anyone get ‘suspicious’ of you? If so, it won’t affect your rating on the end screen but it does negate the ‘spotted’ requirement for SNIPER Assassin. Showing us the briefing screen and that you got Silent Assassin doesn’t mean anything at the moment because the game is broken.

Also, you don’t need to bother doing suit only and silent assassin for sniper assassin, you are putting way more effort in than is actually required. (that’s fine if you want to make it more challenging) but it’s not part of the challenge requirements and you’ll often find it takes a lot longer to SA/SO/sniper assassin than it does to SA/SO and sniper assassin challenges separately.


#2978

The No Running On The Tiles! Challenge in Hawke’s Bay is currently bugged on Xbox One in which it won’t come up completed.

NOTE: It is still possible to get the Completionist achievement for the level.


#2979

If someone become suspicious, i restart or reload the game because i know i can’t get sniper assassin.
I restart/reload any mission if i get any yellow message above the map while i’m doing SA/SO or sniper, except corpse found for sniper. By the way, I think “suspicious” negates SA achievements too even if it tells you at the end that you’re a silent assassin. Well at least, it was the case in Hitman Absolution, so i don’t waste my time to complete a run if i see “suspicious” or anything else.

As far as i remember, in Absolution we had to do a very clean run to unlock some achievements in the hardest difficulty mode. So i kept playing that way in Hitman 1 & 2.
Like i said, i was playing like i did in every other location and i couldn’t unlock sniper assassin only in Mumbai. I did more than 30 runs, trying many things.
And the only way i found to bypass this bug was to clear Mumbai’s mission SA/SO/Sniper w/o saving. Because if they found a dead body or even if i reloaded a safe save, it was locking the challenge. Looks like, it doesn’t reset spotted status after i reload Mumbai.
In other locations, i hadn’t to bother to do everything at once, because it wasn’t broken.

If i was the only one who had this problem, i would wonder what i was doing wrong. It’s a known bug for months and many people experienced this bug in different way. I found several thread on different forums that report this issue. Even in this post you can find some people reporting this bug in january or something like that.


#2980

This was recorded a day or two before the 2.14 update, pretty funny glitch