Official HITMAN 2 Bug Report Thread


#2981

#2982

Its not a bug but i wonder why the doors don’t stay open/closed! I found this extremely annoying in Season 1 and I don’t understand why they didnt change it in season 2. A door that closes without anyone touching it really ruins the atmosphere sometimes and it’s quite annoying when you try to distract or observe someone through an open door.


#2983

Gas canister message is not accurate while holding a wrench if you are even slightly misaligned.

One step away from the canister it says you are missing a wrench (while holding it). One step closer and you can use the wrench on the canister.

It says missing wrench even though I’m holding it:

One step closer and it works:

Location: Colorado (freedom fighters), related challenge: chemical warfare

Platform: PC (windows 10, steam)


#2984

The bug seems to be fixed. The chanllenge is accomplished


#2986

I just played Miami, and unlock a door using a keycard is always considered an illegal action. Am I the only one?


#2987

Are you in the correct costume? A waiter shouldn’t be able to unlock the red pit garage but a red mechanic should. I believe the yellow mechanic can not even unlock the red pit garage.


#2988

In PZ Hokkaido I got the impression that killing virus bloke with a lethal syringe gives “body found” and loses SA. Anyone else finding this?


#2989

Why would it be like that? Was that the case in H2016?
I never finished the mission by lethal poison on him so I don’t know but I don’t see why it shouldn’t get you SA


#2990

Agent 47 keeps on walking in situations in which he shouldn’t. This happens either crouched or stood up.
When he’s coverred he should stay covered but when he’s walking on his own it’s not that stealthy …
How to reproduce:

stay still, look straight ahead
now turn right by a simple move of the LS into the right direction
after some short moves of the stick agent keeps on walking to the right until reaching an obstacle, but he would move until reaching Australia (if you start on New Zealand :-)) or leaving the mission area
the main problem: agent keeps moving even while aiming at a target!! And this one is really bad

I think it’s a camera movement problem, because he keeps moving if there’s enough space to move and stops if I turn the camera far enough to let him hit an obstacle. However, if I turn the camera to give him space to move he’ll move on in that direction (mainly to the right side), this is really annyoing if your are hidden.


#2991

Thanks. I am fairly certain of this issue and of course I don’t see why it shouldn’t be SA either. I had 47 quite close to various people but didn’t get any illegal action spots or whatnot. After I ran off and as I was holding “Y” to exit I noticed “body found” and in the final screen I’d lost the “no bodies found” star. I altered the plan to slow down one person and KO another and got five stars and did it again with a lost SA star by . . . I think I forgot to do the extras or I thought I’d found yet another way of avoiding losing SA. It wasn’t entirely clear when the offending problem occurred, though, I couldn’t pinpoint it. There was one KO’d body to find elsewhere, one of the guards by the helicopter pad (unsurprisingly), but I cannot believe it’s that one as that’s never been found in the, um, several attempts I’ve made at getting a half-decent time. I’m sure it’s virus bloke that is found.

I’ll also add that I’ve occasionally had non-SA poison runs in various levels that have confused me but it’s been erratic. This one seemed clearer-cut.

I wonder if the spotting issues discussed at length elsewhere might come into it, I suppose; a while ago I noted that some guards start to home in on 47/the dead body as soon as the kill occurs even if they are outside the room and can’t see anything. That and this 20-second sniper kill thing, maybe there’s more to spotting and the timing of it all than is currently apparent. That’s speculation, of course.


#2992

Mumbai glitch following the 2.14 update, NPCs going ??? for no reason


#2993

Yes. I am in the correct costume. I’m in the red mechanic unlocking the red pit and I was spotted as suspicious by the security guard at the staircase. Also, in the Korstant building, I’m disguise as the suit bodyguard and I was spotted as suspicious immediately by other bodyguard(who’s not an enforcer) when unlocking using keycard at the room leading to the bridge above the race track.


#2994

Also, usually there’s an option to choose which card to use to unlock. But this time there is no option and it shows as an illegal action (a ! sign) if unlock.


#2996

I have that glitch, too on a XB1 latest patch. Not a controller issue, as HM2 is the only game with that issue …


#2997

I’m also getting the “Using the right keycard in the right diguise is considered an illegal action” bug, reported in my post above (Official HITMAN 2 Bug Report Thread), experienced in Miami and Mumbai so far. One for the list, please, IOI.


#2998

I had this happen to me the other day, as well, hadn’t experienced it until the recent update.

Also, another bug for me that I have complained about since day one of Hitman 2 that still isn’t fixed: the PiP window. What good is it if most of the time it reveals a found body, the camera is completely distorted and pointed up through the ground? It doesn’t tell me where the body is at all when it’s that buggy, makes the whole feature useless.


#2999

Just tested it and this bug also happens on Bangkok, Marrakesh, and Colombia. I’m guessing pretty much any map with keycard locked doors is gonna have this problem.


#3000

These are bugs I’ve been having since the February 2019 update. All of these have been on Xbox One X.

Hokkaido - Morgue Start on Master Level is still bugged. It worked the first time I entered the level but I got spotted while getting off the morgue table. When I restarted I was then instantly spotted just like before the update. (Automatically standing). This also happened when I went back into Re-plan and started again from there.

Paris - Unable to pick up Bust on shelf in room with big Vase (next to lockdown room).

Mumbai - Unable to pick up Rake in east end of the Train Yard (near sewers).

Mumbai - Sniper Assassin Classic Challenge Bugged? I wasn’t so sure before but I’m almost positive this challenge inst registering for me (playing on Master for it). Before the update I did this challenge the ‘easy’ way multiple times. (knockout and closeup sniper shot). I was still rusty on this level then so I came back now after the update and I just did it a more legit way. (shot Vanya Saha from the highest rafters while she was meditating in pool area, then took out Mealstrom and Rangan as they were meeting on the barge). At the end of my mission the stats said I was never compromised or noticed with no extra kills. (although I was getting shot at as i left the scene, thought that wasn’t supposed to happen instantly anymore). This is the last challenge I need for Classics 2 and its getting frustrating running it over and over just wondering if I’m wasting my time.


#3001

Landslide (PC)
There are TWO water bottles on top of each other, so you try to poison it but he pulls out a magical clean one and doesn’t get poisoned… it’s ruined a contract I was going to make, and makes it impossible to get the key to car escape off this guy while maintaining Silent Assassin.


#3002

Also, specifically today on PC, the game has crashed to the desktop twice, and frozen my entire computer (Hard reset required). This sort of thing used to happen for me in 2016, but hadn’t happened in H2. Can’t see any way my PC is different than a week ago, so I’m pondering it may be related to the patch.

Update: All the crashes were while I was doing contract mode on Landslide. I’ve just spoken to someone who recreated it on Xbox for me, and they said it also crashed for them playing the same (recreated) contract