Official HITMAN 2 Bug Report Thread


#3026

From my experience it does work, it’s just difficult to notice because the effect is so subtle. Make sure you are standing still and aiming when you start holding shift and you’ll see the gap in the crosshairs shrink and almost entirely disappear. It makes all the difference if you are trying to shoot heads or cameras from a distance, for example.


#3027

As of late! I’ve noticed a crashing bug with Hitman 2 on Xbox One. It’ll freeze then ultimately crash game. Or while I was playing Sniper Assassin The Last Yardbird it did the same thing. I shot an NPC and game froze then just up and crashed. Another time I was playing Whittleton Creek and was hoping over a fence then the game froze up and crashes. It’s happened about 3 times since the most recent patch/update.


#3028

c0000005 crash partially fixed (pc)? We know Hitman 2 has the problem that the longer you play a level, the more NPCs unconscious on the map, the less stable your save is. Especially when you pass three hour playtime mark, your save will crash once loaded. Despite there is any mention of c0000005 crash fix in the previous patches, I tried to load an old save (the unstable save with a three hour playtime and always crashes a few seconds after loading today, I was so happy that I could keep playing the save. I thought the issue was resolved. However, the save starts to crash after another hour of investment into the save. This time, the saves seems to crash during the loading screen instead of freezing and crashing a few seconds after loading is complete. Obviously, devs managed to delayed c0000005 crash, there is something can be done about the issue. Please devs, any update?

Description
Faulting Application Path: E:\gtav\steamapps\common\HITMAN2\Retail\HITMAN2.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: hitman2.exe
Application Version: 2.14.0.0
Application Timestamp: 5c7cf93c
Fault Module Name: hitman2.exe
Fault Module Version: 2.14.0.0
Fault Module Timestamp: 5c7cf93c
Exception Code: c0000005
Exception Offset: 0000000000c7d3d5
OS Version: 10.0.17763.2.0.0.768.101
Locale ID: 1033
Additional Information 1: 7a71
Additional Information 2: 7a7183cd15231646ede8f7d0738d356f
Additional Information 3: 9c55
Additional Information 4: 9c557d2caffe237c37258e094c7b4e2c

Extra information about the problem
Bucket ID: 3beaf6a5c4edd2a5bc60d6bf674f2948 (2044870348386543944)


#3029

We already have an ongoing thread about crashes.

For that reason I have also closed the topic you just created regarding this. Please use that thread to discuss crash related problems :slight_smile:


#3030

PC/Steam

Playing a contract to get the electrocution kills for Marakesh. Anyway, this target would NOT move (that seems to happen a lot – a target or npc will go to the market and stay there for an indefinite amount of time, like they’re caught in a loop… but anyway). Since I couldn’t get the target to move - I tried killing her with a PT explosion (just so I could leave the stage). She didn’t die, but the crowd you see in the screenshot formed a circle around one of the bodies - and they all had ‘?’ marks over their heads.

This next screenshot is another contract. ‘Bells are ringing’ (I think it was). All targets were to be killed via accident/falling object. I got all targets under the church bell, detonated a breaching charge to the bell rope-winch, and all targets were killed at the same time. But the screen-shot claims otherwise. Perhaps the bell falling isn’t counting as a falling object…?


#3031

20190307183815_1

Beautiful dress, 47.

Ghost mode is still affected by the clothing issues, even after the minor update on March 6.


#3032

The Shaman Powder is a good tool. But why does it make so much noise…?
Please make this silent…
All NPC’s hear this and come to this point. A noise C4 MK2 = Powder - really?
Please see Test from Link:

Please fix this… Thanks
Bye Ric


#3033

Platform: Xbox One

Explosive Liaisons challenge is impossible to complete on Xbox One. Every time I try to complete it, I am unable to pick up the letter. Without the letter, it will not let me call Robert Knox. I have tried moving the camera around, standing up/crouching, different costumes, listening to the entire interrogation conversation, breaking open the safe, using the combo, and different difficulties. Basically, I have tried every combination of events that I can. No matter what I try, I can’t pick up the letter. Is there any way to fix this?


#3034

I’m also playing it on Xbox. There was a problem that 47 was only able to pick up the letter from a fresh start of the level, ie, after loading a saved game it was not possible to pick it up. Is that what’s going on? I have half a memory that this was supposed to be fixed but am not sure.

There was also a gun in Hawke’s Bay and some baseball stuff in Whittleton Creek that could not be picked up. Thinks some others note similar in Isle of Sgàil. I haven’t tried to pick up any of those things for a while, though.


#3035

Sgail:
Knock out both targets, get their kill switches.
Then knock out the Constant. A guard wakes him up and he escapes.
You have 5 minutes to take out the twins before they use the kill switch, but you fail the mission even though both twins dont have a kill switch, and even if you knock them out again.


#3036

Knocked out Zoe and threw her off the edge into the water, but she survives


#3037

NPC compromised me through a staircase in Sgail



#3038

That reminds me… In Rangan Tower, in the bathroom that is on the 3rd or 4th floor, if you subdue anyone in there, you seem to always get spotted by the guard that is outside the room w/ the painter. I know there is part transparent glass, part opaque/frosted glass… And most of the opaque glass is towards the bottom… Anyway, it doesn’t seem like you should get spotted in there, especially from someone that is below what should be line-of-sight.


#3039

In Bangkok - The Source at the outside bar, far right side, there are two beer bottles glitched into each other, while there should only be one.


#3040

Sniping from Hokkaido roof as Ninja puts you into combat every time, even though no one saw you up there.


#3041

That’s not my experience. I found sticking to the side of the toilet away from the window is okay. Turn on the tap there, subdue there was repeatedly okay. Putting a body in the cupboard was okay more than once and involved doing holding the button when as far away from the window as possible. I presume “Master” is more challenging, not done that area on Master.


#3042

Do you mean the same as the one in “Landslide” for the bloke that has the car key? If so it does work, I think, just needs two poison doses and a second cycle of the drinking.


#3043

PS4 Hitman 2
“Switcheroo” feat doesn’t work, I did everything as mr. Freeze in video on youtube. I cant place apricot on place where was necklace.

Mumbai, starting location “train” suit “absolution suit”


#3044

Yeah, clothing glitch is still here


#3045

This one is very annoying since it fucks up my speedrun strat