Official HITMAN 2 Bug Report Thread


#1173

I searched but didn’t find anyone else logging this one -
Xbox One X, Legacy Sapienza.
I was trying to do the cannon challenges, and blow up Caruso’s plane. I tried three times to trigger his evacuation from the Ruins, with my sniper rifle.
All three times the alert happened, the guards started running around and Caruso began his run downstairs, only to stop (at a door, maybe?), and then turn around and go back to his usual route.
i can’t quite figure out exactly what stopped him but it was behind the cliffs of to the left-hand side of my view.
I assume this is a bug? Has anyone else triggered his plane evacuation with a few sniper shots, or do I have to go and set off a fire alarm or something?


#1174

Water still has a problem with displaying. You can check my drivers.


#1175

NPCs sitting into each other. This is in Rangan’s office.


#1176

XBox One, Showstopper. I went to show my invitation to the bodyguards and it wouldn’t “process” the invitation. The prompt stayed on my screen no matter where I went on the map. Reloading fixed it.


#1177

@Stuartshaycarey same here strange I’m on latest version and this bug still exists (not occured in Hitman 1 but 2 only!)


#1178

Almost every time I start in the morgue in Hokkaido, 47 is standing and blowing his cover (as a corpse). It’s too unreliable that I can never use this start. It makes my SOSA runs ruined from the start. It even happens when I touch absolutely no buttons.

I’m playing on Steam.


#1179

just to add one more to the incredibly exciting list - in Miami ‘aquarium’ is misspelled as ‘acquarium’ both on the map and in the ‘area discovered’ message :woman_shrugging:


#1180

game crashes with 0xc0000005 if it’s loaded from a save game that has chalked up many hours of play (hence world change or knocked out bodies). I’ve the save game where it’s completely reproducible. Since all our stuff is clouded, I can point you to which one if you want to troubleshoot. Just pm me.


#1181

So, I recently ordered the GOTY edition for Hitman 2, and the author has way to many issues on the PC. While I could mention these issues there is one in particular that is very annoying. So, the challenge the “The Gravedigger” is literally impossible to do because once you drag the target to the grave to dump him the game decides to kill thae target before you can even dump him. I tried so many times to do this, but this one annoying bug makes it impossible to do. Please fix this as soon as possible


#1182

The PiP window is almost always broken for me when it comes to bodies being found - it focuses on the body upside down, so in essence, it’s actually just showing me under the map where the body is lying and I have no clue whatsoever which body was found.


#1183

Miami - You can’t open the outside THWACK garage door with a keycard. You can swipe it, but the door doesn’t unlock.


#1184

Isn’t Gravedigger challenge to kill your target in crypt (where they are doing photoshoot) and then drop his dead body into grave?


#1186

Platform: PC.
Mode: Contracts.
Location: Mumbai.
Issue: Non-functional exit due to Complication.
Severity: High (causes uncompleteable contracts).

Description

There are two exits on Mumbai which allow the player to exit via the streets, one near the default start location and another down the street near Rangan’s tower. These exits work “automatically” by just getting close to them. These exits normally work fine in Contracts Mode, but do not work if either is set as the Required Exit via Complication. In creation mode, the automatic exit feature is disabled and the exit must be done via prompt; in actual play, however, the prompt does not appear and the automatic exit feature remains disabled. This causes the contract to be impossible to complete and to display no exit after contract conditions are met.

I created two example contracts that demonstrate this. I was easily able to exit in creation mode, but the contracts are seemingly impossible to complete once actually played normally.


#1187

Hopefully you guys are able to fix the lighting in the Legacy maps… It’s like all the color was sucked out. Also please remove the letterbox, it doesn’t look good.


#1188

I guess this is more of a known issue from Season 1 than a bug: You can’t use an emetic syringe on someone if they are on stairs and you are following behind and below them. You will do a loud close quarters punch even if you get the prompt for a silent attack. This feels like an animation/engine limitation rather than a deliberate design decision. I get why from an animation standpoint you wouldn’t be able to choke someone out or even conk their head if you’re not level with them, but 47 already picks things up and opens doors by vaguely waving his hand in the air, there can be a similar animation for the syringe so at very least the world’s greatest assassin isn’t stymied by a set of stairs.


#1189

I’m fine with most changes, I agree Sapienza looks a little too dark but it’s the only one that really bugs me. But whatever you do IOI, please don’t revert Colorado back to the pink, it looks so much nicer now.

Also if you don’t revert the sky in The Source, can you at least update the menu. They look very different.


#1190

In Mumbai, the fireaxe next to the elevator shaft across from the security office in Dawood Rangan’s tower is inaccessible. There’s no prompt to open the case even though the fireaxe inside is highlighted as an interactive item in instinct mode.

Update: I restarted the mission and the prompt to open the case is there. Either I somehow missed the prompt even though I ran back and forth in front of the fireaxe case multiple times, or there is a bug with prompts intermittently not showing up, as I have had prompts for switching disguises with bodies inside not show up in at least two closets (Santa Fortuna and Bangkok), which I have already reported as bugs.

Windows 10 x64.


#1191

This is a big one, often (but not every time) that I change the sauna temperature in Hokkaido, it now kills the 2 guys inside it, the best way to prevent this is to hold the door open. However when Yuki goes in, she dies quickly and it won’t reward me with the challenge for her dying in it. I’ve tried this multiple times and I still don’t have the challenge.

Playing on PC and I was doing this on master difficulty, not sure if it is the same on other difficulties.

20181129124841_1


#1192

I’m on PS4 and when I choose the Kalmer1 (tranqilizer pistol) on my loadout, save progress, use it afterwards and then reload that save, I’m missing one tranquilizing round. it has happened to me in a couple of levels, such as Hawke’s Bay and Bangkok.


#1193

Robots don’t see sunglasses.

Also, I really think this patch broke something in the results screen, or the game itself. Others have been reporting false scores and point deductions. Here’s one I just got after playing a contract in Miami.


I know for a fact that I deleted the recordings, as that’s the last thing I did before exiting the level. The only people who “saw me” were the targets, but that was just a second before getting shot in the face or blown up by accident.